0% found this document useful (0 votes)
31 views

Assignment 4 (1)

The document outlines the design and simulation of a 100 Mbps Ethernet LAN using CISCO Packet Tracer, featuring two 24-port switches and 20 PCs, each with class C IP addresses. It details the configuration of DNS, FTP, HTTP, and a mail server, as well as router setup to connect the two LANs. The successful PDU checks and configurations demonstrate the network's functionality and connectivity between devices.

Uploaded by

roshanaisu1
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
31 views

Assignment 4 (1)

The document outlines the design and simulation of a 100 Mbps Ethernet LAN using CISCO Packet Tracer, featuring two 24-port switches and 20 PCs, each with class C IP addresses. It details the configuration of DNS, FTP, HTTP, and a mail server, as well as router setup to connect the two LANs. The successful PDU checks and configurations demonstrate the network's functionality and connectivity between devices.

Uploaded by

roshanaisu1
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 8

Assignment 4

Problem Statement: Configuration & Simulation using CISCO Packet Tracer : Design & develop a
network topology of 100 mbps fast Ethernet LAN having two(2) 24-port switches. Each of the
switches is connected with a disjoint set of 10 nodes/PCs configured with class C IP
address(192.168.4.41-60). Also add PDU to check ping, implementing simulation using CISCO
Packet Tracer. Configuration of router and configuration of DNS, FTP, HTTP, Mail server.

The above simulation in CISCO Packet Tracer:

The above configuration has: [Note: all the wire connections are straight-through cable]
1 Switch1(2950-24) 12 PC12(192.168.4.50)
2 Switch2(2950-24) 13 PC13(192.168.4.51)
3 PC3(192.168.4.41) 14 PC14(192.168.4.52)
4 PC4(192.168.4.42) 15 PC15(192.168.4.53)
5 PC5(192.168.4.43) 16 PC16(192.168.4.54)
6 PC6(192.168.4.44) 17 PC17(192.168.4.55)
7 PC7(192.168.4.45) 18 PC18(192.168.4.56)
8 PC8(192.168.4.46) 19 PC19(192.168.4.57)
9 PC9(192.168.4.47) 20 PC20(192.168.4.58)
10 PC10(192.168.4.48) 21 PC21(192.168.4.59)
11 PC11(192.168.4.49) 22 PC22(192.168.4.60)

PDU checking to check ping:

As we can see the PDU checking in respective LAN1(in blue) and LAN2(in green) are successful
which suggests that individually both the LANs are connected to the switch successfully.
Configuration of DNS
Now in the LAN1(blue) we need a server, to configure the DNS, connecting a server to the LAN. Set
the IP address of the server and the DNS server same (192.168.4.40). Then click on the server go
to servicesselect DNS, then create a domain web address e.g. (www.cse_ds.com). And set the
address same as DNS server. And then activate the DNS server.

Now we use a client PC in LAN1 to check whether the configuration is successful or not. First we
need to add DNS server in the client PC. Then click on the client PC go to desktop go to web
browser and search for www.cse_ds.com . It will show a webpage of CISCO Packet Tracer.

Configuration of Router

As we can see when we are trying to ping from LAN1 to LAN2, the transfer is failed, because the
switch is a layer 2 device (Data-link layer), it only connects multiple devices in a single LAN. Here
comes the concept of router.
Router is a layer 3 device (Network layer), it connects two or more LAN’s, here we will use a router in
between the switches. Since we are connecting two LANs default gateway for both the LANs are
required, its works as an entrance key for each of the LANs and we need to configure the ports of the
router where these gateways are required. We need to configure the router manually using the CLI.
the following code is to be written in the CLI of the router.
Router>enable
Router#configure terminal
Router(config)#interface FastEthernet0/1
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#ip helper-address 192.168.3.5
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.4.1 255.255.255.0
Router(config-if)#ip helper-address 192.168.3.5
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#end
Router#write memory

Now click on the server & set the default gateway, here we can set the default gateway that is LAN 1
default gateway because server available in LAN 1 network. (The above diagram)

Now we can see that a client pc in LAN 2 can access the DHCP server and take the connection successfully . In this way
we see that the router configuration is successful

For LAN 1 For LAN 2


Configuration of FTP

FTP(File Transfer Protocol) . FTP is a standard network protocol used to transfer files between a
client and a server on a computer network. We need to configure the FTP server. Select the
servergo to servicesselect FTPnow there add user with username(admin) and
password(admin@123) and give all the permissions(write,read,delete,rename,list). Then add the
user. After that select a client PC that is connected to the FTP server and then ping to check its
connection to the server . Then go to the PC desktopselect text editorsave a file named name.txt
with contents. Now go to the command prompt of the PC and write ftp 192.168.4.40 then give the
username and password write put name.txt to upload the file to the ftp server, it will show transfer
complete to check, write dir then it will show the directory of the all the files in the server , and we
will find the file in the directory.
Configuration of Mail Server

Mail server is an application that manages the sending and receiving of emails. It works behind the
scenes to ensure that emails are delivered to the correct recipients and are accessible when users
check their inboxes. Here we will configure the mail server, first go to the services of serverselect
email set the domain name e.g.(www.cseds.edu.in)  create two users with username and
password then click on the ‘+’ button to add the users. Check the SMTP and POP3 options are ON.

Now go to a client PC and naviagte to desktop select email configure the mail with all the
necessary informations and credentials then compose an email from user1 to user2 using the
domain name e.g.([email protected]).
Configuration of HTTP

HTTP (Hypertext Transfer Protocol) is the foundation of data communication on the web. It is a
protocol used for transmitting hypertext (such as web pages) between web servers and web
browsers.To configure HTTP/HTTPS server need to activate the option in server services which is
already configured in default and shows the default webpage of cisco packet tracer sample, I have
modified it to include some changes shown below.

You might also like