Cisco IOS Control Commands
Cisco IOS Control Commands
Command Description
Moves a user from user exec mode into Privileged
enable EXEC mode. Privileged exec mode is indicated by
the # symbol in the command prompt.
configure terminal Logs the user into Global Configuration mode
Enters interface configuration mode for the
interface fastethernet/number
specified fast ethernet interface
DHCP Commands
ip address dhcp Acquires an IP address on an interface via DHCP
Used to configure a DHCP address pool on a
ip dhcp pool name DHCP server and enter DHCP pool configuration
mode
domain-name domain Specifies the domain name for a DHCP client
Configures the network number and mask for a
network network-number [mask] DHCP address pool primary or secondary subnet
on a Cisco IOS DHCP server
ip dhcp excluded-address ip-address [last- Specifies IP addresses that a DHCP server should
ip-address] not assign to DHCP clients
Enables forwarding of UDP broadcasts, including
ip helper-address address
BOOTP, received on an interface
default-router address[address2 ...
Specifies the default routers for a DHCP client
address8]
Security Commands
Lists the password that is required if
password pass-value the login command (with no other parameters) is
configured
Defines one of possibly multiple user names and
associated passwords used for user authentication.
username name password pass-value
It is used when the login local line configuration
command has been used
Defines the password required when using
enable password pass-value
the enable command
Sets the password required for any user to enter
enable secret pass-value
enable mode
Directs the Cisco IOS software to encrypt the
service password-encryption passwords, CHAP secrets and similar data saved in
its configuration file
ip domain-name name Configures a DNS domain name
Creates and stores (in a hidden location in flash
crypto key generate rsa
memory) the keys that are required by SSH
Defines whether Telnet or SSH access is allowed
into this switch. Both values can be specified in a
transport input {telnet | ssh}
single command to allow both Telnet and SSH
access (default settings)
access-list access-list-number {deny |
Defines a standard IP access list
permit} source [source-wildcard] [log]
Restricts incoming and outgoing connections
access-class between a particular VTY (into a basic Cisco
device) and the addresses in an access list
ip access-list {standard | extended} {access-
Defines an IP access list by name or number
list-name | access-list-number}
Allows a packet to pass a named IP ACL. To
permit source [source-wildcard] remove a permit condition from an ACL, use
the “no” form of this command.
deny source [source-wildcard] Used to set conditions in a named IP ACL that will
deny packets. To remove a deny condition from an
ACL, use the “no” form of this command.
Configures the software clock to synchronize a peer
ntp peer <ip-address>
or to be synchronized by a peer
switchport port-security Enables port security on the interface
switchport port-security Sets the maximum number of secure MAC
maximum maximum addresses on the port
switchport port-security mac- Adds a MAC address to the list of secure MAC
address {mac-addr | {sticky [mac-addr]}} addresses. The “sticky” option configures the MAC
addresses as sticky on the interface
switchport port-security Sets the action to be taken when a security violation
violation {shutdown | restrict | protect} is detected
Displays information about security options
show port security [interface interface-id]
configured on the interface