0% found this document useful (0 votes)
7 views

LabAssignment9

Uploaded by

sayiamhanda1123
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
7 views

LabAssignment9

Uploaded by

sayiamhanda1123
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 8

Network Programming Laboratory (UCS413)

Assignment: 9

Objective: Inter-VLAN Routing using Layer 3 Switches

Create following topology and VLANs on Packet Tracer. Configure the network for
Inter-VLAN routing.

Cisco 3560 switch

Verify the Inter-VLAN Routing using ping utility and also by simulation.
Inter-VLAN Routing using Layer 3 Switches
In this Assignment, you will configure inter-VLAN routing using Layer 3 switches.

Layer 3 Switch Inter-VLAN Routing


Modern enterprise networks rarely use router-on-a-stick because it does not scale easily to meet
requirements. In these very large networks, network administrators use Layer 3 switches to configure
inter-VLAN routing.

Inter-VLAN routing using the router-on-a-stick method is simple to implement for a small- to medium-
sized organization. However, a large enterprise requires a faster, much more scalable method to
provide inter-VLAN routing.

Enterprise campus LANs use Layer 3 switches to provide inter-VLAN routing. Layer 3 switches use
hardware-based switching to achieve higher-packet processing rates than routers. Layer 3 switches
are also commonly implemented in enterprise distribution layer wiring closets.

Capabilities of a Layer 3 switch include the ability to do the following:

• Route from one VLAN to another using multiple switched virtual interfaces (SVIs).
• Convert a Layer 2 switchport to a Layer 3 interface (that is, a routed port). A routed port is
similar to a physical interface on a Cisco IOS router.

To provide inter-VLAN routing, Layer 3 switches use SVIs. SVIs are configured using the
same interface vlan vlan-id command used to create the management SVI on a Layer 2 switch. A
Layer 3 SVI must be created for each of the routable VLANs.

Layer 3 Switch Scenario


In Figure 1, the Layer 3 switch, D1, is connected to two hosts on different VLANs. PC1 is in VLAN 10,
and PC2 is in VLAN 20, as shown. The Layer 3 switch will provide inter-VLAN routing services to the
two hosts.

Figure 1 Layer 3 Switch Inter-VLAN Routing Topology


Table 4-3 shows the IP addresses for each VLAN.

Table 4-3 D1 VLAN IP Addresses

VLAN Interface IP Address


10 192.168.10.1/24
20 192.168.20.1/24

Layer 3 Switch Configuration


Complete the following steps to configure S1 with VLANs and trunking:

• Step 1. Create the VLANs. First, create the two VLANs as shown below.

Example 4-13 Create the VLANs

D1(config)# vlan 10
D1(config-vlan)# name LAN10
D1(config-vlan)# vlan 20
D1(config-vlan)# name LAN20
D1(config-vlan)# exit
D1(config)#

• Step 2. Create the SVI VLAN interfaces. Configure the SVI for VLANs 10 and 20, as shown below.
The IP addresses that are configured will serve as the default gateways to the hosts in the respective
VLANs. Notice the informational messages showing the line protocol on both SVIs changed to up.

Create the SVI VLAN Interfaces

D1(config)# interface vlan 10


D1(config-if)# description Default Gateway SVI for 192.168.10.0/24
D1(config-if)# ip add 192.168.10.1 255.255.255.0
D1(config-if)# no shut
D1(config-if)# exit
D1(config)#
D1(config)# int vlan 20
D1(config-if)# description Default Gateway SVI for 192.168.20.0/24
D1(config-if)# ip add 192.168.20.1 255.255.255.0
D1(config-if)# no shut
D1(config-if)# exit
D1(config)#
*Sep 17 13:52:16.053: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Vlan10,
changed state to up
*Sep 17 13:52:16.160: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Vlan20,
changed state to up

• Step 3. Configure access ports. Next, configure the access ports connecting to the hosts and
assign them to their respective VLANs, as shown below.

Configure Access Ports

D1(config)# interface GigabitEthernet1/0/6


D1(config-if)# description Access port to PC1
D1(config-if)# switchport mode access
D1(config-if)# switchport access vlan 10
D1(config-if)# exit
D1(config)#
D1(config)# interface GigabitEthernet1/0/18
D1(config-if)# description Access port to PC2
D1(config-if)# switchport mode access
D1(config-if)# switchport access vlan 20
D1(config-if)# exit

• Step 4. Enable IP routing. Finally, enable IPv4 routing with the ip routing global configuration
command to allow traffic to be exchanged between VLANs 10 and 20, as shown below. This
command must be configured to enable inter-VAN routing on a Layer 3 switch for IPv4.

Enable IP Routing

D1(config)# ip routing
D1(config)#

Layer 3 Switch Inter-VLAN Routing Verification


Inter-VLAN routing using a Layer 3 switch is simpler to configure than the router-on-a-stick method.
After the configuration is complete, the configuration can be verified by testing connectivity between
the hosts.

From a host, verify connectivity to a host in another VLAN using the ping command. It is a good idea
to first verify the current host IP configuration using the ipconfig Windows host command. The output
shown below confirms the IPv4 address and default gateway of PC1.

Example 4-17 Verify Windows Host Configuration

C:\Users\PC1> ipconfig
Windows IP Configuration
Ethernet adapter Ethernet0:
Connection-specific DNS Suffix . :
Link-local IPv6 Address : fe80::5c43:ee7c:2959:da68%6
IPv4 Address : 192.168.10.10
Subnet Mask : 255.255.255.0
Default Gateway : 192.168.10.1
C:\Users\PC1>

Next, verify connectivity with PC2 using the ping Windows host command, as shown below.
The ping output successfully confirms that inter-VLAN routing is operating.

Verify Inter-VLAN Routing by Pinging from PC1

C:\Users\PC1> ping 192.168.20.10


Pinging 192.168.20.10 with 32 bytes of data:
Reply from 192.168.20.10: bytes=32 time<1ms TTL=127
Reply from 192.168.20.10: bytes=32 time<1ms TTL=127
Reply from 192.168.20.10: bytes=32 time<1ms TTL=127
Reply from 192.168.20.10: bytes=32 time<1ms TTL=127
Ping statistics for 192.168.20.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms
C:\Users\PC1>

Routing on a Layer 3 Switch


If VLANs are to be reachable by other Layer 3 devices, they must be advertised using static or
dynamic routing. To enable routing on a Layer 3 switch, a routed port must be configured.

A routed port is created on a Layer 3 switch by disabling the switchport feature on a Layer 2 port that
is connected to another Layer 3 device. Specifically, configuring the no switchport interface
configuration command on a Layer 2 port converts it into a Layer 3 interface. Then the interface can
be configured with an IPv4 configuration to connect to a router or another Layer 3 switch.

Routing Scenario on a Layer 3 Switch (4.3.6)


In Figure 2, the previously configured D1 Layer 3 switch is now connected to R1. R1 and D1 are both
in an Open Shortest Path First (OSPF) routing protocol domain. Assume inter-VLAN has been
successfully implemented on D1. The G0/0/1 interface of R1 has also been configured and enabled.
Additionally, R1 is using OSPF to advertise its two networks, 10.10.10.0/24 and 10.20.20.0/24.
Figure 2 Routing Scenario on a Layer 3 Switch Topology

NOTE

OSPF routing configuration is covered in another course. In this module, OSPF configuration
commands will be given to you in all activities and assessments. It is not required that you understand
the configuration in order to enable OSPF routing on the Layer 3 switch.

Routing Configuration on a Layer 3 Switch


Complete the following steps to configure D1 to route with R1:

• Step 1. Configure the routed port. Configure G1/0/1 to be a routed port, assign it an IPv4 address,
and enable it, as shown below

Configure the Routed Port

D1(config)# interface GigabitEthernet1/0/1


D1(config-if)# description routed Port Link to R1
D1(config-if)# no switchport
D1(config-if)# ip address 10.10.10.2 255.255.255.0
D1(config-if)# no shut
D1(config-if)# exit
D1(config)#

• Step 2. Enable routing, as shown below. Ensure IPv4 routing is enabled with the ip routing global
configuration command.

Enable Routing

D1(config)# ip routing
D1(config)#

• Step 3. Configure routing. Configure the OSPF routing protocol to advertise the VLAN 10 and VLAN
20 networks, along with the network that is connected to R1, as shown below. Notice the message
informing you that an adjacency has been established with R1.
Configure Routing

D1(config)# router ospf 10


D1(config-router)# network 192.168.10.0 0.0.0.255 area 0
D1(config-router)# network 192.168.20.0 0.0.0.255 area 0
D1(config-router)# network 10.10.10.0 0.0.0.3 area 0
D1(config-router)# ^Z
D1#
*Sep 17 13:52:51.163: %OSPF-5-ADJCHG: Process 10, Nbr 10.20.20.1 on
GigabitEthernet1/0/1 from LOADING to FULL, Loading Done
D1#

• Step 4. Verify routing. Verify the routing table on D1, as shown below. Notice that D1 now has a route
to the 10.20.20.0/24 network.

Verify Routing

D1# show ip route | begin Gateway


Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
C 10.10.10.0/30 is directly connected, GigabitEthernet1/0/1
L 10.10.10.2/32 is directly connected, GigabitEthernet1/0/1
O 10.20.20.0/24 [110/2] via 10.10.10.1, 00:00:06,
GigabitEthernet1/0/1
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, Vlan10
L 192.168.10.1/32 is directly connected, Vlan10
192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.20.0/24 is directly connected, Vlan20
L 192.168.20.1/32 is directly connected, Vlan20
D1#

• Step 5. Verify connectivity. At this time, PC1 and PC2 are able to ping the server connected to R1, as
shown below

Verify Connectivity

C:\Users\PC1> ping 10.20.20.254


Pinging 10.20.20.254 with 32 bytes of data:
Request timed out.
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Ping statistics for 10.20.20.254:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss).
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 2ms, Average = 1ms
C:\Users\PC1>
!==================================================
C:\Users\PC2> ping 10.20.20.254
Pinging 10.20.20.254 with 32 bytes of data:
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Ping statistics for 10.20.20.254:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss).
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 2ms, Average = 1ms
C:\Users\PC2>

You might also like