0% found this document useful (0 votes)
23 views

1 LAB Basic Router Configuration

Copyright
© © All Rights Reserved
Available Formats
Download as DOCX, PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
23 views

1 LAB Basic Router Configuration

Copyright
© © All Rights Reserved
Available Formats
Download as DOCX, PDF, TXT or read online on Scribd
You are on page 1/ 4

LAB: Basic Router Configuration

Router CLI Modes:


Router> User Exec Mode
Router# Privilege Exec Mode (Privilege level 15)
Router(config)# Global Configuration Mode
Router(config-if)# Interface Sub-Configuration Mode
Router(config-line) Line Sub-Configuration Mode

Erasing an Existing Configuration:


Router#erase startup-config
Router#reload

Configuring Hostname:
Router>enable
Router#configure terminal
Router(config)#hostname R1

Configuring Domain Name:


R1(config)#ip domain-name cisco.com

Setting Passwords:

1) Setting enable password:


R1(config)#enable password cisco

2) Setting enable secret password:


R1(config)#enable secret utl

Setting line Passwords:

1) Setting password on console line:


R1(config)#line console 0
R1(config-line)#password utl
R1(config-line)#login
R1(config)#exit

LAB: Basic Router Configuration Page 1


2) Setting password on vty lines:
R1(config)#line vty 0 4
R1(config-line)#password utl
R1(config-line)#login
R1(config)#exit

Configuring IP address on Fast Ethernet (LAN) interfaces:


R1(config)#interface FastEthernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

Configuring IP address on Serial (WAN) interfaces:


R1(config)#interface serial 0/0
R1(config-if)#ip address 201.0.0.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

Check Serial (WAN) interfaces for DCE or DTE:


R1# show controllers serial 0/0

Configuring clock rate on DCE Serial (WAN) interfaces:


R1(config)#interface serial 0/0
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit

Setting Clock Time:


R1#set clock 2:15:00 Jan 18 2011

Assigning a Local Host Name to an IP Address:


R1(config)#ip host R1 10.0.0.1
R1(config)#exit

Set the time limit when the console automatically logs off:
R1(config)#line console 0
R1(config-line)#exec-timeout 0 0
R1(config-line)#exit

LAB: Basic Router Configuration Page 2


Turns off trying to automatically resolve an unrecognized command to a local host name:
R1(config)#no ip domain-lookup

Set the time limit when the vty session (telnet, ssh) automatically logs off:
R1(config)#line vty 0 4
R1(config-line)#exec-timeout 0 0
R1(config-line)#exit

Configuring password encryption:


R1#service password-encryption

Saving Router’s Configuration (RAM to NVRAM):


R1#copy running-config startup-config (write)

LAB: Basic Router Configuration Page 3


Show Commands:

Display information about the Cisco IOS Software and Configuration register value:
R1#show version

Display information about flash memory:


R1#show flash

Display interfaces configuration:


R1#show interfaces

Display a specific interface configuration:


R1#show interface serial 0/0

Display a summary of all interfaces on router:


R1#show ip interface brief

Display serial (WAN) interface for checking DCE, DTE and clock rate information:
R1#show controllers serial 0/0

Display clock time:


R1#show clock

Display all users connected to device: (through console and vty)


R1#show users

Display the history of entered commands:


R1#show history

Display status of configured layer 3 protocols:


R1#show protocols

Display the configuration currently running in RAM:


R1#show running-config

Display the configuration saved permanently in NVRAM:


R1#show startup-config

LAB: Basic Router Configuration Page 4

You might also like