Network Design 1

Download as docx, pdf, or txt
Download as docx, pdf, or txt
You are on page 1of 22

Mapua University

School of Electrical, Electronics and Computer Engineering

Network Infrastructure
Design for Computer Shop
Business Implementation

Design of Experiment for Data


Communications and Computer
Networking II

Mga Cis/E01
BONCOLMO, STEVEN DG.
ESCALAW, EMERIE JACK C.
MOLENO, JETHRO P.
MORALDE, ELIJAH B.

October 2020
Andrew Kim Pahutan
Professor
I. SITUATIONAL PROBLEM

ComShop Manongsky is a newly established computer shop that needs a

network layout. The shop is a 2 floored building that has 10 computers each

floor excluding the computer of the shop owner at the entrance. The

traditional way of handling business in computer shops is where the person

assigned in facilitating usage time would shout if he or she would like to

extend their time in their respective computers or walk directly towards

them for an inquiry of an extension is rather inefficient, even more so when

the shop is a two floored building. The network layout would boost not only

the time for transactions but also the ease of life of all the people in the

shop, including the "bantay".


II. OBJECTIVES

 To design a network that applies basic device configuration, VLAN’S,

Inter-VLAN Routing, DHCPv4, Routing Concepts, and IP Static Routing.

 To implement a network layout that would boost not only the time for

transactions but also the ease of all the user in the shop.

 To satisfy the client’s need by operating the proposed network

designed to their newly opened computer shop.

 To meet the requirements of the client. Like, Money is one of the

important design constraints on any network.


III. PROPOSED NETWORK TOPOLOGY

The brown color shaded shows that the ADMIN Router handles the ADMIN

switch and the two PC’s for the shopkeepers. There are 4 switches

represented by the yellow, green, blue, and orange shaded color. Switch 1

with blue color shaded, handles PC0 to PC4, Switch 2 with yellow color

shaded, handles PC5-PC9, Switch 3 with green color shaded handles the

PC10-PC14 and Switch 4 with orange color shaded handles the PC15-PC19.

There are two floors in the computer shop. First floor and Second floor have

2 rows each. Each of them has 10 PC’s.


IV. NETWORK ADDRESSES USED

Addressing Table

Device Interface IP Address Subnet Mask


Router-PT-1st Floor F0/0 & F1/0 10.0.0.1 & 11.0.0.1 255.0.0.0
Router-PT-2nd
Floor F0/0 & F1/0 12.0.0.1 & 13.0.0.1 255.0.0.0
FloorSwitch1
FloorSwitch2
FloorSwitch3
FloorSwitch4
PC0 NIC 192.168.10.10 255.255.255.0
PC1 NIC 192.168.20.10 255.255.255.0
PC2 NIC 192.168.30.10 255.255.255.0
PC3 NIC 192.168.40.10 255.255.255.0
PC4 NIC 192.168.50.10 255.255.255.0
PC5 NIC 192.168.10.11 255.255.255.0
PC6 NIC 192.168.20.11 255.255.255.0
PC7 NIC 192.168.30.11 255.255.255.0
PC8 NIC 192.168.40.11 255.255.255.0
PC9 NIC 192.168.50.11 255.255.255.0
PC10 NIC DHCP Assigned DHCP Assigned
PC11 NIC DHCP Assigned DHCP Assigned
PC12 NIC DHCP Assigned DHCP Assigned
PC13 NIC DHCP Assigned DHCP Assigned
PC14 NIC DHCP Assigned DHCP Assigned
PC15 NIC DHCP Assigned DHCP Assigned
PC16 NIC DHCP Assigned DHCP Assigned
PC17 NIC DHCP Assigned DHCP Assigned
PC18 NIC DHCP Assigned DHCP Assigned
PC19 NIC DHCP Assigned DHCP Assigned
Server0 10.0.0.10 255.0.0.0
Server1 11.0.0.10 255.0.0.0
Server2 12.0.0.10 255.0.0.0
Server3 13.0.0.10 255.0.0.0
V. RUNNING CONFIGURATIONS

1st Floor Switches


SWITCH 0
User Access Verification

Password:

FloorSwitch1>enable
Password:
FloorSwitch1#show running-config
Building configuration...

Current configuration : 1692 bytes


!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname FloorSwitch1
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 40
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 50
switchport mode access
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
switchport trunk native vlan 100
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 10.0.0.1 255.0.0.0
!
interface Vlan99
mac-address 00d0.ff50.7901
ip address 192.168.99.253 255.255.255.0
!
banner motd ^CUnauthorized access is prohibited^C
!
!
!
line con 0
password 7 0822455D0A16
login
!
line vty 0 4
password 7 0822455D0A16
login
line vty 5 15
password 7 0822455D0A16
login
!
!
!
!
end

FloorSwitch1#
SWITCH 1
Switch>enable
Switch#show running-config
Building configuration...

Current configuration : 1628 bytes


!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
switchport trunk native vlan 100
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet0/2
switchport trunk native vlan 100
switchport mode dynamic desirable
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 0002.4a9d.6a01
no ip address
!
interface Vlan20
mac-address 0002.4a9d.6a02
no ip address
!
interface Vlan30
mac-address 0002.4a9d.6a03
no ip address
!
interface Vlan40
mac-address 0002.4a9d.6a04
no ip address
!
interface Vlan50
mac-address 0002.4a9d.6a05
no ip address
!
interface Vlan99
mac-address 0002.4a9d.6a06
ip address 192.168.99.252 255.255.255.0
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
!
end

Switch#
SWITCH#2
User Access Verification

Password:

FloorSwitch2>enable
Password:
FloorSwitch2#show running-config
Building configuration...

Current configuration : 1668 bytes


!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname FloorSwitch2
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 40
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 50
switchport mode access
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
switchport trunk native vlan 100
switchport mode trunk
!
interface Vlan1
ip address 10.0.0.2 255.0.0.0
!
interface Vlan99
mac-address 0001.429e.2e01
ip address 192.168.99.254 255.255.255.0
!
banner motd ^CUnauthorized access is prohibited^C
!
!
!
line con 0
password 7 0822455D0A16
login
!
line vty 0 4
password 7 0822455D0A16
login
line vty 5 15
password 7 0822455D0A16
login
!
!
!
!
end

FloorSwitch2#
2ND FLOOR SWITCHES
SWITCH 3
User Access Verification

Password:

FloorSwitch3>enable
Password:
FloorSwitch3#show running-config
Building configuration...

Current configuration : 1262 bytes


!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname FloorSwitch3
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
banner motd ^CUnauthorized access is prohibited^C
!
!
!
line con 0
password 7 0822455D0A16
login
!
line vty 0 4
password 7 0822455D0A16
login
line vty 5 15
password 7 0822455D0A16
login
!
!
!
!
end

FloorSwitch3#
SWITCH 4
User Access Verification

Password:

FloorSwitch4>enable
Password:
FloorSwitch4#show running-config
Building configuration...

Current configuration : 1262 bytes


!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname FloorSwitch4
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
banner motd ^CUnauthorized access is prohibited^C
!
!
!
line con 0
password 7 0822455D0A16
login
!
line vty 0 4
password 7 0822455D0A16
login
line vty 5 15
password 7 0822455D0A16
login
!
!
!
!
end

FloorSwitch4#

You might also like