Lab 7 - Troubleshoot IPv4 and IPv6 Static and Default Routes

Download as docx, pdf, or txt
Download as docx, pdf, or txt
You are on page 1of 6

Lab 7- Troubleshoot IPv4 and IPv6 Static and Default Routes

Course: NWC303
Semester: SP24
Class: IA1601
Name: Phạm Minnh Khang
Roll number: SE140793

Topology

Addressing Table
Device Interface IP Address / Prefix

R1 G0/0/0 192.168.0.1 /28

R1 G0/0/0
2001:db8:acad::1 /64

R1
G0/0/1 192.168.0.17 /28

R1 G0/0/1
2001:db8:acad:16::1 /64

R1
Loopback1 172.16.1.1 /24

R1 Loopback1
2001:db8:acad:171::1 /64

R1
Loopback2 209.165.200.1 /25

R1 Loopback2
2001:db8:acad:209::1 /64
R2 G0/0/0 192.168.0.14 /28

R2 G0/0/0
2001:db8:acad::14 /64

 - 2024 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 1 of 6 www.netacad.com
Lab 7- Troubleshoot IPv4 and IPv6 Static and Default Routes

Device Interface IP Address / Prefix

R2
G0/0/1 192.168.0.30 /28

R2 G0/0/1
2001:db8:acad:16::2 /64

R2
Loopback1 172.16.2.1 /24

R2 Loopback1
2001:db8:acad:172::1 /64

R2
Loopback2 209.165.200.129 /25

R2 Loopback2
2001:db8:acad:210::1 /64

Objectives
Part 1: Evaluate Network Operation
Part 2: Gather information, create an action plan, and implement corrections

Background / Scenario
Your instructor has preconfigured all the network equipment and has included intentional errors that are
keeping the configured routes from working. Your task is to evaluate the network, identify, and correct the
configuration errors to restore full connectivity. You may find errors with the route statements or with other
configurations that impact the accuracy of the route statements.
Note: The static routing approach used in this lab is used to assess your ability to configure different types of
static routes only. This approach may not reflect networking best practices.

Preconfiguration
Router R1
enable
config terminal
hostname R1
ipv6 unicast-routing
interface g0/0/1
ip address 192.168.0.17 255.255.255.240
ipv6 address fe80::1 link-local
ipv6 address 2001:db8:acad:16::1/64
interface g0/0/0
ip address 192.168.0.1 255.255.255.240
ipv6 address fe80::1 link-local
ipv6 address 2001:db8:acad::1/64
interface loopback 1
ip address 172.16.1.1 255.255.255.0
ipv6 address fe80::1 link-local
ipv6 address 2001:db8:acad:171::1/64
interface loopback 2
ip address 209.165.200.1 255.255.255.128
ipv6 address fe80::1 link-local
ipv6 address 2001:db8:acad:209::1/64

 - 2024 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 2 of 6 www.netacad.com
Lab 7- Troubleshoot IPv4 and IPv6 Static and Default Routes

!ip route 209.165.200.128 255.255.255.128 192.168.0.30


ip route 209.165.200.128 255.255.255.128 192.168.0.3
ip route 0.0.0.0 0.0.0.0 192.168.0.14 80
!ip route 0.0.0.0 0.0.0.0 192.168.0.14
!ip route 0.0.0.0 0.0.0.0 192.168.0.30 80
ip route 0.0.0.0 0.0.0.0 192.168.0.3
ipv6 route ::/0 2001:db8:acad:16::2
Router R2
enable
config terminal
hostname R2
no ip domain lookup
ipv6 unicast-routing
interface g0/0/0
ip address 192.168.0.14 255.255.255.240
ipv6 address fe80::2 link-local
ipv6 address 2001:db8:acad::14/64
interface g0/0/1
ip address 192.168.0.30 255.255.255.240
ipv6 address fe80::2 link-local
ipv6 address 2001:db8:acad:16::2/64
interface loopback 1
ip address 172.16.2.1 255.255.255.0
ipv6 address fe80::2 link-local
ipv6 address 2001:db8:acad:172::1/64
interface loopback 2
ip address 209.165.200.129 255.255.255.128
ipv6 address fe80::2 link-local
ipv6 address 2001:db8:acad:210::1/64
! ipv6 route 2001:db8:acad:209::/64 2001:db8:acad:16::1
ipv6 route 2001:db8:acad:209::/64 2001:db7:acad:16::1
! ipv6 route ::/0 2001:db8:acad::1
ipv6 route ::/0 2001:db8:acad::1 90
! ipv6 route ::/0 2001:db8:acad:16::1 80
ipv6 route ::/0 2001:db8:acad:15::1
ip route 0.0.0.0 0.0.0.0 192.168.0.17
end
Switch S1
enable
config terminal
hostname S1
interface range f0/1-4, f0/6-24, g0/1-2
shutdown
end

 - 2024 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 3 of 6 www.netacad.com
Lab 7- Troubleshoot IPv4 and IPv6 Static and Default Routes

Switch S2
enable
config terminal
hostname S2
interface range f0/1-4, f0/6-24, g0/1-2
shutdown
end

Instructions

Part 1: Evaluate Network Operation.


Use Ping and/or Traceroute from the router console to test the following criteria and show the results.
a. Traffic from R1 to R2’s 172.16.2.1 address use the next hop 192.168.0.14.

b. Traffic from R1 to R2’s 209.165.200.129 address use the next hop 192.168.0.30.

c. When R1’s G0/0/0 interface is shut down, traffic from R1 to R2’s 172.16.2.1 use the next hop
192.168.0.30.

d. Traffic from R2 to R1’s 2001:db8:acad:171::1 address use the next hop 2001:db8:acad::1.

e. Traffic from R2 to R1’s 2001:db8:acad:209::1 address use the next hop 2001:db8:acad:16::1.

f. When R2’s G0/0/0 interface is shut down, traffic from R2 to R1’s 2001:db8:acad:171::1 use the next hop
2001:db8:acad:16::1.

Part 2: Gather information, create an action plan, and implement corrections.


a. For each criterion that is not met, gather information by examining the running configuration and routing
tables and develop a hypothesis for what is causing the malfunction.
b. Create an action plan that you think will fix the issue. Develop a list of all the commands you intend to
issue to fix the issue, and a list of all the commands you need to revert the configuration, should your
action plan fail to correct the issue.

 - 2024 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 4 of 6 www.netacad.com
Lab 7- Troubleshoot IPv4 and IPv6 Static and Default Routes

Router R1
no ip route 209.165.200.128 255.255.255.128 192.168.0.3

ip route 209.165.200.128 255.255.255.128 192.168.0.30

no ip route 0.0.0.0 0.0.0.0 192.168.0.14 80

ip route 0.0.0.0 0.0.0.0 192.168.0.14

no ip route 0.0.0.0 0.0.0.0 192.168.0.3

ip route 0.0.0.0 0.0.0.0 192.168.0.30 80


Router R2
no ipv6 route 2001:db8:acad:209::/64 2001:db7:acad:16::1
ipv6 route 2001:db8:acad:209::/64 2001:db8:acad:16::1
no ipv6 route ::/0 2001:db8:acad::1 90
ipv6 route ::/0 2001:db8:acad::1
no ipv6 route ::/0 2001:db8:acad:15::1
ipv6 route ::/0 2001:db8:acad:16::1 80

c. Execute your action plans one at a time for each criterion that fails and show results after fixed.
R1 to R2’s 172.16.2.1 address use the next hop 192.168.0.14

R1 to R2’s 209.165.200.129 address use the next hop 192.168.0.30.

 - 2024 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 5 of 6 www.netacad.com
Lab 7- Troubleshoot IPv4 and IPv6 Static and Default Routes

R1’s G0/0/0 interface is shut down, traffic from R1 to R2’s 172.16.2.1 use the next hop
192.168.0.30

R2 to R1’s 2001:db8:acad:171::1 address use the next hop 2001:db8:acad::1

R2 to R1’s 2001:db8:acad:209::1 address use the next hop 2001:db8:acad:16::1.

R2’s G0/0/0 interface is shut down, traffic from R2 to R1’s 2001:db8:acad:171::1 use the
next hop 2001:db8:acad:16::1.

 - 2024 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 6 of 6 www.netacad.com

You might also like