Lab5test - Configuring Per-Interface Inter-VLAN Routing - ILM
Lab5test - Configuring Per-Interface Inter-VLAN Routing - ILM
Lab5test - Configuring Per-Interface Inter-VLAN Routing - ILM
Topology
Addressing Table
Device Interface IP Address Subnet Mask Default Gateway
Page 1 of 12
Lab – Configuring Per-Interface Inter-VLAN Routing
configuring Layer-3 switching. Also, you may encounter per-interface inter-VLAN routing in organizations with
very small networks. One of the benefits of legacy inter-VLAN routing is ease of configuration.
In this lab, you will set up one router with two switches attached via the router Gigabit Ethernet interfaces.
Two separate VLANs will be configured on the switches, and you will set up routing between the VLANs.
Note: This lab provides minimal assistance with the actual commands necessary to configure the router and
switches. The required switch VLAN configuration commands are provided in Appendix A of this lab. Test
your knowledge by trying to configure the devices without referring to the appendix.
Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with
Cisco IOS, Release 15.2(4)M3 (universalk9 image). The switches used are Cisco Catalyst 2960s with Cisco
IOS, Release 15.0(2) (lanbasek9 image). Other routers, switches and Cisco IOS versions can be used.
Depending on the model and Cisco IOS version, the commands available and output produced might vary
from what is shown in the labs. Refer to the Router Interface Summary Table at the end of this lab for the
correct interface identifiers.
Note: Make sure that the routers and switches have been erased and have no startup configurations. If you
are unsure, contact your instructor.
Required Resources
• 1 Router (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
• 2 Switches (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)
• 2 PCs (Windows 7, Vista, or XP with terminal emulation program, such as Tera Term)
• Console cables to configure the Cisco IOS devices via the console ports
• Ethernet cables as shown in the topology
Page 2 of 12
Lab – Configuring Per-Interface Inter-VLAN Routing
Configure PC-A and PC-B with IP addresses and a default gateway address according to the Addressing
Table.
Page 3 of 12
Lab – Configuring Per-Interface Inter-VLAN Routing
b. On both S1 and S2, issue the show interface trunk command. Is the F0/1 port on both switches set to
trunk?
S1# show interface trunk
c. Issue a show vlan brief command on both S1 and S2. Verify that VLANs 10 and 20 are active and that
the proper ports on the switches are in the correct VLANs. Why is F0/1 not listed in any of the active
VLANs?
____________________________________________________________________________________
S1# show vlan brief
Page 4 of 12
Lab – Configuring Per-Interface Inter-VLAN Routing
d. Ping from PC-A in VLAN 10 to PC-B in VLAN 20. If Inter-VLAN routing is functioning correctly, the pings
between the 192.168.10.0 network and the 192.168.20.0 should be successful.
Note: It may be necessary to disable the PC firewall to ping between PCs.
e. Verify connectivity between devices. You should be able to ping between all devices. Troubleshoot if you
are not successful.
Reflection
What is an advantage of using legacy inter-VLAN routing?
_______________________________________________________________________________________
_______________________________________________________________________________________
_______________________________________________________________________________________
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
(F0/0) (F0/1)
1900 Gigabit Ethernet 0/0 Gigabit Ethernet 0/1 Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
(G0/0) (G0/1)
2801 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
(F0/0) (F0/1)
2811 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
(F0/0) (F0/1)
2900 Gigabit Ethernet 0/0 Gigabit Ethernet 0/1 Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
(G0/0) (G0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many
interfaces the router has. There is no way to effectively list all the combinations of configurations for each router
class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device.
The table does not include any other type of interface, even though a specific router may contain one. An
example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be
used in Cisco IOS commands to represent the interface.
Appendix A: Configuration Commands Switch S1
S1(config)# vlan 10
S1(config-vlan)# name Student
S1(config-vlan)# exit
S1(config)# vlan 20
S1(config-vlan)# name Faculty-Admin
S1(config-vlan)# exit
S1(config)# interface f0/1
S1(config-if)# switchport mode trunk
Page 5 of 12
Lab – Configuring Per-Interface Inter-VLAN Routing
Switch S2
S2(config)# vlan 10
S2(config-vlan)# name Student
S2(config-vlan)# exit
S2(config)# vlan 20
S2(config-vlan)# name Faculty-Admin
S2(config-vlan)# exit
S2(config)# interface f0/1
S2(config-if)# switchport mode trunk
S2(config-if)# interface f0/11
S2(config-if)# switchport mode access
S2(config-if)# switchport access vlan 20
S2(config-if)# interface f0/18
S2(config-if)# switchport mode access
S2(config-if)# switchport access vlan 20
S2(config-if-range)# interface vlan 10
S2(config-if)#ip address 192.168.10.12 255.255.255.0
S2(config-if)# no shut
S2(config-if)# exit
S2(config)# ip default-gateway 192.168.10.1
Device Configs
Router R1
R1#show run
Building configuration...
no ip domain lookup
ip cef no
ipv6 cef !
multilink bundle-name authenticated !
!
! !
redundancy !
!
!
!
!
! ! interface Embedded-Service-
Engine0/0 no ip address shutdown !
interface GigabitEthernet0/0 ip
address 192.168.20.1 255.255.255.0
duplex auto speed auto ! interface
GigabitEthernet0/1 ip address
192.168.10.1 255.255.255.0 duplex
auto speed auto !
interface Serial0/0/0
no ip address
shutdown clock rate
2000000 !
interface Serial0/0/1
no ip address
shutdown !
ip forward-protocol nd !
no ip http server no ip
http secure-server !
!
! !
control-plane !
! !
line con 0 password cisco login line aux 0 line 2 no
activation-character no exec transport preferred none
transport input all transport output pad telnet rlogin lapb-
ta mop udptn v120 ssh stopbits 1 line vty 0 4
password cisco login transport input all !
scheduler allocate 20000 1000
! end
Switch S1
S1# show vlan brief
S1#show run
Building configuration...
Page 8 of 12
Lab – Configuring Per-Interface Inter-VLAN Routing
no service password-encryption !
hostname S1
! !
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2 !
no aaa new-model system
mtu routing 1500 ! !
no ip domain-lookup !
interface FastEthernet0/1
switchport mode trunk !
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
switchport access vlan 10
switchport mode access !
interface FastEthernet0/6
switchport access vlan 10
switchport mode access !
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
Page 9 of 12
Lab – Configuring Per-Interface Inter-VLAN Routing
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1 !
interface GigabitEthernet0/2 !
interface Vlan1
no ip address
shutdown !
interface Vlan10 ip address
192.168.10.11 255.255.255.0 ! ip
default-gateway 192.168.10.1 ip http
server ip http secure-server ! !
line con 0
password cisco
login line vty
0 4 password
cisco login
line vty 5 15
password cisco
login ! end
Switch S2
S2# show vlan brief
S2#sh run
Building configuration...
Page 10 of 12
Lab – Configuring Per-Interface Inter-VLAN Routing
Page 11 of 12
Lab – Configuring Per-Interface Inter-VLAN Routing
ip default-gateway 192.168.10.1
ip http server ip http secure-
server !
line con 0 line
vty 0 4
password cisco
login line vty
5 15 password
cisco login
end
Page 12 of 12