Vlan Capa3 Ospf DHCP
Vlan Capa3 Ospf DHCP
Vlan Capa3 Ospf DHCP
Se cambiará el servidor por VLAN10 en lugar de VLAN40 que era lo que tenía en un principio
Switch>EN
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname SWL3
SWL3(config)#exit
SWL3#
%SYS-5-CONFIG_I: Configured from console by console
SWL3#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
SWL3#
SWL3>en
SWL3#config t
Enter configuration commands, one per line. End with CNTL/Z.
SWL3(config)#int VLAN 10
SWL3(config-if)#ip address 192.168.10.1 255.255.255.0
SWL3(config-if)#no shut
SWL3(config-if)#exit
SWL3(config)#int VLAN 20
SWL3(config-if)#ip address 192.168.20.1 255.255.255.0
SWL3(config-if)#no shut
SWL3(config-if)#exit
SWL3(config)#int VLAN 30
SWL3(config-if)#ip address 192.168.30.1 255.255.255.0
SWL3(config-if)#no shut
SWL3(config-if)#int VLAN 40
SWL3(config-if)#ip address 192.168.40.1 255.255.255.0
SWL3(config-if)#no shut
SWL3(config-if)#exit
SWL3(config)#exit
SWL3#
%SYS-5-CONFIG_I: Configured from console by console
SWL3#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
SWL3#
Show vlan
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 00e0.f736.0601
ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
mac-address 00e0.f736.0602
ip address 192.168.20.1 255.255.255.0
!
interface Vlan30
mac-address 00e0.f736.0603
ip address 192.168.30.1 255.255.255.0
!
interface Vlan40
mac-address 00e0.f736.0604
ip address 192.168.40.1 255.255.255.0
SWL3#config t
Enter configuration commands, one per line. End with CNTL/Z.
SWL3(config)#int VLAN 1
SWL3(config-if)#ip address 192.168.1.1 255.255.255.0
SWL3(config-if)#name ADMINISTRATIVAexit
^
% Invalid input detected at '^' marker.
SWL3(config-if)#exit
SWL3(config)#name VLAN 1 ADMINISTRATIVA
^
% Invalid input detected at '^' marker.
SWL3(config)#int VLAN 1
SWL3(config-if)#no shut
SWL3(config-if)#
%LINK-5-CHANGED: Interface Vlan1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
SWL3(config-if)#exit
SWL3(config)#VLAN 1
SWL3(config-vlan)#name ADMINISTRATIVA
Default VLAN 1 may not have its name changed.
SWL3(config-vlan)#exit
SWL3(config)#
SWL3(config-if-range)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1,
changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1,
changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to
up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to
up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
up
SWL3#
SWL3#config t
Enter configuration commands, one per line. End with CNTL/Z.
SWL3(config)#int VLAN 1
SWL3(config-if)#ip address 192.168.1.1 255.255.255.0
SWL3(config-if)#no shut
SWL3(config-if)#exit
SWL3(config)#
Feature VLAN :
--------------
VTP Operating Mode : Server
Maximum VLANs supported locally : 1005
Number of existing VLANs : 9
Configuration Revision : 0
MD5 digest : 0x78 0x62 0x1B 0x15 0xA2 0x40 0x82 0x85
0x96 0xAE 0x6E 0x5B 0x16 0x08 0xA7 0xBD
SWL3#
Configuramos el Switch para que sea DHCP. Esto hace que el servidor
que en un principio habíamos considerado hacerle DHCP lo hagamos pc
normal.
SW0L3>en
SW0L3#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW0L3(config)#ip dhcp vlan10 -> esto no sería correcto
SW0L3(config)#ip dhcp pool vlan10
SW0L3(dhcp-config)#network 192.168.10.0 255.255.255.0
SW0L3(dhcp-config)#default-router 192.168.10.1
SW0L3(dhcp-config)#dns-server 200.200.200.2
SW0L3(dhcp-config)#ip dhcp excluded-address 192.168.10.1 192.168.10.80
SW0L3(config)#do write
Building configuration...
[OK]
SW0L3(config)#no ip domain-lookup
SW0L3(config)#
SW0L3#
%SYS-5-CONFIG_I: Configured from console by console
SW0L3#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW0L3(config)#ip dchp pool vlan 10
^
% Invalid input detected at '^' marker.
SW0L3(config)#ip dhcp pool vlan 10
^
% Invalid input detected at '^' marker.
SW0L3(config)#ip dhcp pool vlan10
SW0L3(dhcp-config)#dns-server 200.200.200.2
SW0L3(dhcp-config)#exit
SW0L3#show run
Building configuration...
SW0L3#
default-router 192.168.20.1
dns-server 200.200.200.2
default-router 192.168.30.1
dns-server 200.200.200.2
default-router 192.168.40.1
dns-server 200.200.200.2
SW0L3#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW0L3(config)#ip dhcp excluded-address 192.168.20.1 192.168.20.80
SW0L3(config)#
SW0L3(config)#ip dhcp pool vlan20
SW0L3(dhcp-config)#network 192.168.20.0 255.255.255.0
SW0L3(dhcp-config)#default-router 192.168.20.1
SW0L3(dhcp-config)#dns-server 200.200.200.2
SW0L3(dhcp-config)#
SW0L3(dhcp-config)#ip dhcp excluded-address 192.168.30.1 192.168.30.80
SW0L3(config)#
SW0L3(config)#ip dhcp pool vlan30
SW0L3(dhcp-config)#network 192.168.30.0 255.255.255.0
SW0L3(dhcp-config)#default-router 192.168.30.1
SW0L3(dhcp-config)#dns-server 200.200.200.2
SW0L3(dhcp-config)#
SW0L3(dhcp-config)#ip dhcp excluded-address 192.168.40.1 192.168.40.80
SW0L3(config)#
SW0L3(config)#ip dhcp pool vlan40
SW0L3(dhcp-config)#network 192.168.40.0 255.255.255.0
SW0L3(dhcp-config)#default-router 192.168.40.1
SW0L3(dhcp-config)#dns-server 200.200.200.2
SW0L3(dhcp-config)#
SW0L3>en
SW0L3#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW0L3(config)#int fa0/1
SW0L3(config-if)#no switchport
SW0L3(config-if)#exit
SW0L3(config)#int Fa0/24 Cambiamos la boca para tenerlo todos igual
SW0L3(config-if)#no switchport
SW0L3(config-if)#
SW0L3(config-if)#exit
SW0L3(config)#exit
SW0L3#
%SYS-5-CONFIG_I: Configured from console by console
SW0L3#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW0L3(config)#int Fa0/24
SW0L3(config-if)#ip address 10.0.0.1 255.255.255.252
SW0L3(config-if)#no shutdown
SW0L3(config-if)#exit
SW0L3(config)#exit
SW0L3#
%SYS-5-CONFIG_I: Configured from console by console
SW0L3#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
SW0L3#
SW0L3#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW0L3(config)#router ospf 1
IP routing not enabled
SW0L3(config)#exit
SW0L3#
%SYS-5-CONFIG_I: Configured from console by console
SW0L3#router ospf 1
^
% Invalid input detected at '^' marker.
SW0L3#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW0L3(config)#router ospf 1
IP routing not enabled
SW0L3(config)#ip routing
SW0L3(config)#router ospf 1
SW0L3(config-router)#network 192.168.10.0 0.0.0.255 area 0
SW0L3(config-router)#network 192.168.20.0 0.0.0.255 area 0
SW0L3(config-router)#network 192.168.30.0 0.0.0.255 area 0
SW0L3(config-router)#network 192.168.40.0 0.0.0.255 area 0
SW0L3(config-router)#network 192.168.1.0 0.0.0.255 area 0
SW0L3(config-router)
SW0L3#
SW0L3>en
SW0L3#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW0L3(config)#router ospf 1
SW0L3(config-router)#network 10.0.0.0 0.0.0.3 area 0
SW0L3(config-router)#
02:46:52: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.80.1 on FastEthernet0/24 from
LOADING to FULL, Loading Done
SW0L3(config-router)#exit
SW0L3(config)#do wr
Building configuration...
[OK]
SW0L3(config)#
SW0L3(config)#exit
SW0L3#
%SYS-5-CONFIG_I: Configured from console by console
SW0L3#
SWITCH SW1L3 – 2960
Feature VLAN :
--------------
VTP Operating Mode : Client
Maximum VLANs supported locally : 255
Number of existing VLANs : 5
Configuration Revision : 0
MD5 digest : 0x9D 0xC7 0x19 0xCC 0x8C 0x45 0xC1 0x72
0xCF 0x2B 0xDF 0xC7 0x32 0xF2 0x67 0x84
SW1L3#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW1L3(config)#vtp domain www.cisco.com
Domain name already set to www.cisco.com.
SW1L3(config)#vtp password cisco
Setting device VLAN database password to cisco
SW1L3(config)#
SW1L3(config)#
SW1L3#sh run
Building configuration...
SW1L3#
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
30 enet 100030 1500 - - - - - 0 0
40 enet 100040 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
Configuracion PC VLAN 10
SW1L3>en
SW1L3#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW1L3(config)#int fa0/5
SW1L3(config-if)#switchport mode access
SW1L3(config-if)#switchport access vlan 10
SW1L3(config-if)#do wr
Building configuration...
[OK]
SW1L3(config-if)#
Cambiamos el nombre
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname SW2L3
SW2L3(config)#
Configuramos el switch
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname SW2L3
SW2L3(config)#int range Gig0/2,Fa0/24
SW2L3(config-if-range)#switchport mode trunk
SW2L3(config-if-range)#exit
SW2L3(config)#vtp mode client
Setting device to VTP CLIENT mode.
SW2L3(config)#vtp domain www.cisco.com
Domain name already set to www.cisco.com.
SW2L3(config)#vtp password cisco
Setting device VLAN database password to cisco
SW2L3(config)#
Guardamos la configuración
SW2L3#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
SW2L3#
Comprobamos conexión
R0#ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max =
0/0/0 ms
R0#
Revisión
R0#show ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.2.1 YES manual up up
FastEthernet0/0.50 192.168.50.1 YES manual up up
FastEthernet0/0.60 192.168.60.1 YES manual up up
FastEthernet0/0.70 192.168.70.1 YES manual up up
FastEthernet0/0.80 192.168.80.1 YES manual up up
FastEthernet0/1 10.0.0.2 YES manual up up
Vlan1 unassigned YES unset administratively down down
R0#
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S1R0
S1R0(config)#int Fa0/24
S1R0(config-if)#switchport mode trunk
S1R0(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/24, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/24, changed state to up
S1R0(config-if)#int Fa0/23
S1R0(config-if)#switchport mode trunk
S1R0(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/23, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/23, changed state to up
S1R0(config-if)#exit
S1R0(config)#exit
S1R0#
%SYS-5-CONFIG_I: Configured from console by console
S1R0#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
S1R0#
S1R0>en
S1R0#config t
Enter configuration commands, one per line. End with CNTL/Z.
S1R0(config)#int range Fa0/1-5
S1R0(config-if-range)#switchport mode access
S1R0(config-if-range)#exit
S1R0(config)#int Fa0/1
S1R0(config-if)#switchport acces VLAN50
^
% Invalid input detected at '^' marker.
S1R0(config-if)#switchport access VLAN 50
S1R0(config-if)#int Fa0/2
S1R0(config-if)#switchport access VLAN 60
S1R0(config-if)#int Fa0/3
S1R0(config-if)#switchport access VLAN 70
S1R0(config-if)#int Fa0/4
S1R0(config-if)#switchport access VLAN 80
S1R0(config-if)#
Configuracion Switch 3 como S3R0
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S3R0
S3R0(config)#exit
S3R0#
%SYS-5-CONFIG_I: Configured from console by console
S3R0#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
S3R0#
Feature VLAN :
--------------
VTP Operating Mode : Server
Maximum VLANs supported locally : 255
Number of existing VLANs : 9
Configuration Revision : 8
MD5 digest : 0xD0 0x0E 0x2C 0x76 0xC9 0x8C 0x68 0x11
0xF0 0x07 0x97 0x49 0x0B 0xFC 0x8A 0x70
S1R0#
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S4R0
S4R0(config)#exit
S4R0#
%SYS-5-CONFIG_I: Configured from console by console
S4R0#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
S4R0#
2022.11.15 Configuracion manual del servidor DHCP. Al principio lo
habíamos dejado como un pc normal pero ahora lo vamos a
configurar como un servidor DHCP para las VLANs 50 a 80