Unix /linux Overview: Unix/IP Preparation Course May 23, 2010 Kigali, Rwanda
Unix /linux Overview: Unix/IP Preparation Course May 23, 2010 Kigali, Rwanda
UNIX History
FreeBSD Timeline
Manageability Security
Kernel
The "core" of the operating system Device drivers
communicate with your hardware block devices, character devices, network devices, pseudo devices
Filesystems
organise block devices into files and directories
Memory management Timeslicing (multitasking) Networking stacks - esp. TCP/IP Enforces security model
Shells
Command line interface for executing programs
DOS/Windows equivalent: command.com or command.exe
User processes
The programs that you choose to run Frequently-used programs tend to have short cryptic names
"ls" = list files "cp" = copy file "rm" = remove (delete) file
System processes
Programs that run in the background; also known as "daemons" ==> Examples:
cron: executes programs at certain times of day syslogd: takes log messages and writes them to files inetd: accepts incoming TCP/IP connections and starts programs for each one sshd: accepts incoming logins sendmail (other MTA daemon like Exim): accepts incoming mail
Security model
Numeric IDs
Mapped to names
/etc/passwd, /etc/group (plain text files)
Any questions?
(/boot, /bin, /sbin, /etc, maybe /tmp) (Log files, spool, maybe user mail) (Installed software packages) (May reside under /)
Don't confuse the the root account (/root) with the root (/) partition.
A swap partition for virtual memory /var for variable files, such as logs, mail spools, etc. /tmp
- Where temporary files are located
/usr
Partitioning Issues
/var may not be big enough /usr contains OS utilites, third-party software /usr/home contains your own important data
If you reinstall from scratch and erase /home, you will lose your own data
Everything in / is now more common due to RAID. Why? Valid? /tmp? Others? How much swap should you define?
Note...
Partitioning is just a logical division If your hard drive dies, most likely everything will be lost. If you want data security, then you need to set up mirroring with a separate drive.
Another reason to keep your data on a separate partition, e.g. /u Remember, rm -rf on a mirror works very well.
Any questions?
Software Installation
Software management in FreeBSD
Install from source Install from binary Compile from source using a port Use a wrapper tool, such as portinstall. Install pre-built FreeBSD packages using pkg_*
You can keep the source tree local and up-to-date. This is known as the ports collections. A number of tools to do this, including portsnap.
System Startup
Startup scripts in FreeBSD
/etc/rc.d system startup scripts /usr/local/etc/rc.d third-party startup scripts
Controlling services
In /etc/defaults/rc.conf initial defaults /etc/rc.conf override settings here
Administration
The use of the root account is discouraged and the sudo program should be used to access root privileges from your own account instead. You can do a buildworld to move between major and minor releases.
Important Reads
There's More
The FreeBSD Handbook
http://www.freebsd.org/handbook/