Build A Switch and Router Network Topology: Addressing Table
Build A Switch and Router Network Topology: Addressing Table
Addressing Table
Device Interface IP Address / Prefix Default Gateway
R1 G0/0/0 192.168.0.1 /24 N/A
2001:db8:acad::1/64
fe80::1
G0/0/1 192.168.1.1 /24 N/A
200:db8:acad:1::1/64
fe80::1
S1 VLAN 1 192.168.1.2 /24 192.168.1.1
PC-A NIC 192.168.1.3 /24 192.168.1.1
2001:db8:acad:1::3/64 fe80::1
PC-B NIC 192.168.0.3 /24 192.168.0.1
2001:db8:acad::3/64 fe80::1
Configure the router.
1) Console into the router and enable privileged EXEC mode.
Router> enable
2) Enter configuration mode.
Router# config terminal
3) Assign a device name to the router.
Router(config)# hostname R1
4) Disable DNS lookup to prevent the router from attempting to translate incorrectly entered commands as
though they were host names.
R1(config)# no ip domain lookup
5) Assign class as the privileged EXEC encrypted password.
R1(config)# enable secret class
6) Assign cisco as the console password and enable login.
R1(config)# line console 0
R1(config-line)# password cisco
R1(config-line)# login
7) Assign cisco as the VTY password and enable login.
R1(config)# line vty 0 4
R1(config-line)# password cisco
R1(config-line)# login
8) Encrypt the plaintext passwords.
R1(config)# service password-encryption
9) Create a banner that warns anyone accessing the device that unauthorized access is prohibited.
R1(config)# banner motd $ Authorized Users Only! $
10) Configure and activate both interfaces on the router.
R1(config)# interface g0/0/0
R1(config-if)# ip address 192.168.0.1 255.255.255.0
R1(config-if)# ipv6 address 2001:db8:acad::1/64
R1(config-if)# ipv6 address FE80::1 link-local
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface g0/0/1
R1(config-if)# ip address 192.168.1.1 255.255.255.0 R1(config-if)# ipv6 address
2001:db8:acad:1::1/64 R1(config-if)# no shutdown
R1(config-if)# exit
11) Configure an interface description for each interface indicating which device is connected to it.
R1(config)# interface g0/0/1
R1(config-if)# description Connected to F0/5 on S1
R1(config-if)# exit
R1(config)# interface g0/0/0
R1(config-if)# description Connected to Host PC-B
R1(config-if)# exit
12) To enable IPv6 routing, enter the command ipv6 unicast-routing.
R1(config)# ipv6 unicast-routing
13) Save the running configuration to the startup configuration file.
R1(config)# exit
R1# copy running-config startup-config
14) Set the clock on the router.
R1# clock set 15:30:00 26 Oct 2023
Configure the switch.
In this step, you will configure the hostname, the VLAN 1 interface and its default gateway.