Lab 3.2.1.4 - Configuring Etherchannel: Topology
Lab 3.2.1.4 - Configuring Etherchannel: Topology
Lab 3.2.1.4 - Configuring Etherchannel: Topology
4– Configuring EtherChannel
Topology
Addressing Table
Objectives
Part 1: Configure Basic Switch Settings
Part 2: Configure PAgP
Part 3: Configure LACP
Background / Scenario
Link aggregation allows the creation of logical links that are comprised of two or more physical links. This
provides increased throughput beyond using only one physical link. Link aggregation also provides
redundancy if one of the links fails.
In this lab, you will configure EtherChannel, a form of link aggregation used in switched networks. You will
configure EtherChannel using Port Aggregation Protocol (PAgP) and Link Aggregation Control Protocol
(LACP).
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 1 of 18
Lab – Configuring EtherChannel
Note: PAgP is a Cisco-proprietary protocol that you can only run on Cisco switches and on switches that are
licensed vendors to support PAgP. LACP is a link aggregation protocol that is defined by IEEE 802.3ad, and it
is not associated with any specific vendor.
LACP allows Cisco switches to manage Ethernet channels between switches that conform to the 802.3ad
protocol. You can configure up to 16 ports to form a channel. Eight of the ports are in active mode and the
other eight are in standby mode. When any of the active ports fail, a standby port becomes active. Standby
mode works only for LACP, not for PAgP.
Note: The switches used with CCNA hands-on labs are Cisco Catalyst 2960s with Cisco IOS Release 15.0(2)
(lanbasek9 image). Other switches and Cisco IOS versions can be used. Depending on the model and Cisco
IOS version, the commands available and output produced might vary from what is shown in the labs.
Note: Make sure that the switches have been erased and have no startup configurations. If you are unsure,
contact your instructor.
Required Resources
3 Switches (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)
3 PCs (Windows 7, Vista, or XP with terminal emulation program, such as Tera Term)
Console cables to configure the Cisco IOS devices via the console ports
Ethernet cables as shown in the topology
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 2 of 18
Lab – Configuring EtherChannel
S1(config-if-range)# no shutdown
S3(config-if-range)# no shutdown
*Mar 1 00:09:12.792: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
*Mar 1 00:09:12.792: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to up
S3(config-if-range)#
*Mar 1 00:09:15.384: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3,
changed state to up
*Mar 1 00:09:16.265: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4,
changed state to up
S3(config-if-range)#
*Mar 1 00:09:16.357: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
*Mar 1 00:09:17.364: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1,
changed state to up
*Mar 1 00:09:44.383: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed
state to up
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 3 of 18
Lab – Configuring EtherChannel
Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 4 of 18
Lab – Configuring EtherChannel
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 5 of 18
Lab – Configuring EtherChannel
b. Issue the show interfaces trunk and show spanning-tree commands on S1 and S3. What trunk port is
listed? What is the native VLAN? What is concluding result from the output?
____________________________________________________________________________________
____________________________________________________________________________________
From the show spanning-tree output, what is port cost and port priority for the aggregated link?
____________________________________________________________________________________
S1(config-if-range)# no shutdown
S2(config-if-range)# no shutdown
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 6 of 18
Lab – Configuring EtherChannel
S3(config-if-range)# no shutdown
b. Verify that the EtherChannel has formed.
Device Configs
Switch S1
S1# show vlan brief
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 7 of 18
Lab – Configuring EtherChannel
boot-end-marker
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
system mtu routing 1500
!
!
no ip domain-lookup
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface Port-channel1
switchport trunk native vlan 99
switchport mode trunk
!
interface Port-channel2
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
channel-group 2 mode active
!
interface FastEthernet0/2
switchport trunk native vlan 99
switchport mode trunk
channel-group 2 mode active
!
interface FastEthernet0/3
switchport trunk native vlan 99
switchport mode trunk
channel-group 1 mode desirable
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 8 of 18
Lab – Configuring EtherChannel
!
interface FastEthernet0/4
switchport trunk native vlan 99
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet0/5
shutdown
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/7
shutdown
!
interface FastEthernet0/8
shutdown
!
interface FastEthernet0/9
shutdown
!
interface FastEthernet0/10
shutdown
!
interface FastEthernet0/11
shutdown
!
interface FastEthernet0/12
shutdown
!
interface FastEthernet0/13
shutdown
!
interface FastEthernet0/14
shutdown
!
interface FastEthernet0/15
shutdown
!
interface FastEthernet0/16
shutdown
!
interface FastEthernet0/17
shutdown
!
interface FastEthernet0/18
shutdown
!
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 9 of 18
Lab – Configuring EtherChannel
interface FastEthernet0/19
shutdown
!
interface FastEthernet0/20
shutdown
!
interface FastEthernet0/21
shutdown
!
interface FastEthernet0/22
shutdown
!
interface FastEthernet0/23
shutdown
!
interface FastEthernet0/24
shutdown
!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
shutdown
!
interface Vlan1
no ip address
!
interface Vlan99
ip address 192.168.99.11 255.255.255.0
!
ip http server
ip http secure-server
!
!
banner motd ^C
Unauthorized Access Prohibited.^C
!
line con 0
password 7 0822455D0A16
logging synchronous
login
line vty 0 4
password 7 0822455D0A16
login
line vty 5 15
password 7 1511021F0725
login
!
end
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 10 of 18
Lab – Configuring EtherChannel
Switch S2
S2# show vlan brief
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 11 of 18
Lab – Configuring EtherChannel
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 12 of 18
Lab – Configuring EtherChannel
!
interface FastEthernet0/9
shutdown
!
interface FastEthernet0/10
shutdown
!
interface FastEthernet0/11
shutdown
!
interface FastEthernet0/12
shutdown
!
interface FastEthernet0/13
shutdown
!
interface FastEthernet0/14
shutdown
!
interface FastEthernet0/15
shutdown
!
interface FastEthernet0/16
shutdown
!
interface FastEthernet0/17
shutdown
!
interface FastEthernet0/18
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/19
shutdown
!
interface FastEthernet0/20
shutdown
!
interface FastEthernet0/21
shutdown
!
interface FastEthernet0/22
shutdown
!
interface FastEthernet0/23
shutdown
!
interface FastEthernet0/24
shutdown
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 13 of 18
Lab – Configuring EtherChannel
!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
shutdown
!
interface Vlan1
no ip address
!
interface Vlan99
ip address 192.168.99.12 255.255.255.0
!
ip http server
ip http secure-server
!
banner motd ^C
Unauthorized Access Prohibited.^C
!
line con 0
password 7 060506324F41
logging synchronous
login
line vty 0 4
password 7 060506324F41
login
line vty 5 15
password 7 121A0C041104
login
!
end
Switch S3
S3# show vlan brief
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 14 of 18
Lab – Configuring EtherChannel
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 15 of 18
Lab – Configuring EtherChannel
!
interface FastEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
channel-group 3 mode passive
!
interface FastEthernet0/2
switchport trunk native vlan 99
switchport mode trunk
channel-group 3 mode passive
!
interface FastEthernet0/3
switchport trunk native vlan 99
switchport mode trunk
channel-group 1 mode auto
!
interface FastEthernet0/4
switchport trunk native vlan 99
switchport mode trunk
channel-group 1 mode auto
!
interface FastEthernet0/5
shutdown
!
interface FastEthernet0/6
shutdown
!
interface FastEthernet0/7
shutdown
!
interface FastEthernet0/8
shutdown
!
interface FastEthernet0/9
shutdown
!
interface FastEthernet0/10
shutdown
!
interface FastEthernet0/11
shutdown
!
interface FastEthernet0/12
shutdown
!
interface FastEthernet0/13
shutdown
!
interface FastEthernet0/14
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 16 of 18
Lab – Configuring EtherChannel
shutdown
!
interface FastEthernet0/15
shutdown
!
interface FastEthernet0/16
shutdown
!
interface FastEthernet0/17
shutdown
!
interface FastEthernet0/18
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/19
shutdown
!
interface FastEthernet0/20
shutdown
!
interface FastEthernet0/21
shutdown
!
interface FastEthernet0/22
shutdown
!
interface FastEthernet0/23
shutdown
!
interface FastEthernet0/24
shutdown
!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
shutdown
!
interface Vlan1
no ip address
!
interface Vlan99
ip address 192.168.99.13 255.255.255.0
!
ip http server
ip http secure-server
!
!
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 17 of 18
Lab – Configuring EtherChannel
banner motd ^C
Unauthorized Access Prohibited.^C
!
line con 0
password 7 045802150C2E
logging synchronous
login
line vty 0 4
password 7 110A1016141D
login
line vty 5 15
password 7 070C285F4D06
login
!
end
© 2013 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 18 of 18