0% found this document useful (0 votes)
24 views

ITNET02 Module 05 InterVLAN Routing

Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
24 views

ITNET02 Module 05 InterVLAN Routing

Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 42

Module 5

InterVLAN Routing

ITNET02

Basic Routing and Switching


Module Objectives

Module Title: InterVLAN Routing


Module Objectives:
▪ Describe options for configuring inter-VLAN routing

▪ Configure inter-VLAN routing using the router-on-a-stick and Layer 3 switching methods.

▪ Troubleshoot common interVLAN routing issues

Module References:
▪ CCNAv7 SRWE – Module 4

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 2
4.1 Review of Routing Configuration

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 3
Basic Routing Concepts
The Role of Routers
• Hosts in different logical networks cannot directly exchange data with each other
• A router is needed to forward packets between networks
• To send data out of their own subnet, devices must be configured with a default
gateway address in order to have the router handle packets destined for outside hosts

192.168.1.0/24

192.168.1.254/24
192.168.1.1/24
Gateway 192.168.1.254

192.168.1.2/24
Gateway 192.168.1.254
© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 4
Basic Router Configuration
Configure Router Interfaces
• Routers support LANs and WANs and can interconnect different types of networks; therefore,
they support many types of interfaces.
• To be available, an interface must be activated and configured with at least 1 IP address:

Task IOS Command

Enable IPv6 routing (only if using IPv6 addresses in the


Router(config)# ipv6 unicast-routing
network)

Enter interface configurations mode Router(config)# interface interface-id

Set an IPv4 address and mark Router(config-if)# ip address ip_addr subnet_mask

Set an IPv6 address and prefix length Router(config-if)# ipv6 address ipv6_addr/prefix

Activate the interface Router(config-if)# no shutdown

Set the interface description (Optional but good practice) Router(config-if)# description text

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 5
Basic Router Configuration
Configure Router Interfaces (Cont.)

Network A 192.168.1.1/24 192.168.2.1/24 Network B


192.168.1.0/24 2001:DB8:ACAD:1::1/64 2001:DB8:ACAD:2::1/64 192.168.2.0/24
2001:DB8:ACAD:1::/64 2001:DB8:ACAD:2::/64
G0/0 G0/1

R1
R1(config)# ipv6 unicast-routing
R1(config)# interface G0/0
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# ipv6 address 2001:db8:acad:1::1/64
R1(config-if)# description Connection to Network A
R1(config-if)# no shutdown
R1(config-if)# interface G0/1
R1(config-if)# ip address 192.168.2.1 255.255.255.0
R1(config-if)# ipv6 address 2001:db8:acad:2::1/64
R1(config-if)# description Connection to Network B
R1(config-if)# no shutdown © 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 6
R1(config-if)# end
Basic Router Configuration
IPv4 Loopback Interfaces
• The loopback interface is a logical interface not assigned to a physical port and can never be
connected to any other device. It is considered a software interface that is automatically placed in
an “up” state, as long as the router is functioning.
• Useful in testing and managing a Cisco IOS device because it ensures that at least one interface
will always be available. E.g. It can be used for testing purposes, such as testing routing processes
by emulating networks behind the router.
• Loopback interfaces are given the interface ID “Loopback” or “Lo” and a number. They are
configured just like any other physical interface.
• Example:

R1(config)# interface Loopback0


R1(config-if)# ip address 192.168.255.1 255.255.255.0
R1(config-if)# ipv6 address 2001:db8:acad:ffff::1/64
R1(config-if)# description Loopback interface for testing
R1(config-if)# no shutdown
R1(config-if)# end

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 7
Verify Directly Connected Networks
Interface Verification Commands
The following commands are useful to quickly identify the status of an interface:
• show ip interface brief and show ipv6 interface brief - Display a summary for all
interfaces including the interface IPv4 or IPv6 address and current operational status.
• .
R1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 192.168.1.1 YES manual up up
GigabitEthernet0/1 192.168.2.1 YES manual up up
Loopback0 192.168.255.1 YES manual up up
R1#show ipv6 interface brief
GigabitEthernet0/0 [up/up]
FE80::201:96FF:FE03:BD01
2001:DB8:ACAD:1::1
GigabitEthernet0/1 [up/up]
FE80::201:96FF:FE03:BD02
2001:DB8:ACAD:2::1
Loopback0 [up/up]
FE80::201:64FF:FEE1:B319
2001:DB8:ACAD:FFFF::1 © 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 8
Verify Directly Connected Networks
Interface Verification Commands
The following commands are useful to quickly identify the status of an interface:
• show ip route and show ipv6 route - Display the contents of the IPv4 or IPv6 routing
table stored in RAM.
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
. . .

Gateway of last resort is not set

192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks


C 192.168.1.0/24 is directly connected, GigabitEthernet0/0
L 192.168.1.1/32 is directly connected, GigabitEthernet0/0
192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.2.0/24 is directly connected, GigabitEthernet0/1
L 192.168.2.1/32 is directly connected, GigabitEthernet0/1
192.168.255.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.255.0/24 is directly connected, Loopback0
L 192.168.255.1/32 is directly connected, Loopback0
© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 9
Verify Directly Connected Networks
Interface Verification Commands
The following commands are useful to quickly identify the status of an interface:
• show ip route and show ipv6 route - Display the contents of the IPv4 or IPv6 routing
table stored in RAM.
R1#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
. . .
C 2001:DB8:ACAD:1::/64 [0/0]
via GigabitEthernet0/0, directly connected
L 2001:DB8:ACAD:1::1/128 [0/0]
via GigabitEthernet0/0, receive
C 2001:DB8:ACAD:2::/64 [0/0]
via GigabitEthernet0/1, directly connected
L 2001:DB8:ACAD:2::1/128 [0/0]
via GigabitEthernet0/1, receive
C 2001:DB8:ACAD:FFFF::/64 [0/0]
via Loopback0, directly connected
L 2001:DB8:ACAD:FFFF::1/128 [0/0] © 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 10
via Loopback0, receive
4.2 Inter-VLAN Routing
Operation

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 11
Inter-VLAN Routing Operation
What is Inter-VLAN Routing?
• VLANs are used to segment switched Layer 2 networks for a variety of reasons.
• Each VLAN is a unique broadcast domain and IP subnetwork.
• Hosts in one VLAN cannot communicate with hosts in another VLAN unless there is a router or a
Layer 3 switch to provide routing services.

• Inter-VLAN routing is the process of forwarding network traffic from one VLAN to another VLAN.

• There are three inter-VLAN routing options:


• Legacy Inter-VLAN routing - This is a legacy solution. It does not scale well.
• Router-on-a-Stick - This is an acceptable solution for a small to medium-sized
network.
• Layer 3 switch using switched virtual interfaces (SVIs) - This is the most scalable
solution for medium to large organizations.

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 12
Inter-VLAN Routing Operation
Legacy Inter-VLAN Routing

• Relies on using a router


with multiple Ethernet
interfaces.
• Each router interface is
connected to a switch
port on a different VLAN,
serving as the default
gateway to the local
hosts on the VLAN
subnet

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 13
Inter-VLAN Routing Operation
Legacy Inter-VLAN Routing
Example:

R1(config)# interface G0/0/0


R1(config-if)# ip address 192.168.10.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# interface G0/0/1
R1(config-if)# ip address 192.168.20.1 255.255.255.0
R1(config-if)# no shutdown

VLAN 10 VLAN 20

S1(config)# interface Fa0/1


S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 10
S1(config)# interface Fa0/12
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 20 © 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 14
Inter-VLAN Routing Operation
Legacy Inter-VLAN Routing
R1#show ip route
. . .
Gateway of last resort is not set

C 192.168.10.0/24 is directly connected, GigabitEthernet0/0/0


C 192.168.20.0/24 is directly connected, GigabitEthernet0/0/1

• Not scalable because routers have a


limited number of physical interfaces.
• Requiring one physical router
interface per VLAN quickly exhausts
the physical interface capacity of a
router.
• This method is no longer
implemented in switched networks

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 15
4.3 Router-on-a-Stick
Inter-VLAN Routing

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 16
Inter-VLAN Routing Operation
Router-on-a-Stick Inter-VLAN Routing
• The ‘router-on-a-stick’ inter-VLAN routing
method enables one physical Ethernet interface
to route traffic between multiple VLANs on a
network.
• A router Ethernet interface is configured as an
802.1Q trunk and connected to a trunk port on
a Layer 2 switch.
• The router interface is logically divided into
subinterfaces, each assigned to a routable
VLAN.
• The configured subinterfaces are software-
based virtual interfaces.
• Each subinterface is independently
configured with a VLAN assignment and an
IP address corresponding to the subnet of
their VLAN
© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 17
Inter-VLAN Routing Operation
Router-on-a-Stick Inter-VLAN Routing
• Since the link to the router is a trunk, traffic
entering the router will remain tagged with the
VLAN ID of the sending host
• When VLAN-tagged traffic enters the router
interface, it is forwarded to the VLAN
subinterface.
802.1q-tagged frames
• After a routing decision is made based on the
destination IP network address, the router
determines the exit interface for the traffic.
• If the exit interface is configured as an 802.1q
subinterface, the data frames are VLAN-tagged
with the new VLAN and sent back out the
physical interface
• Note: The router-on-a-stick method of inter-
VLAN routing does not scale beyond 50 VLANs.
© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 18
Inter-VLAN Routing Configuration
Router-on-a-Stick Configuration Procedure
To configure inter-VLAN routing using the router-on-a-stick method:
• Step 1. Set the switch interface to trunk mode
• Step 2. Create and configure subinterfaces on the router
Subinterface VLAN IP Address

G0/0/1.10 10 192.168.10.1/24

G0/0/1.20 20 192.168.20.1/24

S1(config)# interface G0/0


S1(config-if)# switchport mode trunk

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 19
Inter-VLAN Routing Configuration
Router Subinterface Configuration
• Step 2. Create and configure subinterfaces on the router
Task IOS Command

Enter interface configurations mode on the physical interface Router(config)# interface interface-id

Activate the interface Router(config-if)# no shutdown

Create a subinterface Router(config-if)# interface interface-id.subid

Configure subinterface encapsulation and assign to VLAN


*Add the native parameter if the assigned VLAN is the native Router(config-subif)# encapsulation dot1q vlan_id [native]
VLAN of the switch

Set an IPv4 address and mark Router(config-subif)# ip address ip_addr subnet_mask

• Notes:
• Manually activating/deactivating the main interface automatically activates / deactivates all its subinterfaces
• Subinterfaces may be individually enabled / disabled, but the main physical interface must be enabled for
any of its subinterfaces to be active
© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 20
Inter-VLAN Routing Configuration
Router Subinterface Configuration
• Step 2. Create and configure subinterfaces on the router
Subinterface VLAN IP Address

G0/0/0.10 10 192.168.10.1/24
R1(config)# interface G0/0/0
R1(config-if)# no shutdown G0/0/0.20 20 192.168.20.1/24
R1(config-if)# interface G0/0/0.10
R1(config-subif)# encapsulation dot1q 10
R1(config-subif)# ip address 192.168.10.1 255.255.255.0
R1(config-if)# interface G0/0/0.20
R1(config-subif)# encapsulation dot1q 20
R1(config-subif)# ip address 192.168.20.1 255.255.255.0
R1(config-subif)#end

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 21
Router-on-a-Stick Inter-VLAN Routing
Router-on-a-Stick Inter-VLAN Routing Verification
The show interface, show ip interface brief and show ip route commands can
be used to verify and troubleshoot the router-on-a-stick configuration.
R1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0/0 none YES manual up up
GigabitEthernet0/0/0.10 192.168.10.1 YES manual up up
GigabitEthernet0/0/0.20 192.168.20.1 YES manual up up
GigabitEthernet0/0/1 none YES manual administratively down administratively do

R1#show interface G0/0/0.10


GigabitEthernet0/0/0.10 is up, line protocol is up (connected)
Hardware is PQUICC_FEC, address is 0001.9603.bd01 (bia 0001.9603.bd01)
Internet address is 192.168.10.1/24
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 10
ARP type: ARPA, ARP Timeout 04:00:00,
Last clearing of "show interface" counters never

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 22
Router-on-a-Stick Inter-VLAN Routing
Router-on-a-Stick Inter-VLAN Routing Verification
The show interface, show ip interface brief and show ip route commands can
be used to verify and troubleshoot the router-on-a-stick configuration.
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
. . .

Gateway of last resort is not set

192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks


C 192.168.10.0/24 is directly connected, GigabitEthernet0/0/0.10
L 192.168.10.1/32 is directly connected, GigabitEthernet0/0/0.10
192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.20.0/24 is directly connected, GigabitEthernet0/0/0.20
L 192.168.20.1/32 is directly connected, GigabitEthernet0/0/0.20

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 23
4.4 Inter-VLAN Routing using
Layer 3 Switches

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 24
Inter-VLAN Routing Operation
Inter-VLAN Routing on a Layer 3 Switch

• The modern method of performing


inter-VLAN routing is to use Layer 3
(a.k.a. multilayer) switches and
switched virtual interfaces (SVI).
• An SVI is a virtual interface that is
configured on a Layer 3 switch
• Inter-VLAN SVIs are created for VLANs
existing on the switch in the same way
that the management VLAN interface is
configured.
• Although virtual, the SVI performs the
L3 processing functions for the VLAN
as a router interface would.

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 25
Inter-VLAN Routing using Layer 3 Switches
Layer 3 Switch Inter-VLAN Routing
• Enterprise campus LANs use Layer 3 switches
instead of routers to provide inter-VLAN routing
and commonly place them in the distribution layer.
• Layer 3 switches use specialized hardware-based
switching processors to achieve higher-packet
processing rates than routers.
• Capabilities of a Layer 3 switch include following:
• Route from one VLAN to another using multiple
switched virtual interfaces (SVIs).
• Convert a Layer 2 switchport to a Layer 3 interface
(i.e., a routed port). A routed port is similar to a
physical interface on a Cisco IOS router.

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 26
Inter-VLAN Routing Operation
Benefits of Inter-VLAN Routing on a Layer 3 Switch

• Advantages:
• No need for external links from the switch
to the router for routing.
• Not limited to one link because aggregated
trunk links can be used to link switches for
increased bandwidth.
• Latency is much lower because data does
not need to leave the switch in order to be
routed to a different network.
• Much faster than router-on-a-stick because
everything is hardware switched and
routed.

• The only disadvantage is that Layer 3


switches are more expensive.
© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 27
Inter-VLAN Routing using Layer 3 Switches S1(config)# vlan 10
Layer 3 Switch Configuration S1(config-vlan)# vlan 20
S1(config-vlan)# exit
S1(config)# interface range F0/1-2
Procedure to configure L3 S1(config-if-range)# switchport mode access
switching: S1(config-if-range)# switchport access vlan 10
S1(config)# interface range F0/3-4
• Step 1. Create the VLANs and S1(config-if-range)# switchport mode access
assign access ports S1(config-if-range)# switchport access vlan 20

F0/1 F0/3

F0/2 F0/4

192.168.10.11 192.168.20.11

VLAN 10 VLAN 20
Default gateway: Default gateway:
192.168.10.1 192.168.20.1
192.168.10.12 192.168.20.12

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 28
Inter-VLAN Routing using Layer 3 Switches S1(config)# interface vlan 10
Layer 3 Switch Configuration S1(config-if)# ip address 192.168.10.1 255.255.255.0
S1(config-if)# no shutdown
Procedure to configure L3 S1(config)# interface vlan 20
S1(config-if)# ip address 192.168.20.1 255.255.255.0
switching: S1(config-if)# no shutdown
S1(config-if)# exit
• Step 1. Create the VLANs and S1(config)# ip routing
assign access ports

• Step 2. Create the SVI VLAN


interfaces. The IP address F0/1 F0/3
configured will serve as the
F0/2 F0/4
default gateway for hosts in
the respective VLAN.

• Step 3. Enable IP routing on


the L3 switch to allow traffic to
be exchanged between VLANs 192.168.10.11 192.168.20.11
using the ‘ip routing’
command VLAN 10 VLAN 20
Default gateway: Default gateway:
192.168.10.1 192.168.20.1
192.168.10.12 192.168.20.12
© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 29
Inter-VLAN Routing using Layer 3 Switches
Routing on a Layer 3 Switch
S1(config)# interface G0/1
S1(config-if)# no switchport
• If VLANs need to be reachable by S1(config-if)# ip address 192.168.1.2 255.255.255.252
other Layer 3 devices such as S1(config-if)# end
routers, then they must be advertised
using static or dynamic routing.
• To interface a Layer 3 switch with a
G0/1 G0/1
router, a routed port must be 192.168.1.1
configured as follows:
Step 1: Disable the switching feature
on a Layer 2 port that is connected to
another Layer 3 device using the ‘no
switchport’ command
Step 2: Configure IP address on the
VLAN 10 VLAN 20
port
Default gateway: Default gateway:
192.168.10.1 192.168.20.1

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 30
Inter-VLAN Routing using Layer 3 Switches
Layer 3 Switch Inter-VLAN Routing Verification
The show ip route command can be used to verify the routing status of the
switch.
S1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.1.0/30 is directly connected, GigabitEthernet0/1


C 192.168.10.0/24 is directly connected, Vlan10
C 192.168.20.0/24 is directly connected, Vlan20

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 31
4.4 Troubleshoot Inter-VLAN
Routing

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 32
Troubleshoot Inter-VLAN Routing
Common Inter-VLAN Issues
There are a number of reasons why an inter-VAN configuration may not work. All of them will manifest as
connectivity issues between hosts in the network.

Issue Type How to Fix How to Verify

show vlan [brief]


• Create (or re-create) the VLAN if it does not exist.
Missing VLANs show interfaces switchport
• Ensure host port is assigned to the correct VLAN.
ping

• Ensure trunks are configured correctly. show interface trunk


Switch Trunk Port Issues
• Ensure port is a trunk port and enabled. show running-config
• Router subinterface IPv4 address is incorrectly
Router Configuration configured. show ip interface brief
Issues • Router subinterface is assigned with an incorrect show interfaces
VLAN ID.
• Assign correct default gateway address to hosts
Default Gateway based on their VLAN membership ishow ip interface brief
Configuration Issues • Default gateway must match the router subinterface ipconfig
assigned to the VLAN

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 33
Troubleshoot Inter-VLAN Routing
Troubleshoot Inter-VLAN Routing Scenario

Examples of some of these inter-VLAN routing


problems will now be covered in more detail.
This topology will be used for all of these
issues.

Router R1 Subinterfaces

Subinterface VLAN IP Address

G0/0/0.10 10 192.168.10.1/24

G0/0/0.20 20 192.168.20.1/24

G0/0/0.30 99 192.168.99.1/24

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 34
Troubleshoot Inter-VLAN Routing
Missing VLANs

• A VLAN could be missing if it was not


created, it was accidently deleted, or it S1#show int fa0/6 switchport
Name: Fa0/6
is not allowed on the trunk link. Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
• When a VLAN is deleted, any ports Administrative Trunking Encapsulation: dot1q
assigned to that VLAN become inactive Operational Trunking Encapsulation: native
until reassigned to a new VLAN or the Negotiation of Trunking: Off
missing VLAN is recreated. Access Mode VLAN: 10 (inactive)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
• To verify: show interface interface- ...
id switchport

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 35
Troubleshoot Inter-VLAN Routing
Switch Trunk Port Issues
• Another issue for inter-VLAN routing includes misconfigured switch ports.
• In a legacy inter-VLAN solution, this could be caused when the port connected to the router is not set
as an access port or is not assigned to the correct VLAN.
• In a router-on-a-stick solution, the most common cause is a misconfigured trunk port.
• To verify: show interface trunk
S1#show interface trunk
Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 1

Port Vlans allowed on trunk


Fa0/1 1-4094

Port Vlans allowed and active in management domain


Fa0/1 1,10,20,99

Port Vlans in spanning tree forwarding state and not pruned


Fa0/1 1,10,20,99

Switch#
© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 36
Troubleshoot Inter-VLAN Routing
Router Configuration Issues
• Router-on-a-stick configuration problems are usually related to subinterface
misconfigurations.
• To verify subinterface status: show ip interface brief
• To verify VLANs assignment: show interfaces - Optionally use the include keyword to filter
output and show only line containing the physical interface ID and “802.1Q”

Router>show interfaces | include Gig|802.1q


GigabitEthernet0/0/0 is administratively down, line protocol is down
GigabitEthernet0/0/1 is up, line protocol is up (connected)
Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set
GigabitEthernet0/0/1.10 is up, line protocol is up (connected)
Encapsulation 802.1Q Virtual LAN, Vlan ID 100
GigabitEthernet0/0/1.20 is up, line protocol is up (connected)
Encapsulation 802.1Q Virtual LAN, Vlan ID 20
GigabitEthernet0/0/1.99 is up, line protocol is up (connected)
Encapsulation 802.1Q Virtual LAN, Vlan ID 99

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 37
Troubleshoot Inter-VLAN Routing
Default Gateway Configuration Issues

• Assigning the wrong gateway


address causes devices to lose C:\WINDOWS\system32>ipconfig

connectivity to those outside their Windows IP Configuration


VLAN
Ethernet adapter Local Area Connection* 1:
• The default gateway setting
should use the router IP address Connection-specific DNS Suffix . :
IPv4 Address. . : . . . . . . . . : 192.168.10.10
on the subinterface or L3 SVI Subnet Mask . . . . . . . . . . . : 255.255.255.0
assigned to the same VLAN as Default Gateway . . . . . . . . . : 192.168.20.1
the host.
• To verify: ipconfig

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 38
Questions?
Module Summary
What You Learned In This Module
• Inter-VLAN routing is the process of forwarding network traffic from one VLAN to another
VLAN.
• Three options include legacy, router-on-a-stick, and Layer 3 switch using SVIs.
• The legacy method
• Requires an access connection from the switch to the router for each VLAN
• Requires a physical interface per VLAN from the router to serve as gateway
• The router-on-a-stick method
• Requires a trunk connection from the switch to the router
• Requires a subinterface to be created for each VLAN to be routed.
• Each router subinterface must be assigned an IP address on a unique subnet for routing to
occur.
• Recommended for small to medium sized networks

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 40
Module Summary
What You Learned In This Module
• Inter-VLAN routing is the process of forwarding network traffic from one VLAN to another
VLAN.
• Three options include legacy, router-on-a-stick, and Layer 3 switch using SVIs.
• The L3 switching method
• Uses switches that capable of routing packets using hardware-based switching to achieve
higher-packet processing rates than routers.
• Layer 3 switches can route from one VLAN to another using multiple switched virtual
interfaces (SVIs) and converting a Layer 2 switchport to a Layer 3 interface (i.e. a routed
port).
• Recommended for enterprise campus networks
• Common causes of errors in interVLAN routing are: missing VLANs, misconfigured port
modes, incorrect routing interface IP address / VLAN assignment and incorrect host default
gateway settings

© 2016 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 41

You might also like