0% found this document useful (0 votes)
24 views

Assignment 4

The document provides instructions for configuring static and dynamic NAT on two routers. For static NAT, it defines inside and outside interfaces on each router and maps a private IP to a public IP. For dynamic NAT, it creates an address pool, defines an access list to match inside traffic, and maps inside traffic to addresses in the pool. It also provides IP configurations for PCs and a server to test the NAT configurations.
Copyright
© © All Rights Reserved
Available Formats
Download as DOCX, PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
24 views

Assignment 4

The document provides instructions for configuring static and dynamic NAT on two routers. For static NAT, it defines inside and outside interfaces on each router and maps a private IP to a public IP. For dynamic NAT, it creates an address pool, defines an access list to match inside traffic, and maps inside traffic to addresses in the pool. It also provides IP configurations for PCs and a server to test the NAT configurations.
Copyright
© © All Rights Reserved
Available Formats
Download as DOCX, PDF, TXT or read online on Scribd
You are on page 1/ 4

Computer Networks (LAB)

Assignment 4

Name: Ibrahim Khalilullah (F2020266029), V2


Submitted to: Sir Muhammad Tanveer
Setup for Static NAT

Router 1 Setup:
Enable the Router and enter Terminal with commands:
“Router>enable”
“Router#config t”
Router(config)#
then do following:
Router(config)#hostname R1

R1(config)# int FastEthernet 0/0


R1(config-if)# ip address 10.0.0.1 255.0.0.0
R1(config-if)# ip nat inside
R1(config-if)# exit

R1(config)# int FastEthernet 0/1


R1(config-if)# ip address 192.168.0.1 255.255.255.0
R1(config-if)# ip nat outside
R1(config-if)# exit

R1(config)# ip nat inside source static 10.0.0.2 200.200.200.1

R1# show ip nat translations

Router 2 Setup:
Enable the Router and enter Terminal with commands:
“Router>enable”
“Router#config t”
Router(config)#
then do following:
Router(config)#hostname R2

R2(config)# int FastEthernet 0/0


R2(config-if)# ip address 20.0.0.1 255.0.0.0
R2(config-if)# ip nat inside
R2(config-if)# exit

R2(config)# int FastEthernet 0/1


R2(config-if)# ip address 192.168.0.2 255.255.255.0
R2(config-if)# ip nat outside
R2(config-if)# exit

R2(config)# ip nat inside source static 20.0.0.2 200.200.200.1

R2# show ip nat translations

PC 1 Setup:
IP address: 10.0.0.2
Subnet: 255.0.0.0

PC 2 Setup:
IP address: 10.0.0.3
Subnet: 255.0.0.0

Server Setup:
IP address: 20.0.0.2
Subnet: 255.0.0.0

Setup for Dynamic NAT


Router 1 Setup:
R1(config)# int FastEthernet 0/0
R1(config-if)# ip address 10.0.0.1 255.0.0.0
R1(config-if)# ip nat inside
R1(config-if)# exit

R1(config)# int FastEthernet 0/1


R1(config-if)# ip address 192.168.0.1 255.255.255.0
R1(config-if)# ip nat outside
R1(config-if)# exit

R1(config)# ip nat pool mypool 150.150.1.1 150.150.1.10 netmask 255.255.0.0

R1(config)# ip nat inside source list 10 pool mypool

R1(config)# access-list 10 permit 10.0.0.0 0.255.255.255

R1(config)# int FastEthernet 0/0


R1(config-if)# ip access-group 50 out

R1# show ip nat translations

Router 2 Setup:
R2(config)# int FastEthernet 0/0
R2(config-if)# ip address 20.0.0.1 255.0.0.0
R2(config-if)# ip nat inside
R2(config-if)# exit

R2(config)# int FastEthernet 0/1


R2(config-if)# ip address 192.168.0.2 255.255.255.0
R2(config-if)# ip nat outside
R2(config-if)# exit

R2(config)# ip nat pool mypool 150.150.1.1 150.150.1.10 netmask 255.255.0.0

R2(config)# ip nat inside source list 10 pool mypool

R2(config)# access-list 10 permit 20.0.0.0 0.255.255.255

R2(config)# int FastEthernet 0/0


R2(config-if)# ip access-group 50 out

R2# show ip nat translations

PC 1 Setup:
IP address: 10.0.0.2
Subnet: 255.0.0.0
Ping 192.168.1.2

PC 2 Setup:
IP address: 10.0.0.3
Subnet: 255.0.0.0
Ping 192.168.1.2

Server Setup:
IP address: 20.0.0.2
Subnet: 255.0.0.0

You might also like