CSE 4512 Computer Networks-Lab 07

Download as pdf or txt
Download as pdf or txt
You are on page 1of 17

CSE 4512 [Computer Networks Lab]

Lab # 07

1. Objectives:
● Define and describe the concept of static routing
● Explain practical static routing concepts used in cisco devices
● Configure static routing in a network topology following given specifications
● Describe the concept of dynamic routing
● Explain disadvantages of RIPv1 and improvement in RIPv2
● Configure Routing Information Protocol (RIP) in a network topology following given
specifications

2. Theory:
As with other labs, this lab will also build up on the concepts and techniques of previous labs. So, make
sure you've properly understood the previous lab contents.

Static Routing:
By now, you all know that routers take the help of routing table to forward packets to the intended
destinations. When a packet reaches the router, it looks up the routing table, finds the corresponding
output interfaces for the destination network address and sends the packet through that interface. The
question is how this routing table is formed in the first place. The answer is either manually configuring
the routing entries or using routing protocols to configure the routes dynamically. The first approach is
called static routing and this is what we'll talk about and learn in this lab. The second approach is the
topic of next lab.
In static routing, the network administrator manually adds the routing entries to the routing table. The
routing entries will not be changed automatically. All changes have to be done manually. If the network
condition changes (for example, some link goes down), then the necessary changes in the routing table
must be done manually whereas these info are updated automatically in dynamic routing.
In practical large networks, static routing is mostly used as a backup to dynamic routing. Unlike
dynamic routing, static routing requires very less computational resource and bandwidth as no extra
packet is required for routing table update process. But as the network administrator needs to know the
whole network topology and network addresses to effectively configure the routing table, static routing
is not used as the only routing mechanism in large scale networks.

There are some concepts related to static routing that you need to be familiar with before you get your
hands dirty. You know that packets travel from one hop to the next to reach its final destination. In the
routing table of a router, the next hop address is associated with a certain destination address. Its not
realistic to assume that there would be next-hop entry for every possible destination network. That’s why
a routing entry known as the default route is present in the routing table. It defines a default exit
interface for the packets that don't have any corresponding route in the routing table.

1
When working with CISCO devices and specifically for this lab, you'll encounter two types of static
default routes. One is directly connected static default route and another is next-hop static default
route. You'll have to configure these two types of routes in this lab.

The general format of the command to specify static routes is:

ip route destination_network_prefix destination_prefix_mask


(next-hop_address | interface) [distance_metric]
ipv6 route ipv6_destination_network_prefix(with CIDR) (ipv6_next-hop_address
| interface) [distance_metric]

In case of directly connected static default routes, you'll specify the interface. In case of next-hop
static default routes, you'll specify the next_hop address. One special use case of the above
command is to configure a primary static default route where both the
destination_network_prefix and destination_prefix_mask are 0.0.0.0. The IPv4 and IPv6
command format for specifying primary static default route is given below:

ip route 0.0.0.0 0.0.0.0 (next-hop_address | interface) [distance_metric]


ipv6 route ::/0 (ipv6_next-hop_address | interface) [distance_metric]

The above commands basically mean that "packets from any IP address with any subnet mask get sent to
the specified next-hop address or interface".

Another concept when configuring static routing is the floating static route. A floating route is nothing
but the route that’s used to forward a packet to a certain destination when main route is unavailable. The
way floating routes are defined is by providing a higher distance_metric to a certain route. The
default distance_metric when its not manually specified is 1. The floating static routes are given
higher numbers than 1. Routers always take the route with lower distance_metric when multiple
routes to the same destination are available. That's why this floating static route will only be used when
main route is down or unavailable.

Dynamic Routing:
In the previous lab you learnt the concept of static routing and how to configure static routing in a
network. You also saw that static routing has some serious disadvantages when it comes to configure
large-scale networks. Network administrator needs to know about the whole topology and the network
changes have to be reflected manually in the configuration. In this lab, you'll learn about dynamic
routing which overcomes all these issues but at the cost of bandwidth overhead. Still, its better to use
extra bandwidth than to configure everything manually.

Basically, dynamic routing lets routers to select routes based on the real-time network condition. Always
there will be packets travelling around the networks to keep the routers up-to-date about the present
network condition. Then the routers will select an optimal route to a given destination based on some set
of metrics. The dynamic routing protocols perform this basic function. As you know by now, there are

2
different types of dynamic routing protocols following different algorithms. Two most common ones are
Routing Information Protocol (RIP) following distance-vector algorithm and Open Shortest Path
First (OSPF) protocol following link state routing algorithm. We'll not look at how these algorithms
work. This is covered in your theory class. In this lab, we'll look at RIP only. OSPF will be covered in
next lab.

Routing Information Protocol (RIP)


Before starting, know that RIP is somewhat an obsolete protocol due to its limitations and the advent of
more modern and sophisticated protocols like OSPF, EIGRP etc. Still, as this was one of the pioneering
dynamic routing protocols and dominated the networking world for quite some time, you need to
understand this. This will help you in turn to understand the improvements made in newer protocols.
There are two versions of RIP namely RIPv1 and RIPv2. RIPv2 is the dominant one and is used almost
in all cases where RIP is used. So, we'll focus on RIPv2 only for our lab. Major problem of RIPv1 was
that it used to broadcast routing table updates every 30 seconds. You can imagine the flood of packets
every 30 seconds that would take place where millions of networks are now interconnected, even if they
are configured to send updates at random times. RIPv2 was designed to overcome this issue along with
other improvements. You can learn more on these two versions here.
RIP uses hop count as the metric for routes. Paths with lower metric are selected always for a given
destination. The max hop count is 15 for both versions of RIP to prevent loops. Any route further than
15 hops away are considered unreachable. To configure RIP, three steps are followed:
I. Enable RIP by using the router rip global configuration command.

II. Tell router to use the RIPv2 by the version 2 command.

III. Tell RIP which networks to advertise by using one or more network commands.

In the 3rd step, you don't need to specify any subnet mask when using the network command. The
network command takes a classful address as the parameter. As any address beginning with 10 belongs
to class A, RIP will be enabled on all the interfaces that has IP address that begins with 10.

3
3. Configure static routing:

I. Configure R1 Interfaces
R1(config)#int g0/0
R1(config-if)#ip add 192.168.1.1 255.255.255.0
R1(config-if)#desc connection-to-PC0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#int s0/1/0
R1(config-if)#ip add 192.168.0.2 255.255.255.252
R1(config-if)#desc connection-to-R3
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#int s0/1/1
R1(config-if)#ip add 192.168.0.6 255.255.255.252
R1(config-if)#desc connection-to-R2
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit

II. Configure R2 Interfaces


R2(config)#int s0/1/1
R2(config-if)#ip add 192.168.0.5 255.255.255.252
R2(config-if)#desc connection-to-R1
R2(config-if)#no shutdown
R2(config-if)#exit

4
R2(config)#int g0/0
R2(config-if)#ip add 192.168.2.1 255.255.255.0
R2(config-if)#desc connection-to-RemoteLAN
R2(config-if)#no shutdown
R2(config-if)#exit

III. Configure R3 Interfaces


R3(config)#int s0/1/0
R3(config-if)#ip add 192.168.0.1 255.255.255.252
R3(config-if)#desc connection-to-R1
R3(config-if)#no shutdown
R3(config-if)#exit

R3(config)#int g0/0
R3(config-if)#ip add 192.168.2.2 255.255.255.0
R3(config-if)#desc connection-to-RemoteLAN
R3(config-if)#no shutdown
R3(config-if)#exit

IV. Configure PC0


IP: 192.168.1.10
Mask: 255.255.255.0
Gateway: 192.168.1.1

V. Configure PC1
IP: 192.168.2.10
Mask: 255.255.255.0
Gateway: 192.168.2.1

VI. Configure static routing to Remote LAN in R1


R1(config)#ip route 192.168.2.0 255.255.255.0 s0/1/1
It’s a directly connected static default route.
R1(config)#ip route 192.168.2.0 255.255.255.0 192.168.0.1 5
It’s a next-hop floating static default route.

VII. Configure static routing to Local LAN in R2


R2(config)#ip route 192.168.1.0 255.255.255.0 s0/1/1
It’s a directly connected static default route.
R2(config)#ip route 192.168.1.0 255.255.255.0 192.168.0.6 5
It’s a next-hop floating static default route

VIII. Configure static routing to Local LAN in R3


R2(config)#ip route 192.168.1.0 255.255.255.0 s0/1/0
It’s a directly connected static default route.
R2(config)#ip route 192.168.1.0 255.255.255.0 192.168.0.2 5

5
It’s a next-hop floating static default route

IX. Verify
Ping PC1 from PC0

4. Configure RIP:

X. Configure R1 Interfaces
R1(config)# int g0/0
R1(config-if)# ip address 10.0.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

R1(config)# int g0/1


R1(config-if)# ip address 172.16.0.1 255.255.0.0
R1(config-if)# no shutdown
R1(config-if)# exit

R1# copy running-config startup-config

XI. Configure R2 Interfaces


R2(config)# int g0/1
R2(config-if)# ip address 192.168.0.1 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# exit

R2(config)# int g0/0


R2(config-if)# ip address 172.16.0.2 255.255.0.0
R2(config-if)# no shutdown
R2(config-if)# exit

R2# copy running-config startup-config

XII. Configure PC0


IP: 10.0.1.10
Mask: 255.255.255.0
Gateway: 10.0.1.1
6
XIII. Configure PC1
IP: 192.168.0.10
Mask: 255.255.255.0
Gateway: 192.168.0.1

XIV. Configure RIP in R1


R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.0.0.0
R1(config-router)#network 172.16.0.0

XV. Configure RIP in R2


R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 192.168.0.0
R2(config-router)#network 172.16.0.0

XVI. Verify
R1# show ip route rip

Ping PC1 from PC0

5. Tasks:

I. Task 1
You will implement IPv4 and IPv6 static routing following the address configurations in a given
network topology in this task. The task description for this task is provided in the pdf
Task-1_ipv4-and-ipv6-static-and-default-routes. You're provided a .pka file for this task.

7
Packet Tracer - Configure IPv4 and IPv6 Static and Default Routes
Addressing Table

Device Interface IP Address / Prefix

Edge_Router S0/0/0 10.10.10.2/30


Edge_Router S0/0/0
2001:db8:a:1::2/64
Edge_Router
S0/0/1 10.10.10.6/30
2001:db8:a:2::2/64
Edge_Router
S0/0/1

Edge_Router

G0/0 192.168.10.17/28
Edge_Router

G0/0
2001:db8:1:10::1/64
Edge_Router

G0/1 192.168.11.33/27
Edge_Router

G0/1
2001:db8:1:11::1/64
ISP1 S0/0/0 10.10.10.1/30
ISP1 S0/0/0
2001:db8:a:1::1/64
ISP1
G0/0 198.0.0.1/24
2001:db8:f:f::1/64
ISP1
G0/0

ISP2 S0/0/1 10.10.10.5/30


ISP2 S0/0/1
2001:db8:a:2::1/64
ISP2
G0/0 198.0.0.2/24
2001:db8:f:f::2/64
ISP2
G0/0

PC-A NIC 192.168.10.19/28

2001:db8:1:10::19/64
PC-A NIC

PC-B NIC 192.168.11.4/27


PC-B NIC
2001:db8:1:11::45
Customer Server NIC 198.0.0.10
Customer Server NIC
2001:db8:f:f::10

8
Packet Tracer - Configure IPv4 and IPv6 Static and Default Routes

Objectives
In this Packet Tracer summary activity, you will configure static, default, and floating static routes for both
the IPv4 and IPv6 protocols.
• Configure IPv4 Static and Floating Static Default Routes.
• Configure IPv6 static and floating static default routes.
• Configure IPv4 static and floating static routes to internal LANs.
• Configure IPv6 static and floating static routes to the internal LANS.
• Configure IPv4 host routes.
• Configure IPv6 host routes.

Background / Scenario
In this activity, you will configure IPv4 and IPv6 default static and floating static routes.
Note: The static routing approach that is used in this lab is used to assess your ability to configure different
types of static routes only. This approach may not reflect networking best practices.

Instructions
Part 1: Configure IPv4 Static and Floating Static Default Routes
Open configuration window

The PT network requires static routes to provide internet access to the internal LAN users through the ISPs.
In addition, the ISP routers require static routes to reach the internal LANs. In this part of the activity, you
will configure an IPv4 static default route and a floating default route to add redundancy to the network.

Step 1: Configure an IPv4 static default route.


On Edge_Router, configure a directly connected IPv4 default static route. This primary default route
should be through router ISP1.

Step 2: Configure an IPv4 floating static default route.


On Edge_Router, configure a directly connected IPv4 floating static default route. This default route
should be through router ISP2. It should have an administrative distance of 5.
Part 2: Configure IPv6 Static and Floating Static Default Routes
In this part of the activity, you will configure IPv6 static default and floating static default routes for IPv6.

Step 1: Configure an IPv6 static default route.


On Edge_Router, configure a next hop static default route. This primary default route should be through
router ISP1.

Step 2: Configure an IPv6 floating static default route.


On Edge_Router, configure a next hop IPv6 floating static default route. The route should be via router
ISP2. Use an administrative distance of 5.
Close configuration window

9
Packet Tracer - Configure IPv4 and IPv6 Static and Default Routes

Part 3: Configure IPv4 Static and Floating Static Routes to the Internal LANs
In this part of the lab you will configure static and floating static routers from the ISP routers to the internal
LANs.

Step 1: Configure IPv4 static routes to the internal LANs.


Open configuration window

a. On ISP1, configure a next hop IPv4 static route to the LAN 1 network through Edge_Router.
b. On ISP1, configure a next hop IPv4 static route to the LAN 2 network through Edge_Router.

Step 2: Configure IPv4 floating static routes to the internal LANs.


a. On ISP1, configure a directly connected floating static route to LAN 1 through the ISP2 router. Use an
administrative distance of 5.
b. On ISP1, configure a directly connected floating static route to LAN 2 through the ISP2 router. Use an
administrative distance of 5.

Part 4: Configure IPv6 Static and Floating Static Routes to the Internal LANs.

Step 1: Configure IPv6 static routes to the internal LANs.


c. On ISP1, configure a next hop IPv6 static route to the LAN 1 network through Edge_Router.
d. On ISP1, configure a next hop IPv6 static route to the LAN 2 network through Edge_Router.

Step 2: Configure IPv6 floating static routes to the internal LANs.


a. On ISP1, configure a next hop IPv6 floating static route to LAN 1 through the ISP2 router. Use an
administrative distance of 5.
b. On ISP1, configure a next hop IPv6 floating static route to LAN 2 through the ISP2 router. Use an
administrative distance of 5.
If your configuration has been completed correctly, you should be able to ping the Web Server from the
hosts on LAN 1 and LAN 2. In addition, if the primary route link is down, connectivity between the LAN
hosts and the Web Server should still exist.
Close configuration window

Part 5: Configure Host Routes


Users on the corporate network frequently access a server that is owned by an important customer. In this
part of the activity, you will configure static host routes to the server. One route will be a floating static route
to support the redundant ISP connections.

Step 1: Configure IPv4 host routes.


Open configuration window

a. On Edge Router, configure an IPv4 directly connected host route to the customer server.
b. On Edger Router, configure an IPv4 directly connected floating host route to the customer sever. Use an
administrative distance of 5.

10
Step 2: Configure IPv6 host routes.
a. On Edge Router, configure an IPv6 next hop host route to the customer server through the ISP1 router.
b. On Edger Router, configure an IPv6 directly connected floating host route to the customer sever through
the ISP2 router. Use an administrative distance of 5.
Close configuration window
End of document

II. Task 2
You will implement RIP following the address configurations and answer the given questions in this
task. The task description for this task is provided in the pdf Task-1_RIP. You're not provided a .pka
file for this task. You need to create the topology on your own.

Lab 6.1.5 Configuring and Verifying RIP

11
Host
Device Name Interface IP Address Subnet Mask
R1 R1 Serial 0/0/0 (DCE) 172.X.0.1 255.255.255.224
Fast Ethernet 0/0 172.X+1.0.1 255.255.255.0

R2 R2 Serial 0/0/0 (DTE) 172.X.0.2 255.255.255.224


Fast Ethernet 0/0 172.X+2.0.1 255.255.255.0
X=Last 2 digits of your student ID

Objectives
• Implement RIP routing and verify that network routes are being exchanged dynamically.

Background / Preparation
RIP is one of the most commonly used and widely supported routing protocols in the networking industry.
Knowledge of RIP and how to configure it using the Cisco IOS CLI is essential to success as a network
technician. In this lab, you build a multi-router network and use RIP to automatically propagate routes, so
hosts on remote networks can communicate.
Set up a network similar to the one in the diagram above. You can use any router or combination of routers
that meets the interface requirements in the diagram, such as 800, 1600, 1700, 1800, 2500, or 2600 routers.
Refer to the chart at the end of the lab to correctly identify the interface identifiers to be used based on the
equipment in the lab. Depending on the model of router, your output may vary from the output shown in this
lab. The lab steps are intended to be executed on each router, unless you are specifically instructed
otherwise.
From hosts H1 and H2, start a HyperTerminal session with each router.
Required Resources
The following resources are required:
• Two routers, each with an Ethernet and serial interface. These should be non-SDM routers, if
possible, because the required SDM startup configuration is deleted when the startup-config is
erased.
• Two Windows XP computers
• Two straight-through Category 5 Ethernet cables (H1 to switch and switch to R1)
• Crossover Category 5 Ethernet cable (H2 to router R2)
• Null serial cable
• Console cables (from H1 and H2 to routers R1 and R2)
• Access to the H1 and H2 command prompt
• Access to the H1 and H2 network TCP/IP configuration

Step 1: Build the network and configure the routers.


a. Build a network as shown in the topology diagram
b. In global configuration mode, configure the host names and interfaces according to the chart.
Note: See Lab 5.3.5 if you have difficulty with the basic router configuration. That lab provides
instructions for using the Cisco IOS CLI.

12
Step 2: Configure the hosts.
a. Configure host H1 attached to R1 with an IP address, subnet mask, and default gateway that is
compatible with the IP address of the R1 Fast Ethernet interface (172.16.0.1/24).
Host H1 IP configuration:
IP address: 172.16.0.2
Subnet mask: 255.255.0.0
Default gateway: 172.16.0.1
b. Configure host H2 attached to R2 with an IP address, subnet mask, and default gateway that is
compatible with the IP address of the R2 Fast Ethernet interface (172.18.0.1/24).
Host H2 IP configuration:
IP address: 172.18.0.2
Subnet mask: 255.255.0.0
Default gateway: 172.18.0.1

Step 3: Check the R1 routing table.


a. View the IP routing table for R1 using the show ip route command.
R1>show ip route
<output omitted>
Gateway of last resort is not set
C 172.16.0.0/16 is directly connected,
FastEthernet0/0
C 172.17.0.0/16 is directly connected,
Serial0/0/0
b. What is the significance of the “C” to the left of the 172.16.0.0 and 172.17.0.0 network entries in the
routing table?
__________________________________________________________________________
c. Is there a route in the R1 routing table to the R2 Ethernet network 172.18.0.0? ______ Why?
______________________________________________________________________________

Step 4: Test end-to-end connectivity.


a. From R1, ping the R2 router Fast Ethernet interface.
R1#ping 172.18.0.1
Are the pings successful? ____
b. From host H1, ping host H2 (from network 172.16.0.2 to network 172.18.0.2).
C:\>ping 172.18.0.2
Are the pings successful? _____
c. Why are the pings not successful? ___________________________________________________
_______________________________________________________________________________
________________________________________________________________________________

13
Step 5: Configure the routing protocol of the routers.
There are two versions of RIP: version 1 and version 2. It is important to specify RIP version 2 (RIPv2) in
this configuration, because RIPv2 is the most current version. Some routers default to RIPv2, but it is best
to not assume that is the case.
a. In global configuration mode, enter the following on R1.
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 172.16.0.0
R1(config-router)#network 172.17.0.0
R1(config-router)#exit
R1(config)#exit
b. Save the R1 router configuration.
R1#copy running-config startup-config
c. In global configuration mode, enter the following on R2.
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 172.17.0.0
R2(config-router)#network 172.18.0.0
R2(config-router)#exit
R2(config)#exit

d. Save the R2 router configuration.


R2#copy running-config startup-config

Step 6: View the routing tables for each router.


a. In enable or privileged EXEC mode, examine the routing table entries using the show ip route
command on router R1.
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M -
mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF
inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external
type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E
- EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area
* - candidate default, U - per-user static route, o -
ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 172.17.0.0/16 is directly connected, Serial0/0/0

14
C 172.16.0.0/16 is directly connected, FastEthernet0/0
R 172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:17, Serial0/0/0
b. Which networks are shown in the R1 routing table?
__________________________________________________________________________
__________________________________________________________________________
c. What is the significance of the “R” to the left of the 172.18.0.0 network entry in the routing table?
__________________________________________________________________________
d. What does “via 172.17.0.2” mean for this network route?
__________________________________________________________________________
e. What does “Serial0/0/0” mean for this network route?
__________________________________________________________________________
f. Examine the routing table entries on router R2.
R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile,
B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter
area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external
type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E -
EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia -
IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 172.17.0.0/16 is directly connected, Serial0/0/0


R 172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:13,
Serial0/0/0 C 172.18.0.0/16 is directly connected,
FastEthernet0/0
g. Which networks are shown in the R2 routing table?
__________________________________________________________________________
__________________________________________________________________________

Step 7: Test end-to-end connectivity.


a. From R1, ping the R2 router Fast Ethernet interface.
R1#ping 172.18.0.1
Are the pings successful? ____
b. From the host H1 command prompt, ping H2 (from network 172.16.0.2 to network 172.18.0.2).
C:\>ping 172.18.0.2
15
c. Are the pings successful? ____
If the answer is no for either question, troubleshoot the router configurations to find the error. Then do
the pings again until the answer to both questions is yes. Be sure to check physical cabling for problems
and bad connections, and make sure that you are using the correct cable types.
d. Why are the pings successful this time? _______________________________________________
_______________________________________________________________________________

Step 8: Use debug to observe RIP communications


Using the debug ip rip command, you can see real-time communication and updates passing between
routers that are running RIP.
Note: Running debug commands puts a significant load on the CPU of the router. Do not use debug
commands on a production network, if possible.
a. On router R1, enter the debug ip rip command from privileged EXEC mode. Examine the exchange
of routes between the two routers. The output should look similar to that shown here.
R1#debug ip rip
RIP protocol debugging is on
R1#
00:51:28: RIP: sending v2 update to 224.0.0.9 via Serial0/0/0
(172.17.0.1)
00:51:28: RIP: build update entries
00:51:28: 172.16.0.0/16 via 0.0.0.0, metric 1, tag 0
00:51:49: RIP: received v2 update from 172.17.0.2 on Serial0/0/0
00:51:49: 172.18.0.0/16 via 0.0.0.0 in 1 hops
00:51:57: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0
(172.16.0.1)
00:51:57: RIP: build update entries
00:51:57: 172.17.0.0/16 via 0.0.0.0, metric 1, tag 0
00:51:57: 172.18.0.0/16 via 0.0.0.0, metric 2, tag 0
b. Enter the command undebug all to stop all debugging activity.
R1#undebug all
All possible debugging has been turned off
R1#
c. What interface does router R1 send and receive updates through? ________________
d. Why does the route to 172.17.0.0 have a metric of 1, and the route to 172.18.0.0 have a metric of 2?
______________________________________________________________________________ e.
Log off by typing exit and turn off the router.

Step 9: Reflection
a. What would happen to the routing table on router R1 if the Ethernet network on router R2 went
down?
________________________________________________________________________________

16
________________________________________________________________________________
b. What would happen if router R1 was configured to run RIPv1, and R2 was configured to run RIPv2?
________________________________________________________________________________
________________________________________________________________________________
Router Interface Summary Table
Router Interface Summary
Router Ethernet Ethernet Serial Serial
Model Interface #1 Interface #2 Interface #1 Interface #2
800 (806) Ethernet 0 (E0) Ethernet 1 (E1)
1600 Ethernet 0 (E0) Ethernet 1 (E1) Serial 0 (S0) Serial 1 (S1)
1700 Fast Ethernet 0 Fast Ethernet 1 Serial 0 (S0) Serial 1 (S1)
(FA0) (FA1)
1800 Fast Ethernet Fast Ethernet Serial Serial 0/0/1
0/0 0/1 0/0/0 (S0/0/1)
(FA0/0) (FA0/1) (S0/0/0
)
2500 Ethernet 0 (E0) Ethernet 1 (E1) Serial 0 (S0) Serial 1 (S1)
2600 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/0 (S0/0) Serial 0/1
(FA0/0) (FA0/1) (S0/1)
Note: To find out exactly how the router is configured, look at the interfaces. The interface
identifies the type of router and how many interfaces the router has. There is no way to
effectively list all combinations of configurations for each router class. What is provided
are the identifiers for the possible combinations of interfaces in the device. This interface
chart does not include any other type of interface, even though a specific router may
contain one. An example of this might be an ISDN BRI interface. The information in
parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent
the interface.

17

You might also like