BGP Aggregation

Download as txt, pdf, or txt
Download as txt, pdf, or txt
You are on page 1of 4

Task

Configure BGP AS 8.10 on R8 & R10.


Configure BGP AS 100 on R1, R2, R3, R4, R5, and R6.
Configure BGP AS 200 on R7 and R9.
R8 & R10 should peer iBGP.
R7 & R9 should peer iBGP.
R5 should peer iBGP with all routers in AS 100; use OSPF as the IGP for AS 100.
AS 100 should peer EBGP with AS 200 and 8.10.
Advertise the Host5, Host7, Host8, Host9, and Host10 segments into BGP.
Configure AS 8.10 to advertise a summary route for the Host8 and Host10 segments to
AS 100.
Configure AS 200 to advertise a single summary of the Host7 & Host9 segments and
the Loopback0 addresses of R7 & R9 to AS 100; this summary should be as specific as
possible, but still include all four of these prefixes.
Configure route leaking from AS 200 to AS 100 to accomplish the following:
Traffic to the Loopback0 addresses of R7 & R9 should prefer to forward through R6.
Traffic to the Host7 and Host9 segments should prefer to forward through R3.
If either R3 or R6 is down, reachability should be maintained.
Routers outside of AS 100 should not see these specific routes, only the summary.
Solutions

R1:
interface Tunnel0
ip ospf 1 area 0
!
interface GigabitEthernet0/1
ip ospf 1 area 0
!
interface GigabitEthernet0/2
ip ospf 1 area 0
!
interface Loopback0
ip ospf 1 area 0
!
router bgp 100
neighbor 150.1.5.5 remote-as 100
neighbor 150.1.5.5 update-source Loopback0

R2:
interface Tunnel0
ip ospf 1 area 0
!
interface GigabitEthernet0/1
ip ospf 1 area 0
!
interface Loopback0
ip ospf 1 area 0
!
router bgp 100
neighbor 150.1.5.5 remote-as 100
neighbor 150.1.5.5 update-source Loopback0

R3:
interface Tunnel0
ip ospf 1 area 0
!
interface GigabitEthernet0/1
ip ospf 1 area 0
!
interface GigabitEthernet0/2
ip ospf 1 area 0
!
interface Loopback0
ip ospf 1 area 0
!
router bgp 100
neighbor 150.1.5.5 remote-as 100
neighbor 150.1.5.5 update-source Loopback0
neighbor 150.1.5.5 next-hop-self
neighbor 150.1.5.5 send-community both
neighbor 155.1.37.7 remote-as 200

R4:
interface Tunnel0
ip ospf 1 area 0
!
interface GigabitEthernet0/1
ip ospf 1 area 0
!
interface GigabitEthernet0/2
ip ospf 1 area 0
!
interface Loopback0
ip ospf 1 area 0
!
router bgp 100
neighbor 150.1.5.5 remote-as 100
neighbor 150.1.5.5 update-source Loopback0

R5:
interface Tunnel0
ip ospf network point-to-multipoint
ip ospf hello-interval 10
ip ospf 1 area 0
!
interface GigabitEthernet0/1
ip ospf 1 area 0
!
interface Loopback0
ip ospf 1 area 0
!
router bgp 100
network 155.1.5.0 mask 255.255.255.0
neighbor IBGP peer-group
neighbor IBGP remote-as 100
neighbor IBGP update-source Loopback0
neighbor IBGP route-reflector-client
neighbor IBGP next-hop-self
neighbor IBGP send-community both
neighbor 150.1.1.1 peer-group IBGP
neighbor 150.1.2.2 peer-group IBGP
neighbor 150.1.3.3 peer-group IBGP
neighbor 150.1.4.4 peer-group IBGP
neighbor 150.1.6.6 peer-group IBGP
neighbor 155.1.58.8 remote-as 8.10
R6:
interface GigabitEthernet0/0
ip ospf 1 area 0
!
interface Loopback0
ip ospf 1 area 0
!
router bgp 100
neighbor 150.1.5.5 remote-as 100
neighbor 150.1.5.5 update-source Loopback0
neighbor 150.1.5.5 next-hop-self
neighbor 150.1.5.5 send-community both
neighbor 155.1.67.7 remote-as 200

R7:
ip prefix-list R7-R9-LOOPBACKS permit 150.1.7.7/32
ip prefix-list R7-R9-LOOPBACKS permit 150.1.9.9/32
!
ip prefix-list HOST7-HOST9-NETWORKS permit 155.1.7.0/24
ip prefix-list HOST7-HOST9-NETWORKS permit 155.1.9.0/24
!
route-map UNSUPPRESS-R7-R9-LOOPBACKS permit 10
match ip address prefix-list R7-R9-LOOPBACKS
set community no-export
!
route-map UNSUPPRESS-HOST7-HOST9-NETWORKS permit 10
match ip address prefix-list HOST7-HOST9-NETWORKS
set community no-export
!
router bgp 200
aggregate-address 144.0.0.0 240.0.0.0 summary-only
network 155.1.7.0 mask 255.255.255.0
network 150.1.7.7 mask 255.255.255.255
neighbor 155.1.79.9 remote-as 200
neighbor 155.1.79.9 next-hop-self
neighbor 155.1.37.3 remote-as 100
neighbor 155.1.37.3 send-community both
neighbor 155.1.37.3 unsuppress-map UNSUPPRESS-HOST7-HOST9-NETWORKS
neighbor 155.1.67.6 remote-as 100
neighbor 155.1.67.6 send-community both
neighbor 155.1.67.6 unsuppress-map UNSUPPRESS-R7-R9-LOOPBACKS

R8:
router bgp 8.10
distance bgp 20 200 255
aggregate-address 155.1.8.0 255.255.252.0 summary-only
network 155.1.8.0 mask 255.255.255.0
neighbor 155.1.108.10 remote-as 8.10
neighbor 155.1.108.10 next-hop-self
neighbor 155.1.58.5 remote-as 100

R9:
router bgp 200
network 155.1.9.0 mask 255.255.255.0
network 150.1.9.9 mask 255.255.255.255
neighbor 155.1.79.7 remote-as 200

R10:
router bgp 8.10
network 155.1.10.0 mask 255.255.255.0
neighbor 155.1.108.8 remote-as 8.10

You might also like