0% found this document useful (0 votes)
273 views

Cisco Router Basic Network Configuration

This document provides instructions for a CCNA lab exercise on configuring IPv4 addressing on a Cisco router. The lab scenario has the student configure IP addresses on serial and fast ethernet interfaces to connect the router to other devices and subnets. Specifically, the student must set IP addresses on serial interfaces to connect to routers at specific IP addresses, assign IP addresses to fast ethernet interfaces for subnets with specified numbers of hosts, and configure host and gateway IPs. The goal is to test connectivity by having hosts ping a server IP address.

Uploaded by

Mitra
Copyright
© © All Rights Reserved
Available Formats
Download as DOCX, PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
273 views

Cisco Router Basic Network Configuration

This document provides instructions for a CCNA lab exercise on configuring IPv4 addressing on a Cisco router. The lab scenario has the student configure IP addresses on serial and fast ethernet interfaces to connect the router to other devices and subnets. Specifically, the student must set IP addresses on serial interfaces to connect to routers at specific IP addresses, assign IP addresses to fast ethernet interfaces for subnets with specified numbers of hosts, and configure host and gateway IPs. The goal is to test connectivity by having hosts ping a server IP address.

Uploaded by

Mitra
Copyright
© © All Rights Reserved
Available Formats
Download as DOCX, PDF, TXT or read online on Scribd
You are on page 1/ 42

Cisco Router Basic Network

Configuration (CCNA Lab 1-1)


Posted on July 29, 2013 by Alex — No Comments ↓

A good practice method for the CCNA exam (Cisco Certified Networking Associate) if you have the Cisco study tool Packet
Tracer is to download some practice labs that cover the CCNA objectives. A list of download links to 19 of these labs is
about half way down this page. For documentation about basic router configuration from Cisco, visit their page. For details
from Cisco on configuring Telnet, Console and AUX passwords, click here.

This first lab (1-1) covers basic Cisco router network configuration. I will walk you through all of the commands to
accomplish each objective of this lab. Before we get started, I will explain how to configure routers in the Packet Tracer lab
environment.

The way this lab has been setup resembles how you would configure a router in actuality. You must use the PC to open a
terminal (console) session to the router in order to configure it via the command line interface (CLI).

When the lab launches, click on “PC-PT Console Terminal”. This is the PC that has a console (light blue) cable connected to
the router that will be configured.
Click the “PC-PT Console Terminal” device.

Click the “Desktop” tab in the “Console Terminal” window.


Click the “Desktop” tab of the “Console Terminal” window.

Click the “Terminal” icon on the desktop.


Click the “Terminal” icon on the desktop.

Accept the default terminal configuration parameters by clicking “OK”.


Accept the default terminal configuration parameters by clicking “OK”.

Press the “enter” key to begin. Your prompt will show the router name followed by a greater than sign. This means that you
are in the User EXEC command mode.
Press the “enter” key to begin.

Type “enable” to enter the Privileged EXEC command mode and press “enter”. Remember that pressing the enter key will
tell the router to execute the command you have typed. The router name is now followed by a pound (#) symbol to show
this.
The router name is followed by a pound (#) symbol in Privileged EXEC command mode.

The command mode we must be in to change the name of the router is called Global configuration command mode and is
entered by typing “configure terminal”. This can also be done by entering “config t”. The router name is now followed by
the word “config” in parenthesis followed by the pound (#) symbol.

HINT: When typing commands in the CLI you can press the “tab” key to auto complete the command. This will save you
lots off typing although it is not always necessary to have each word in a command completely spelled out.
HINT: Use the question mark (?) when not sure about the syntax or availability of commands. It will show you which of all
the available commands are for the command mode you are in. You can use it after typing a few letters of a word or after
one or two words of a command.
Global configuration command mode and is entered by typing “configure terminal”.

We are now prepared to enter the commands to complete the lab. Below are the lab’s scenario and instructions:

You are the Network Administrator at Ranet.


We have just installed a new router to be our gateway.
You have to do the basic configuration via Console Terminal
(PC-PT) as below:
1. Set hostname to be “RanetA”
2. Set enable secret to be “ranetenablepass”
3. Set console password to be “ranetconsolepass”
4. Set telnet password to be “ranettelnetpass”
5. Set IP address of interface Fastethernet 0/0 to
be the first address of network 10.0.0.0/30
6. Set IP address of interface Fastethernet 0/1 to
be 192.168.0.254/26
7. Both interface Fastethernet 0/0 and 0/1 must
be enable.

After configuring this, you should be able to


1. Ping to 10.0.0.2 from Ranet A
2. Telnet from Ranet PC to Ranet A by using IP
address 192.168.0.254 and telnet password
as above.

Let’s begin with step 1.

1. Set hostname to be “RanetA”

Once in the global configuration mode, type “hostname” followed by a space and the new router name which is “RanetA”.
After pressing enter you will see the prompt change from “Router(config)#” to “RanetA(config)#”.
After pressing enter you will see the prompt change from “Router(config)#” to “RanetA(config)#”.

2. Set enable secret to be “ranetenablepass”

This password will be required to enter privileged EXEC command mode. In global configuration mode enter “enable secret
ranetenablepass”.
In global configuration mode enter “enable secret ranetenablepass”.

3. Set console password to be “ranetconsolepass”

This password will deter unauthorized access to the router via the console connection. While in global configuration mode
enter

“line con 0
password ranetenablepass
login
end”.

You will then be dropped down into the privileged EXEC command mode after entering the “end” command. “Exit can also
be used instead of “end”.
4. Set telnet password to be “ranettelnetpass”

“The VTY lines are the Virtual Terminal lines of the router, used solely to control inbound Telnet connections. They are
virtual, in the sense that they are a function of software – there is no hardware associated with them. They appear in the
configuration as line vty 0 4” (cisco.com). To set the Telnet password type:

“line vty 0 4
password ranettelnetpass
exit”.

Note: The “exit” command will drop you down into the global configuration command mode.

5. Set IP address of interface Fastethernet 0/0 to be the first address of network 10.0.0.0/30

The first useable IP address of the 10.0.0.0/30 network is 10.0.0.1. A /30 network means the subnet mask is
255.255.255.252. To accomplish this objective we must enter the interface configuration command mode for fast ethernet
port 0/0 and set the interface’s IP address as well as its subnet mask. The “exit” command will drop us back into the global
configuration command mode. While in global configuration command mode type

“interface fastethernet 0/0


ip address 10.0.0.1 255.255.255.252
exit”.

6. Set IP address of interface Fastethernet 0/1 to be 192.168.0.254/26

We will follow the same instructions as step 5 to configure fast ethernet port 0/1. A /26 network means the subnet mask is
255.255.255.128.

“interface fastethernet 0/1


ip address 192.168.0.254 255.255.255.192
exit”.

7. Both interface Fastethernet 0/0 and 0/1 must be enable.

In order for a port to be turned on or activated, the “no shutdown” command must be entered for each interface.

“interface fastethernet 0/0


no shutdown
exit
interface fastethernet 0/1
no shutdown”

You should see status updates in the CLI that both configured interfaces are “up”.

You should see status updates in the CLI that both configured interfaces are “up”.

Now that you have completed the configuration of the router, test your work.

1. Ping to 10.0.0.2 from Ranet A

To test connectivity between routers Ranet A and Ranet B we will execute a ping command. While in privileged EXEC
mode of router Ranet A enter
“ping 10.0.0.2”.

If things are correct, you should have an 80-100% ICMP success rate (see screenshot).

If things are correct, you should have an 80-100% ICMP success rate.

 2. Telnet from Ranet PC to Ranet A by using IP address 192.168.0.254 and telnet password as above.

To telnet from Ranet PC, open the Ranet PC desktop and click the command prompt.
To telnet from Ranet PC, open the Ranet PC desktop and click the command prompt.

In the command prompt type

“telnet 192.168.0.254
ranettelnetpass”.

 
In the command prompt type “telnet 192.168.0.254 ranettelnetpass”.

If you see RanetA>, congratulations! You have reached the user EXEC command mode of the Ranet A router.

The list of commands below are an example of how you can type all the router commands into a plain text file and paste it
into the router CLI. Be sure to order them correctly and remember which command mode you are in.

enable
configure terminal
hostname RanetA
enable secret ranetenablepass
line con 0
password ranetenablepass
login
end
configure terminal
ranetenablepass
configure terminal
line vty 0 4
password ranettelnetpass
exit
interface fastethernet 0/0
ip address 10.0.0.1 255.255.255.252
exit
interface fastethernet 0/1
ip address 192.168.0.254 255.255.255.192
exit
interface fastethernet 0/0
no shutdown
exit
interface fastethernet 0/1
no shutdown
exit
exit
exit
Cisco Router IPv4 Addressing
(CCNA Lab 1-2)
Posted on July 29, 2013 by Alex — No Comments ↓

This lab will help us better understand configuring a router’s serial and fast ethernet interfaces. This builds upon what was
covered in CCNA Lab 1-1. The scenario for this lab is as follows:

You are the network administrator at Ranet, and have to config the router “Ranet-BR” via Console Terminal as below:

1. enable interface Se 0/0/0 and set IP address /Subnet Mask so that it can connect with router “Ranter-HQ” at
192.168.0.254/30
2. enable interface Se 0/1/0 and set IP address /Subnet Mask so that it can connect with router “Ranter-BR1-1” at
192.168.0.30/30
3. The Headquaters has given IP address range 192.168.0.0/27 for the network behind our router, then you have to:
3.1 enable interface Fa 0/0 and set IP address/Subnet Mask to be the last IP of this subnet that has 10 host as members.
3.2 enable interface Fa0/1 and set IP address/Subnet Mask to be the last IP of this subnet that has 5 host as members.
3.3 Set IP address/Subnet Mark of Host1 in each LAN to be the first IP of its own subnet, and set IP of gateway also

If the configuration is correct, Host1 in each subnet will be able to ping Ranet Server at 192.168.0.33.
CCNA lab 1-2 network topology.

1. enable interface Se 0/0/0 and set IP address /Subnet Mask so that it can connect with router “Ranter-HQ” at
192.168.0.254/30

After consoling into router Ranet-BR enter the global configuration command mode.

Ranet-BR>enable
Ranet-BR#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Ranet-BR(config)#

Enter the interface configuration command mode for serial interface 0/0/0 and set the IP address to 192.168.0.253
255.255.255.252 (this is the only other useable IP address in that subnet).

Ranet-BR(config)#interface serial 0/0/0


Ranet-BR(config-if)#ip address 192.168.0.253 255.255.255.252
Ranet-BR(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

Ranet-BR(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

 2. enable interface Se 0/1/0 and set IP address /Subnet Mask so that it can connect with router “Ranter-BR1-1” at
192.168.0.30/30interface fastethernet 0/0
ip address 192.168.0.14 255.255.255.240
no shutdown

Ranet-BR(config)#interface serial 0/1/0


Ranet-BR(config-if)#ip address 192.168.0.29 255.255.255.252
Ranet-BR(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

Ranet-BR(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

3. The Headquaters has given IP address range 192.168.0.0/27 for the network behind our router, then you have to:
3.1 enable interface Fa 0/0 and set IP address/Subnet Mask to be the last IP of this subnet that has 10 host as
members.

Ranet-BR(config)#interface fastEthernet 0/0


Ranet-BR(config-if)#ip address 192.168.0.14 255.255.255.240
Ranet-BR(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up


Ranet-BR(config-if)#exit

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet 0/0, changed state to up

 3.2 enable interface Fa0/1 and set IP address/Subnet Mask to be the last IP of this subnet that has 5 host as members.

Ranet-BR(config)#interface fastEthernet 0/1


Ranet-BR(config-if)#ip address 192.168.0.22 255.255.255.248
Ranet-BR(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet 0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet 0/1, changed state to up

Ranet-BR(config-if)#exit

3.3 Set IP address/Subnet Mark of Host1 in each LAN to be the first IP of its own subnet, and set IP of gateway also.

On each Host1, open the desktop tab and click IP configuration and enter the appropriate settings.
Set the IP address of Host1 on LAN1 as 192.168.0.1, subnet mask as 255.255.255.240 and default gateway as 192.168.0.14.
Set the IP address of Host1 on LAN2 as 192.168.0.17, subnet mask as 255.255.255.248 and default gateway as 192.168.0.22.

If the configuration is correct, Host1 in each subnet will be able to ping Ranet Server at 192.168.0.33.

Execute a ping command from Host1 on each LAN. Ping 192.the Ranet Server at 168.0.33 to test network connectivity.
Ping the Ranet Server from Host1 on LAN1.
Ping the Ranet Server from Host1 on LAN2.

If you get replies from your pings than you did it! Great job completing this lab.
Router Simulator Supported
Commands
List of Router Commands

Sl. No. Command Comments, if any.

access-list <list-num> {permit Only standard access list of the format given is
1
| deny} <source-ip-address>  supported.
access-list <100-199>
{permit/deny} protocol source-
addr [source-mask] [operator
2  Global command for extended access-lists
operand] destination-addr
[destination-mask] [operator
operand]

access-list <list-num>
3  {permit/deny} protocol <source-  
addr> any operator operand

access-list <list-num>
4  {permit/deny} protocol <source-  
addr> any

access-list <list-num>
{permit/deny} protocol host
5   
<source-addr> <dest-
addr><dest-mask>

access-list <list-num>
6   
{permit/deny} protocol any any

access-list <list-
num>{permit/deny} protocol
7   
any host <dest-addr> operator
operand

8  access-list <list-num>  
{permit/deny} protocol host
<source-addr> any operator
operand

access-list <list-num>
{permit/deny} protocol <source-
9   
addr> <source-wmask> host
<dest-addr>

10 banner motd <banner>  

11 bandwidth <kilobits> Required bandwidth, in kilobits per second.

12 cdp advertise-v2  

13 cdp enable   

14 cdp run  

15 cdp holdtime <seconds>  

16 cdp timer <seconds>  

17 clear arp-cache  

Desired clock rate in bits per second: 1200, 2400,


18 clock rate <bps>
4800, 9600, 19200, 38400, 56000, 64000 etc.

Hexadecimal or decimal value that represents the


16-bit configuration register value. It is used at the
19 config-register <value> router start-up. The value range is from 0x0 to
0xFFFF (0 to 65535 in decimal). Normally, the
default value is 0x2102

20 configure terminal  

copy running-config startup-


21  
config

copy startup-config running-


22  
config

23 description <string> Character string from 1 to 80 characters.


Terminates the suspended telnet session and then
24 disconnect
logout it.

25  copy running-config tftp: Running configuration file is copied to TFTP server

26  copy tftp: running-config Copies configuration file from TFTP server to new router

27  copy tftp: startup-config Copies configuration file from TFTP server to new router

28 debug ip packet   

29 disable   

30 disconnect  

31 disconnect <TELNET_ID>  

32  domain-name <domain_name> Assigns the domain-name to the client.

dns-server <IP_address> Allows assigning upto 8 DNS server addresses to the


33 
[IP_address_2......IP_address_8] client.

default-router <IP_address> Allows assigning upto 8 default-gateway addresses to


34 
[IP_address_2......IP_address_8] the client for this range of addresses.

35 enable  

36 enable password <password>  

37 enable secret <password>  

38 erase startup-config  

39  encapsulation dot1q <vlan id> Command for router in interface configuration mode.

Only PPP/HDLC are supported at this time by the


encapsulation  <encapsulation-
40 simulator.
type>
ex: encapsulation hdlc
encapsulation framerelay [cisco]
41   
[ietf]

42 end   

exec-timeout <minutes>
43 seconds is optional. 
[seconds] 

44  frame-relay lmi-type <lmi_type> LMI type is specific to the entire interface,not to a VC.

frame-relay map<protocol-
45  It configures the manual resolution of PVC's.
name> <ip-address> <dlci_num>

frame-relay map<protocol-
46  name> <ip-address> <dlci_num>  
broadcast

frame-relay map<protocol-
47  name> <ip-address> <dlci_num>  
broadcast cisco

frame-relay map<protocol-
48  name> <ip-address> <dlci_num>  
broadcast ietf

frame-relay map<protocol-
49  name> <ip-address> <dlci_num>  
cisco

frame-relay map<protocol-
50  name> <ip-address> <dlci_num>  
ietf

51 hostname <host-name>  

52 interface ethernet 0  

53  interface fa <Port-number>  

interface fa <Slot-
54   
number>/<Port-number>

55  interface fa <Port-  


number>.<Subint-number>

interface fa <Slot-
56  number>/<Port-  
number>.<Subint-number>

interface loopback <port-


57  Loop back interface numbers 0 to 9 are supported
number>

58 interface serial 0   

59  ip access-group <named ACL> Interface sub command to enable named access-list

60 ip access-group <num> in  

61 ip access-group <num> out   

ip access-list extended <named


62  Global command for Named Access-List
ACL>

ip address <ip-address> <sub-


63  
net mask> 

64 ip default-network <ip-address>  

65 ip domain-lookup   

66 ip name-server<ip-address>  

ip nat inside source list <ANUM>


67   
pool <WORD>

ip nat inside source static <ip-


68   
address> <ip-address>

69  ip nat inside  

ip nat outside source static <ip-


70   
address> <ip-address>

71  ip nat outside  

72  ip nat pool <WORD> <ip-  


address> <ip-address> netmask
<ip-address>

ip nat inside source list <num>


73  PAT command
interface <int> overload

The command supported by the simulator are:


ip route <prefix> <mask> {next-
74 ip route <prefix> <mask> <next-hop-ip> and
hop-ip-addr | interface-type}
ip route <prefix> <mask> serial 

ip route 0.0.0.0 0.0.0.0 <ip-


75  
address>

ip route<ip-address> <ip-
76  
address> <ip-address>

ip route <ip-address> <ip-


77 Not supported at this time
address> serial 0

Complete syntax for this command: ip host name [tcp-


78 ip host <name> <ip-address>
port-number] address1 [address2...address8]

79 ip routing  

80 ipx routing  

Enables the forwarding of ipv6 unicast datagrams


81  ipv6 unicast-routing
globally on the router. 

Configures IPV6 RIP routing process and enters router


82  ipv6 router rip <word>
configuration mode for the IPV6 RIP routing process. 

Enters router configuration mode and creates an EIGRP


83  ipv6 router eigrp <as-number>  IPV6 routing process. The "AS" stands for Autonomous
System number. 

84  ipv6 address <ipv6-prefix/prefix- Assigns ipv6 address to an interface.


length>

85  ipv6 enable Enables ipv6 processing on the interface.

Enables specified IPV6 RIP routing process on an


86  ipv6 rip <name> enable
interface.

Enables EIGRP for IPV6 on a specified interface. The "AS"


87  ipv6 eigrp <as-number> 
stands for Autonomous System number. 

ipv6 ospf <process-id> area


88  Enables OSPF for IPV6 on a specified interface. 
<area-id>

89 ip dhcp pool <pool_name> Creates an addressing pool

90 ip address dhcp Command to use DHCP to acquire its IP address

91
ip cef Enables CEF on the cisco router
new
92 keepalive <seconds>  

93 line aux  

94 line console 0   

95 line vty  

96 logging synchronous  

97 login  

98 logout   

lease <days [hours][min] |


98 Specifies the duration of the lease
infinite>

100 network <ip-address>  Used with routing rip, igrp etc.

network <ip-address> < ip-


 101  (For ospf routing)
address > area <Area-id>
102 no cdp enable  

103 no ip address  

104 no ip routing  

105 no cdp run  

no frame map <protocol name>


106  
<ip-address> <dlci_num>

no frame map<protocol-name>
107 <ip-address> <dlci_num>  
broadcast

no frame map<protocol-name>
108   
<ip-address> <dlci_num> cisco

no frame map<protocol-name>
109   
<ip-address> <dlci_num> ietf

110 no ip domain-lookup  

no ip nat pool <WORD><ip-


111 address> <ip-address> netmask Nat pool related command
<mask-addr>

no ip nat inside source list


112  
<ANUM> pool <WORD>

no ip nat inside source static


113  
<ip-address> <ip-address>

114 no router eigrp  

115 no router ospf  

116 no router rip  

117 no shutdown  

118 no ip address dhcp Unconfigures any address that was acquired

119 mpls label protocol ldp Configures LDP on all interfaces


new
120 Configure MPLS hop-by-hop forwarding for a router
mpls ip
interface.
new
121 password <password>   

122 ping <host-name>  

123 ping <ip-address>  

124 ping ipv6 <ipv6-address> Used to test the connectivity.

125
ping mpls ipv4 <address> Used to test MPLS connectivity
new
126 reload  

127 resume <TELNET_ID>  

128 router eigrp <aut_sys>  

Process_id is locally significant and is used to


129 router ospf <proc_id> differentiate different ospf processes running on a
router.

130 router rip  

131 shutdown  

132 show access-list   

133 show arp Displays entries in the ARP table

134 show cdp neighbor   

135 show flash   

136 show history  


137 show frame-relay lmi Shows the detailed statistics regarding LMI.

138 show frame-relay map  

show frame-relay pvc Shows all the frame relay PVC's terminated and their
139
<dlci_num> statistics at a specified router

140 show hosts  

141 show ip arp  

142 show ip eigrp neighbors detail  

143 show ip eigrp neighbors  

144 show ip eigrp topology  

145 show ip eigrp traffic  

146 show ip interface brief  

147 show ip interface  

148 show ip ospf interface  

149 show ip nat statistics  

150 show ip nat translations  

151 show ip ospf database  

152 show ip ospf neighbor detail   

Displays parameters and current state of the active


153 show ip protocols
routing protocol process.

154 show ip route  

155 show interfaces  

156 show interfaces ethernet 0  

157 show interfaces serial 0  


show interfaces loopback
158 Loopback interface number,0 to 9 are supported
<Loopback_num>

159 show protocols  

160 show running-config  

161 show sessions  

162 show startup-config   

163 show users Displays users connected to the router

164 show version   

Displays information about all current IPV6 RIP


165 show ipv6 rip
processes. 

show ipv6 interface <interface-


166 Displays ipv6 interface configuration information. 
name>

Displays general information about OSPF routing


167 show ipv6 ospf 
processes.

168 show ipv6 route Displays routes in the IPV6 routing table.

Displays parameters and current state of the active IPV6


169 show ipv6 protocols
routing protocol processes. 

170 service dhcp Enables and disables the DHCP server feature on router

171 show ip dhcp binding To view the addresses assigned to clients on dhcp server

172
show mpls interface To verify that the interfaces are configured to use LDP.
new
173 show mpls forwarding-table shows MPLS forwarding table information
new
174 Shows that the LDP session between routers was
show mpls ldp neighbor
successfully established
new

175 To display entries in the Cisco Express Forwarding


show ip cef Forwarding Information Base (FIB) or to display a
new summary of the FIB

176 To display a summary of the IP Cisco Express Forwarding


show ip cef summary
table
new
177 telnet <host-name>  

178 telnet <IP-address>  

Lists all routers along path to destination and finds the


179 traceroute <hostname>
routing problems if any.

180 traceroute <ip-address>  

Traceroute command to determine path of a packet to


181 traceroute ipv6 <ipv6-address>
its destination. 

182 traceroute mpls ipv4


used to determine routes to destination
<ipaddress>
new
username <name> password
183  
<password>

184 version 2 For RIPv2 routing

185 write erase  

186 write memory  

187 write terminal  

188 no auto-summary  

189 no network <ip addr> <ip addr>  


area <area id>

     

List of Switch Commands Supported

Sl.No. commands Comments, if any.

1 banner motd <phrase>  

copy startup-config running-


2  
config

3 configure terminal  

4 cdp advertise-v2  

copy running-config startup-


5  
config

6 cdp holdtime <seconds>  

7 cdp timer <seconds>  

clock set hh:mm:ss <1-31>


8  
Month <2004-2035>

9 cdp run  

10 duplex <duplex-type>  

11 description <phrase>  

12 disable  

13 enable  

14 erase startup-config  

15 enable secret <secret>  

16 enable password <password>  

17 end  
18 hostname <name>  

interface fastethernet <0-0>/<0- Depends on the switch type. For module 0, port 1 the
19
24> command is interface fastethernet 0/1

20 ip default-gateway <ip-address>  

21  ip host<hostname> <ip-address>  

interface range fastethernet <0-


22   
0>/<0-12>

You can enter interface config mode.


23 interface vlan <vlan #> example: interface vlan 1
(config-if)#ip address 192.168.10.1 255.255.255.0

24 ip name-server <ip-address>  

A switch can have one IP address. The IP address of the


ip address <ip-address> <subnet
25 switch can be accessed only through ports that belong to
mask>
the management VLAN. 

26 line vty 0 15  

27 line console 0  

28 login  

29 logout  

mac-address-table static <mac-


30  address> vlan <valn_num>  
interface fastethernet <pnum>

31  no ip address  
32
no spanning-tree vlan <vlan-id> Disables STP on a specified VLAN.
new

It re-enables the interface when the interface is


33  no shutdown
disabled.By default interfaces are enabled.

34  no switchport mode  

35  no switchport <port_security>  

36 password <password>  

37 reload  

38 show interfaces  

39 show history  

40  show mac-address-table Displays mac-address-table information

Display version information for the hardware  and


41 show version
firmware

42 Displays spanning-tree statistics, including information


show spanning-tree
new about root bridge and port status.

43
show spanning-tree summary Displays summary of port states.
new

44 show spanning-tree vlan <vlan-


Displays STP information for the specified VLAN.
new id>

45  show vlan Displays vlan information

46  show vlan-membership Displays vlan membership information

47  show vtp status Displays vtp status information

48 show startup-config  

49 show flash  
50 show running-config  

51 show ip interface brief  

Disables a port and shuts-down management vlan. no


52 shutdown
shutdown command enables a port.

53 snmp-server enable traps vtp  

54
spanning-tree vlan <vlan-id> Enables STP on a specified VLAN
new

55 spanning-tree vlan <vlan-id>


Configures the root switch.
new root

56 spanning-tree vlan <vlan-id>


Configures switch priority of a VLAN.
new priority <priority-num>

57 spanning-tree vlan <vlan-id>


Configures STP hello timer.
new hello-time <hello_time>

58 spanning-tree vlan <vlan-id>


Configures STP forward-time.
new forward-time <forward_time>

59 spanning-tree vlan <vlan-id>


Configures STP max-age.
new max-age <max_age>

60 spanning-tree port-priority
Configures port priority on a specified interface.
new <port_priority>

61 speed <speed> Enter switch port speed 10,100, auto. 

switchport access vlan


62 
<vlan_num>

63  switchport mode access Access mode of the switch is set to access

64  switchport mode trunk Access mode of the switch is set to trunk

switchport port-security mac-


65   
address sticky<mac_addr>

66  switchport port-security  


maximum <max_macadd>

switchport port-security
67   
violation <violat_mode>

switchport trunk encapsulation


68  Command for switch in interface configuration mode
dot1q

VLAN numbers can range 1-1000,However only 64VLANs


69  vlan<vlan_num>
can be active at a time.

vlan <vlan_num> name  VLAN numbers can range 1-1000, VLAN name can be
70
<vlan_name> upto 32 characters

Place the switch in VTP client mode. But it does not store
71 vtp client
VLAN information in non-volatile memory.

72 vlan database  

SW(vlan)# vtp transparent


73 vtp transparent
Sets the switch to VTP TRANSPARENT mode.

Passwords are case sensitive. Passwords should match


74 vtp password <password>
on all switches in the same domain.

VTP domain name can be 1 to 32 characters long and


75 vtp domain <name> identifies the VTP administrative domain for the switch.
The domain name is case sensitive.

76 vtp pruning  

Place the switch in VTP server mode. Stores VLAN


77 vtp server information in non-volatile memory. Generates VLAN
advertisements.

You might also like