Clase 4. ISIS
Clase 4. ISIS
Clase 4. ISIS
Clase 4. IS-IS
R1 R2
int lo0 int lo0
ip add 192.168.0.1 255.255.255.255 ip add 192.168.0.2 255.255.255.255
ip router Isis ip router Isis
exit exit
int e0/0 int e0/0
ip add 10.10.10.1 255.255.255.0 ip add 10.10.10.2 255.255.255.0
ip router ip router Isis
exit exit
router Isis router Isis
net 49.0001.1921.6800.0001.00 net 49.0001.1921.6800.0002.00
Configure IS-IS – CISCO IOS XR
Configure IS-IS - JUNIPER
em0 em0 Lo0=192.168.0.1/32
Lo0=192.168.0.1/32
R1L1/L2 R2
10.10.10.0/24
system-view
isis 1
is-level level-1
network-entity 49.0001.1921.6800.0001.00
quit
interface gigabitethernet 1/0/1
isis enable 1
quit
Lab. IS-IS IPv4 Multivendor
Configure IS-IS Core Network – R2
Configure IS-IS Core Network – JUN-1
configure
set interfaces em0 unit 0 family inet address 10.10.2.2/24
set interfaces em0 unit 0 family iso
set interfaces em1 unit 0 family inet address 200.10.10.253/30
set interfaces em2 unit 0 family inet address 10.10.5.1/24
set interfaces em2 unit 0 family iso
set interfaces em3 unit 0 family inet address 10.10.3.1/24
set interfaces em3 unit 0 family iso
set interfaces lo0 unit 0 family inet address 192.168.0.2/32
set interfaces lo0 unit 0 family iso address 49.0006.1921.6800.0002.00
set protocols isis interface em0
set protocols isis interface em2
set protocols isis interface em3
set protocols isis interface lo0
commit
Configure IS-IS Core Network – JUN-2
configure
set interfaces em0 unit 0 family inet address 10.10.5.2/24
set interfaces em0 unit 0 family iso
set interfaces em1 unit 0 family inet address 10.10.6.1/24
set interfaces em1 unit 0 family iso
set interfaces lo0 unit 0 family inet address 192.168.0.3/32
set interfaces lo0 unit 0 family iso address 49.0006.1921.6800.0003.00
set protocols isis interface em0
set protocols isis interface em1
set protocols isis interface lo0
commit
Configure IS-IS Core Network – R4
Configure IS-IS Core Network – JUN-3
configure
set interfaces em0 unit 0 family inet address 10.10.4.2/24
set interfaces em0 unit 0 family iso
set interfaces em1 unit 0 family inet address 10.10.7.2/24
set interfaces em1 unit 0 family iso
set interfaces em2 unit 0 family inet address 10.10.3.2/24
set interfaces em2 unit 0 family iso
set interfaces lo0 unit 0 family inet address 192.168.0.5/32
set interfaces lo0 unit 0 family iso address 49.0006.1921.6800.0005.00
set protocols isis interface em0
set protocols isis interface em1
set protocols isis interface em2
set protocols isis interface lo0
commit
Verify IS-IS Neighbors
Verify IS-IS Routing Table
Verify IS-IS Routing Table
Redistribute Default Route&Static Route
Redistribute Default Route&Static Route-Cisco
Redistribute Static Route - Juniper
1.- Create Static Route
2.- Create Policy Routing
3.- Export Policy Routing into Protocol ISIS
interface FastEthernet0/0.23
encapsulation dot1Q 23
ip address 20.2.3.2 255.255.255.0
ip router isis
ipv6 address 2001:20:2:3::2/64
ipv6 router isis
isis ipv6 metric 20
end
interface FastEthernet0/0.24
encapsulation dot1Q 24
ip address 20.2.4.2 255.255.255.0
ip router isis
ipv6 address 2001:20:4:2::2/64
ipv6 router isis
isis metric 20
end
IS-IS IPv6 Multi-Topology (RFC 5120)
• Multitopology IS-IS enables IS-IS to run independent IP
topologies in a single routing domain.
• This can be separate IPv4 topologies, separate IPv6
topologies, or a combination of both sets.
• When multitopology IS-IS is used, separate databases
are maintained for each topology and SPF runs are
performed separately for each database.
IS-IS IPv6 Multi-Topology (RFC 5120)