Lab 1.5.1: Cabling A Network and Basic Router Configuration: Topology Diagram
Lab 1.5.1: Cabling A Network and Basic Router Configuration: Topology Diagram
Topology Diagram
Addressing Table
Device Interface IP Address Subnet Mask Default Gateway
Fa0/0 192.168.1.1 255.255.255.0 N/A
R1
S0/0/0 192.168.2.1 255.255.255.0 N/A
Fa0/0 192.168.3.1 255.255.255.0 N/A
R2
S0/0/0 192.168.2.2 255.255.255.0 N/A
PC1 N/A 192.168.1.10 255.255.255.0 192.168.1.1
PC2 N/A 192.168.3.10 255.255.255.0 192.168.3.1
Learning Objectives
Upon completion of this lab, you will be able to:
• Cable devices and establish console connections.
• Erase and reload the routers.
• Perform basic IOS command line interface operations.
• Perform basic router configuration.
• Verify and test configurations using show commands, ping and traceroute.
• Create a startup configuration file.
• Reload a startup configuration file.
• Install a terminal emulation program.
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 1 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 2 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
Step 1: Create a null serial cable to connect the R1 router to the R2 router.
Step 2: Connect the DCE end of the null serial cable to the Serial 0/0/0 interface of the R1 router,
and the DTE end of the null serial cable to the Serial 0/0/0 interface of the R2 router.
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 3 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
Step 1: Using the HyperTerminal session established in Task 3, enter privileged EXEC mode on
R1.
Router>enable
Router#
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 4 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
Router#
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Step 6: Examine the commands that are available for privileged EXEC mode.
A question mark, ?, can be entered at the prompt to display a list of available commands.
Router#?
Exec commands:
<1-99> Session number to resume
clear Reset functions
clock Manage the system clock
configure Enter configuration mode
connect Open a terminal connection
copy Copy from one file to another
debug Debugging functions (see also 'undebug')
delete Delete a file
dir List files on a filesystem
disable Turn off privileged commands
disconnect Disconnect an existing network connection
enable Turn on privileged commands
erase Erase a filesystem
exit Exit from the EXEC
logout Exit from the EXEC
no Disable debugging informations
ping Send echo messages
reload Halt and perform a cold restart
resume Resume an active network connection
setup Run the SETUP command facility
show Show running system information
--More--
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 5 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
The abbreviated command en contains enough characters for the IOS to distinguish the enable
command from the exit command.
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 6 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
Step 11: Press the Tab key after an abbreviated command to use auto-complete.
Typing an abbreviated command, such as conf, followed by the Tab key completes a partial command
name. This functionality of the IOS is called auto-complete. Type the abbreviated command conf, press
the Tab key, and observe the results.
Router#conf
Router#configure
This auto-complete feature can be used as long as enough characters are typed for the IOS to recognize
the unique command.
Router#
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 7 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
The enable secret command is used to provide an additional layer of security over the enable
password command. The enable secret command provides better security by storing the enable
secret password using a non-reversible cryptographic function. The added layer of security
encryption provides is useful in environments where the password crosses the network or is stored on a
TFTP server. When both the enable password and enable secret passwords are configured,
the
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 8 of 28
CCNA Exploration
Routing Protocols
Enter and Concepts:
TEXT message. End with the
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
********************************
!!!AUTHORIZED ACCESS ONLY!!!
********************************
&
R1(config)#
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 9 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
Step 10: Configure the password for the virtual terminal lines.
Use cisco as the password. When you are finished, exit from line configuration mode.
R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#
Step 11: Configure the FastEthernet 0/0 interface with the IP address 192.168.1.1/24.
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
Step 12: Use the description command to provide a description for this interface.
R1(config-if)#description R1 LAN
R1(config-if)#
Step 13: Configure the Serial0/0/0 interface with the IP address 192.168.2.1/24.
Set the clock rate to 64000.
Note: Because the routers in the labs will not be connected to a live leased line, one of the routers will
need to provide the clocking for the circuit. This is normally provided to each of the routers by the service
provider. To provide this clocking signal in the lab, one of the routers will need to act as the DCE on the
connection. This function is achieved by applying the clock rate 64000 command on the serial
0/0/0 interface, where the DCE end of the null modem cable has been connected. The purpose of the
clock rate command is discussed further in Chapter 2, “Static Routes.”
Note: The interface will not be activated until the serial interface on R2 is configured and activated.
Step 14: Use the description command to provide a description for this interface.
R1(config-if)#description Link to R2
R1(config-if)#
Step 15: Use the end command to return to privileged EXEC mode.
R1(config-if)#end
R1#
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 10 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
Step 2: Configure the Serial 0/0/0 interface with the IP address 192.168.2.2/24.
R2(config)#interface serial 0/0/0
R2(config-if)#ip address 192.168.2.2 255.255.255.0
R2(config-if)#no shutdown
Step 3: Use the description command to provide a description for this interface.
R1(config-if)#description Link to R1
R1(config-if)#
Step 4: Configure the FastEthernet 0/0 interface with the IP address 192.168.3.1/24.
R2(config-if)#interface fastethernet 0/0
R2(config-if)#ip address 192.168.3.1 255.255.255.0
R2(config-if)#no shutdown
Step 5: Use the description command to provide a description for this interface.
R1(config-if)#description R2 LAN
R1(config-if)#
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 11 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 12 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
!
!
!
line con 0
password cisco
line vty 0 4
password cisco
login
!
end
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 13 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
!
!
!
line con 0
password cisco
line vty 0 4
password cisco
login
!
end
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 14 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
of the show version command. If the –-More-- prompt appears, press the Spacebar to view
the remainder of the command output.
R1#show version
Cisco IOS Software, 1841 Software (C1841-IPBASE-M), Version 12.3(14)T7,
RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Mon 15-May-06 14:54 by pt_team
R1#
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 15 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
Step 1: Use the ping command to test connectivity between the R1 router and PC1.
R1#ping 192.168.1.10
Each exclamation point (!) indicates a successful echo. Each period (.) on the display indicates that the
application on the router timed out while it waited for a packet echo from a target. The first ping packet
failed because the router did not have an ARP table entry for the destination address of the IP packet.
Because there is no ARP table entry, the packet is dropped. The router then sends an ARP request,
receives a response, and adds the MAC address to the ARP table. When the next ping packet arrives, it
will be forwarded and be successful.
R1#
All of the pings are successful this time because the router has an entry for the destination IP address in
the ARP table.
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 16 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 17 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 18 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 19 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 20 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 21 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 22 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 23 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 24 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 25 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 26 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 27 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 28 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 29 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 30 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 31 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 32 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 33 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 34 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 35 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 36 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 37 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 38 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 39 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 40 of 28
CCNA Exploration
Routing Protocols and Concepts:
Introduction to Routing and Packet Forwarding Lab 1.5.1: Cabling a Network and Basic Router Configuration
C:\>ping 192.168.1.1 –n 10
Step 1: Use the traceroute command at the R1 privileged EXEC prompt to discover the path
that a packet will take from the R1 router to PC1.
R1#traceroute 192.168.1.10
Type escape sequence to abort.
Tracing the route to 192.168.1.10
Step 2: Use the tracert command at the Windows command prompt to discover the path that
a packet will take from the R1 router to PC1.
C:\>tracert 192.168.1.1
1 71 ms 70 ms 73 ms 192.168.1.1
Trace complete.
C:\>
All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 41 of 28