Lab - Configuring Per-Interface Inter-VLAN Routing
Lab - Configuring Per-Interface Inter-VLAN Routing
Topology
Addressing Table
Objectives
Part 1: Build the Network and Configure Basic Device Settings
Part 2: Configure Switches with VLANs and Trunking
Part 3: Verify Trunking, VLANs, Routing, and Connectivity
Background / Scenario
Legacy inter-VLAN routing is seldom used in today’s networks; however, it is helpful to configure and
understand this type of routing before moving on to router-on-a-stick (trunk-based) inter-VLAN routing or
© 2016 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 1 of 6
Lab – Configuring Per-Interface Inter-VLAN Routing
configuring Layer-3 switching. Also, you may encounter per-interface inter-VLAN routing in organizations with
very small networks. One of the benefits of legacy inter-VLAN routing is ease of configuration.
In this lab, you will set up one router with two switches attached via the router Gigabit Ethernet interfaces.
Two separate VLANs will be configured on the switches, and you will set up routing between the VLANs.
Note: This lab provides minimal assistance with the actual commands necessary to configure the router and
switches. The required switch VLAN configuration commands are provided in Appendix A of this lab. Test
your knowledge by trying to configure the devices without referring to the appendix.
Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with
Cisco IOS, Release 15.2(4)M3 (universalk9 image). The switches used are Cisco Catalyst 2960s with Cisco
IOS, Release 15.0(2) (lanbasek9 image). Other routers, switches and Cisco IOS versions can be used.
Depending on the model and Cisco IOS version, the commands available and output produced might vary
from what is shown in the labs. Refer to the Router Interface Summary Table at the end of this lab for the
correct interface identifiers.
Note: Make sure that the routers and switches have been erased and have no startup configurations. If you
are unsure, contact your instructor.
Required Resources
• 1 Router (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
• 2 Switches (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)
• 2 PCs (Windows 7, Vista, or XP with terminal emulation program, such as Tera Term)
• Console cables to configure the Cisco IOS devices via the console ports
• Ethernet cables as shown in the topology
© 2016 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 2 of 6
Lab – Configuring Per-Interface Inter-VLAN Routing
login
c. Configure addressing on G0/0 and G0/1 and enable both interfaces.
d. Copy the running configuration to the startup configuration.
© 2016 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 3 of 6
Lab – Configuring Per-Interface Inter-VLAN Routing
d. Assign ports F0/11 and F0/18 to VLAN 20 and configure both F0/11 and F0/18 as access ports.
e. Assign an IP address to VLAN 10 and enable it. Refer to the Addressing Table.
f. Configure the default gateway according to the Addressing Table.
Reflection
What is an advantage of using legacy inter-VLAN routing?
Answers may vary. Configuration of both the router and switches is relatively easy and straightforward. No
subinterfaces are required on the router and trunking does NOT have to be configured between the router
and switch.
© 2016 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 4 of 6
Lab – Configuring Per-Interface Inter-VLAN Routing
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
(F0/0) (F0/1)
1900 Gigabit Ethernet 0/0 Gigabit Ethernet 0/1 Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
(G0/0) (G0/1)
2801 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
(F0/0) (F0/1)
2811 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
(F0/0) (F0/1)
2900 Gigabit Ethernet 0/0 Gigabit Ethernet 0/1 Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
(G0/0) (G0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many
interfaces the router has. There is no way to effectively list all the combinations of configurations for each router
class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device.
The table does not include any other type of interface, even though a specific router may contain one. An
example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be
used in Cisco IOS commands to represent the interface.
Switch S1
S1(config)# vlan 10
S1(config-vlan)# name Student
S1(config-vlan)# exit
S1(config)# vlan 20
S1(config-vlan)# name Faculty-Admin
S1(config-vlan)# exit
S1(config)# interface f0/1
S1(config-if)# switchport mode trunk
S1(config-if)# interface range f0/5 – 6
S1(config-if-range)# switchport mode access
S1(config-if-range)# switchport access vlan 10
S1(config-if-range)# interface vlan 10
S1(config-if)# ip address 192.168.10.11 255.255.255.0
S1(config-if)# no shut
S1(config-if)# exit
S1(config)# ip default-gateway 192.168.10.1
Switch S2
S2(config)# vlan 10
S2(config-vlan)# name Student
© 2016 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 5 of 6
Lab – Configuring Per-Interface Inter-VLAN Routing
S2(config-vlan)# exit
S2(config)# vlan 20
S2(config-vlan)# name Faculty-Admin
S2(config-vlan)# exit
S2(config)# interface f0/1
S2(config-if)# switchport mode trunk
S2(config-if)# interface f0/11
S2(config-if)# switchport mode access
S2(config-if)# switchport access vlan 20
S2(config-if)# interface f0/18
S2(config-if)# switchport mode access
S2(config-if)# switchport access vlan 20
S2(config-if-range)# interface vlan 10
S2(config-if)#ip address 192.168.10.12 255.255.255.0
S2(config-if)# no shut
S2(config-if)# exit
S2(config)# ip default-gateway 192.168.10.1
© 2016 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 6 of 6