BRKSPG 2210 PDF
BRKSPG 2210 PDF
BRKSPG 2210 PDF
Network Automation
and Programmability
for Service Providers
How
1. Find this session in the Cisco Live Mobile App
2. Click “Join the Discussion”
3. Install Spark or go directly to the space
4. Enter messages/questions in the space
cs.co/ciscolivebot#BRKSPG-2210
© 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public
Agenda
• Programmable network
• Automatic Device Provisioning
• Design the programmable underlay
• Building a Programmable Transport
• Network Topology Discovery
• Compute & Program the Transport Path
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 5
Programmable Network
Trends in the Service Provider Transport
Access and Aggregation
• Scale the access within a domain Access Domain C
• Number of nodes and services increasing
• Bandwidth growth 10GE -> 100G
• Traffic load optimization
Core
• Agile service deployment across domains
• End to End service deployments
Access Domain A
• Virtualization
• Virtual CPE, Virtual NID
Access Domain B
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 7
Network Programmability
What is changing in the network?
Traditional Programmatic Approach
Access Domain C Access Domain C
IP/MPLS/ L2
Segment Routing
Core Core
Service WAN XR
NMS Assurance OSS BSS
Orchestration Optimization Transport Open Source
Engine Controller
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 8
Programmable Network – New Operation Model
Configuration Operational Traffic
Management State Engineering
APIC EM Netconf
IOS XR XML Telemetry BGP-LS PCEP
Restconf
API Protocols
Programmatic
Interfaces Model Driven Programmable Interfaces
Open
Protocols
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 9
Automatic Device Provisioning
“The Day 0 Challenge”
The Day 0 Challenges
5G Large Simplify Day 0 device
number of
devices to deployments
Rapid Nodes and bring up
•
Service
deployments
SD-WAN
Expected Devices
to be distributed
service in different
Service- ready on physical
Ready bringup locations
Infrastructure
IoT
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 11
ZTD – Two Different Deployment Scenarios
Servers
(DHCP/NMS)
1 • Routers are connected to a
management network via out-of-band
management port “out-of-band”
Management
network
• Popular in Data Center, Enterprise,
and Web customers
Sub-int
2
L2 EVC
• There is no dedicated management Servers
network. Routers are managed via (DHCP/HTTP)
in-band, the same as user data L3 link L3 link
network “in-band”
management
• Typical deployment in the SP L3 link
L3 link
Access/Metro
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 12
ZTD requirements
Layer 3 Ring Topology
Baseline requirements across both
deployment scenarios
Layer 3 MPLS MPLS
• No pre-staging required
• DHCP for management IP address
• Configuration download Layer 2 Ring Topology
• Image upgrade/downgrade
• Connection to the NMS
Layer 2 Layer 2 MPLS
Baseline requirement for “in-band
management” deployment scenario
Compound Topology
• Auto L3 adjacency configuration in any
topology Layer 2 L3 Network MPLS
• L2 VLAN auto-discovery
1
Device boot up and initiate a DHCP
Discover DHCP
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 14
Option 1: NSO Initiated
When Device do not run any Script or Compute Server
Initiated
0 Run ZTP.sh
DHCP Request DHCP Request
( Broadcast) ( Unicast) DHCP
1 Server Notification Python Script
address leased
1
NSO
2 Registration NSO
3 3
2
3 IP Address, Default GW
DHCP Option 67 DHCP Response ( Unicast)
Bootfile name
Config
Synch
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 15
Option 2: Provisioning from the Device Device
Initiated
1 Device boot up and initiates a DHCP Discover
DHCP
DHCP server provides a script using “boot-file-
name” (option 67)
1
2 Device Downloads scripts from HTTP/FTP
server HTTP
2
Get Script
Provision.py
NSO
3-4
0 Run ZTP.sh
DHCP Request DHCP Request
( Broadcast) ( Unicast) DHCP
1 Server
1
2 2 NSO
2 IP Address, Default GW
DHCP Option 67 DHCP Response ( Unicast)
Bootfile name
Config
Config
Synch
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 17
Different download method with IOS XE versus XR
IOS XR IOS XE XR XE
Download No Yes
Configuration Script
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 18
Designing the Programmable Underlay
Step 1: Build a Programmable Transport
Why Segment Routing?
• More Control and Programmable
Program MPLS labels
• Segment Routing Labels are assigned Service label
manually or programmed SR-TE path
OR
• Simplifies the Control plane stack. Programmable MPLS
• Extension to IGP’s ( ISIS , OSPF) CLI>
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 20
Program MPLS labels:
Prefix SID
Unified MPLS vs Segment Routing Service Label
OR
Intra Domain
Service Label
CLI>
LDP/IGP
PW LDP
PW
LDP LDP
ISIS-SR
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 21
Program MPLS labels
Unified MPLS vs Segment Routing Prefix SID
Service Label
OR
Inter Domain
Unified MPLS Programmable MPLS CLI>
Head-End
Link Addresses
Interfaces
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 23
Configure
Segment Routing Configuration
IGP - OSPF IGP - ISIS
RP/0/0/CPU0:A11#config t A11 RP/0/0/CPU0:A21#config t A21
segment-routing segment-routing
global-block 16000 23999 global-block 16000 23999
! ! SRGB Block
router ospf 1 SRGB Block router isis 2
router-id 1.1.1.11 is-type level-2-only
segment-routing mpls net 49.0001.0000.0000.0021.00
segment-routing forwarding mpls address-family ipv4 unicast
fast-reroute per-prefix Enable Segment metric-style wide
fast-reroute per-prefix ti-lfa enable Routing segment-routing mpls Enable Segment
address-family ipv4 ! Routing
area 0 interface Loopback0
interface Loopback0 Link Protection (TI- address-family ipv4 unicast
prefix-sid index 11 LFA) prefix-sid index 21
Configure Prefix SID
! !
interface GigabitEthernet0/0/0/1 router isis 2 (Node SID)
network point-to-point Configure Prefix SID !
! (Node SID) address-family ipv4 unicast
interface GigabitEthernet0/0/0/0 !
network point-to-point interface GigabitEthernet0/0/0/0
! point-to-point
commit address-family ipv4 unicast
fast-reroute per-prefix
fast-reroute per-prefix ti-lfa
Link Protection (TI-
!
[SNIP…]
LFA)
!
commit © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public
ISIS Validation Only
Segment Routing Validation
Control Plane Control Plane
RP/0/0/CPU0:A21#sh isis neighbors A21 RP/0/0/CPU0:A21#show route 3.3.3.122/32 detail A21
Mon Jan 29 02:07:57.650 UTC Mon Jan 29 02:06:47.650 UTC
ISIS Neighbors Routing entry for 3.3.3.122/32
IS-IS 2 neighbors: Known via "isis 2", distance 115, metric 30, labeled SR, type level-2
System Id Interface SNPA State Holdtime Type IETF- Installed Jan 25 04:13:15.316 for 3d21h
NSF Routing Descriptor Blocks SR Label
A22 Gi0/0/0/1 *PtoP* Up 23 L2 Capable 21.121.0.121, from 3.3.3.122, via GigabitEthernet0/0/0/0, Protected
PE121 Gi0/0/0/0 *PtoP* Up 22 L2 Capable Route metric is 30
Label: 0x3efa (16122)
Total neighbor count: 2 Tunnel ID: None
SRGB Block Binding Label: None Primary Path (TI-LFA
!
RP/0/0/CPU0:A21#show mpls label table label 16000 detail Extended communities count: 0 Protected Link)
Thu Feb 23 21:30:43.546 UTC Path id:1 Path ref count:0
Table Label Owner State Rewrite NHID:0x3(Ref:10)
----- ------- ------------------------------- ------ ------- Backup path id:65
0 16000 ISIS(A):2 InUse No 21.22.1.22, from 3.3.3.122, via GigabitEthernet0/0/0/1, Backup
(Lbl-blk SRGB, vers:0, (start_label=16000, size=8000) (Local-LFA)
! Route metric is 40
RP/0/0/CPU0:A21#show isis route 3.3.3.122/32 detail Label: 0x3efa (16122)
Tunnel ID: None
Backup Path
Mon Jan 29 02:08:17.650 UTC
Route to Core Binding Label: None
L2 3.3.3.122/32 [30/115] medium priority Extended communities count: 0
via 21.121.0.121, GigabitEthernet0/0/0/0, PE121, SRGB Base: Path id:65 Path ref count:1
16000, Weight: 0 NHID:0x4(Ref:10)
src PE122.00-00, 3.3.3.122, prefix-SID index 122, R:0 N:1 P:0 Route version is 0xd (13)
E:0 V:0 L:0 Local Label: 0x3efa (16122)
[SNIP] © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public
ISIS Validation Only
Segment Routing Validation
Forwarding Plane Forwarding Plane
RP/0/0/CPU0:A21#show cef 3.3.3.122/32 detail A21 RP/0/0/CPU0:A21#show mpls forwarding labels 16122 A21
Mon Jan 29 02:10:35.815 UTC Mon Jan 29 02:15:30.415 UTC
3.3.3.122/32, version 104, labeled SR, internal 0x1000001 0x81 (ptr Local Outgoing Prefix Outgoing Next Hop Bytes
0xa134e63c) [1], 0x0 (0xa1333878), 0xa28 (0xa18190d4) Label Label or ID Interface Switched
Updated Jan 25 04:13:15.336 ------ ----------- ------------------ ------------ --------------- ------------
local adjacency 21.121.0.121 16122 16122 SR Pfx (idx 122) Gi0/0/0/0 21.121.0.121 957044
Prefix Len 32, traffic index 0, precedence n/a, priority 1 16122 SR Pfx (idx 122) Gi0/0/0/1 21.22.1.22 0 (!)
gateway array (0xa1299a48) reference count 3, flags 0x500068, !
source rib (7), 0 backups Primary & Backup Path
[2 type 5 flags 0x8401 (0xa15ef5f0) ext 0x0 (0x0)]
LW-LDI[type=5, refc=3, ptr=0xa1333878, sh-ldi=0xa15ef5f0] RP/0/0/CPU0:A21#ping 3.3.3.122 source 2.2.2.21
gateway array update type-time 1 Jan 25 04:13:15.336 Mon Jan 29 02:16:11.032 UTC
Ping
LDI Update time Jan 25 04:13:15.336 Type escape sequence to abort.
LW-LDI-TS Jan 25 04:13:15.336 Sending 5, 100-byte ICMP Echos to 3.3.3.122, timeout is 2 seconds:
via 21.121.0.121/32, GigabitEthernet0/0/0/0, 10 dependencies, !!!!!
weight 0, class 0, protected [flags 0x400] Success rate is 100 percent (5/5), round-trip min/avg/max = 9/9/9 ms
path-idx 0 bkup-idx 1 NHID 0x0 [0xa1833544 0x0] Primary Path & !
next hop 21.121.0.121/32 Label Imposed
local label 16122 labels imposed {16122}
via 21.22.1.22/32, GigabitEthernet0/0/0/1, 10 dependencies, RP/0/0/CPU0:A21#traceroute 3.3.3.122 source 2.2.2.21
weight 0, class 0, backup (Local-LFA) [flags 0x300] Mon Jan 29 02:16:33.810 UTC
path-idx 1 NHID 0x0 [0xa171c250 0x0] Traceroute
next hop 21.22.1.22/32 Type escape sequence to abort.
local adjacency Backup Path & Tracing the route to 3.3.3.122
local label 16122 labels imposed {16122} Label Imposed
[SNIP] 1 21.121.0.121 [MPLS: Label 16122 Exp 0] 19 msec 9 msec 9 msec
2 121.122.2.122 9 msec * 9 msec
© 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public
Designing the Programmable Underlay
Step 2: Network Topology Discovery
BGP-LS Overview
Path PCE Traffic
Computation Engineering
• Build TED for Multi-Domain Optimal Element (PCE) Database (TED)
Path Computation
• Scalable Solution is BGP, not IGP.
CLI>
• BGP-LS is an address-family BGP-LS
ABR 1 ABR 2
• afi=16388, safi=71
Head-End
• Defined to carry IGP link-state
Domain A Domain B Domain C
database via BGP
• Supports both IS-IS and OSPF
• Delivers topology information to outside
agents
• Only one BGP-LS speaker required
per domain
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 28
XR Transport Controller (XTC)
An IOS XR-powered Stateful Path Computation Element (PCE)
WAE Custom app
• Multi-Domain Topology Collection
• Real-time reactive feed
XTC
• Computation
North-Bound API
• Native SR Policy algorithms
Multi-Domain
Computation
• Applicable to Centralized (Controller) Topology
and Distributed (Router) deployments
“Collection” “Deployment”
BGP-LS PCEP
ISIS / OSPF
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 29
XTC – Real-time Topology Feed
• XTC learns real-time topologies via BGP-LS and/or IGP
• BGP-LS is intended to carry link-state topology information
• Hence the name “LS” that stands for “Link State”
• BGP-LS has been extended multiple times in order to incorporate other types of
topology information:
• SR Extensions
• Traffic Engineering Metric Extensions
• Egress Peer Engineering
• SR TE Policies
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 30
BGP Link State Configuration
• Common topology abstraction model
• IGP network modeled
• Three classes of objects
• Nodes
• Links
• prefixes
BGP-LS Objects
• 11 nodes
• 29 links
• 98 prefixes
• 248 Paths
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 31
Configure
BGP Link State Device Configuration
IGP Configuration BGP Configuration
RP/0/0/CPU0:PE122#config t PE122 RP/0/0/CPU0:PE122#sh run router bgp PE122
! Mon Jan 29 04:09:49.717 UTC
router isis 3 Instance ID = router bgp 1
distribute bgp-ls instance-id 3 bgp router-id 3.3.3.122 BGP ID
Domain ID
! !
RP/0/0/CPU0:PE122#sh run router isis 2 [SNIP]
Mon Jan 29 04:18:22.432 UTC !
router isis 2 neighbor-group epn
is-type level-2-only remote-as 1
net 49.0001.0000.0000.0122.00 update-source Loopback0
distribute link-state instance-id 2 address-family ipv4 labeled-unicast
address-family ipv4 unicast route-reflector-client
Specify BGP-LS
segment-routing mpls Domain 2 next-hop-self
! Neighbor
!
interface Loopback0 !
address-family ipv4 unicast neighbor 4.4.4.4 XR Transport
prefix-sid index 122 remote-as 1 Controller (XTC)
! update-source Loopback0 Address
! address-family ipv4 labeled-unicast
interface GigabitEthernet0/0/0/1 !
point-to-point address-family link-state link-state
address-family ipv4 unicast ! Enable BGP Link
fast-reroute per-prefix ! State
fast-reroute per-prefix ti-lfa neighbor 2.2.2.21
[SNIP] use neighbor-group epn
!
[Output TRIMMED]
© 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public
Configure
BGP Link State XTC Configuration
RP/0/0/CPU0:XTC-RR4#sh run router bgp XTC-RR4
Mon Jan 29 04:07:50.050 UTC
router bgp 1
bgp router-id 4.4.4.4
BGP ID
address-family ipv4 unicast
table-policy fib
additional-paths receive
additional-paths send
additional-paths selection route-policy multipath
!
address-family link-state link-state
!
neighbor-group epn
remote-as 1
update-source Loopback0
address-family ipv4 labeled-unicast
Enable Address
route-reflector-client
Family Link State
!
address-family link-state link-state
!
neighbor 3.3.3.111
use neighbor-group epn
! BGP-LS Neighbors
neighbor 3.3.3.112
use neighbor-group epn
!
[SNIP]
© 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public
BGP -LS Validation Only
Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd Total = 62x4 = 248 Paths
3.3.3.111 0 1 2792 2758 95 0 0 1d21h 62
3.3.3.112 0 1 2792 2758 95 0 0 1d21h 62
3.3.3.121 0 1 2788 2758 95 0 0 1d21h 62
3.3.3.122 0 1 2788 2758 95 0 0 1d21h 62
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 34
BGP -LS Validation Only
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 35
BGP -LS Validation Only
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 39
Verification
SR Policy Verification
RP/0/0/CPU0:A23#sh segment-routing traffic-eng policy 4.4.4.4/32
Sun Jan 28 15:23:57.734 UTC
XTC-RR4
XTC-RR4
SR-TE policy database
---------------------
1.1.1.11/32 3.3.3.121/3
Name: POLICY1 (Color: 30, End-point: 1.1.1.13) 3.3.3.111/32
2
Status: 2.2.2.21/32
Admin: up Operational: up for 00:00:07 (since Jan 28 A11 Gig0/0/0/0
PE111
Gig0/0/0/1
PE121
Gig0/0/0/0 A21
15:23:50.464)
1.1.1.12/32 Gig0/0/0/1 Gig0/0/0/1
Candidate-paths:
2.2.2.22/32
Preference 200:
Explicit: segment-list SIDLIST1 (active)
A12 OSPF 1 ISIS 3 ISIS 2 A22
Weight: 0, Metric Type: TE
Gig0/0/0/2 3.3.3.112/32 3.3.3.122/32 Gig0/0/0/2
16122 1.1.1.13/32
2.2.2.23/32
16112
16013
A13 Gig0/0/0/0
PE112
Gig0/0/0/1
PE122
Gig0/0/0/0 A23
Preference 100:
Dynamic (inactive)
Access Domain ID 1 Core Domain ID 3Access Domain ID 2
Weight: 0, Metric Type: IGP
Attributes:
Binding SID: 1000
Allocation mode: explicit
State: Programmed
Policy selected: yes
Forward Class: 0
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 40
XTC – IOS XR PCE Configuration Configure
Enable PCE
© 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 41
PCC – Device Configuration Configure
© 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 42
Verification
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 43
Verification
PCEP Verification – IOS XR PCE
RP/0/0/CPU0:XTC-RR4#show pce ipv4 topology summary XTC-RR4
Mon Jan 29 13:30:30.987 UTC
Private Information:
Lookup Nodes 15
Consistent yes
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 44
Verification
PCEP Verification – IOS XR PCE
RP/0/0/CPU0:XTC-RR4#show pce ipv4 topology 1.1.1.11
Mon Jan 29 13:35:12.578 UTC
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 45
Next Step:
Service Enablement or Service
Provisioning
Network Services Orchestrator (NSO)
Management Network
• Multi-vendor service orchestrator Applications Engineer
o Distributed service configuration management
o Transaction integrity REST, Java, NETCONF Network-wide CLI, Web UI
o Validation and rollback
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 47
Configure
Step 1: L3VPN Provisioning
RP/0/0/CPU0:A11#config t A11
• Configure L3VPN Service on Node A11 and A21 vrf epn
address-family ipv4 unicast
import route-target
1:1
!
export route-target
XTC- 1:1
RR NSO !
interface Loopback10
vrf epn
ipv4 address 9.9.9.11 255.255.255.255
!
interface Loopback11
vrf epn
A11 PE111 PE121 A21 ipv4 address 8.8.8.11 255.255.255.255
!
router bgp 1
bgp router-id 1.1.1.11
address-family ipv4 unicast
!
A12 OSPF ISIS ISIS A22 address-family vpnv4 unicast
!
neighbor 4.4.4.4
remote-as 1
update-source Loopback0
A13 PE112 PE122 A23 address-family vpnv4 unicast
!
vrf epn
rd 11:11
address-family ipv4 unicast
redistribute connected
© 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 48
Configure
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 49
Verification
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 50
Verfication
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 51
Configure
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 52
Configure
Step 4: Apply the route-policy to the BGP VPNv4 unicast
peering between A11 and the route reflector (XTC-RR4)
router bgp 1 A11
bgp router-id 1.1.1.11
!
address-family vpnv4 unicast
!
neighbor 4.4.4.4
remote-as 1
update-source Loopback0
address-family vpnv4 unicast
route-policy SET_COLOR out
Egress PE Policy
If Prefix 8.8.8.0/24 then set Color 10
else
Set Color 20
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 53
Configure
commit
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 54
L3VPN Verfication
L3VPN Service Validation
Control Plane Control Plane
RP/0/0/CPU0:A11# show bgp vrf epn A11 RP/0/0/CPU0:A11#sh bgp vpnv4 unicast vrf epn 8.8.8.21/32 A11
Mon Jan 29 15:11:52.273 UTC Mon Jan 29 15:14:35.342 UTC
BGP VRF epn, state: Active BGP routing table entry for 8.8.8.21/32, Route Distinguisher: 11:11
BGP Route Distinguisher: 11:11 Versions:
VRF ID: 0x60000001 Process bRIB/RIB SendTblVer
BGP router identifier 1.1.1.11, local AS number 1 Speaker 57 57
Non-stop routing is enabled Last Modified: Jan 27 05:41:18.359 for 2d09h
BGP table state: Active Paths: (1 available, best #1)
Table ID: 0xe0000010 RD version: 61 Not advertised to any peer
BGP main routing table version 62 Path #1: Received by speaker 0
BGP NSR Initial initsync version 13 (Reached) Not advertised to any peer
BGP NSR/ISSU Sync-Group versions 0/0 Local
2.2.2.21 C:10 (bsid:24018) from 4.4.4.4 (2.2.2.21)
Status codes: s suppressed, d damped, h history, * valid, > best Received Label 24007
i - internal, r RIB-failure, S stale, N Nexthop-discard Origin incomplete, metric 0, localpref 100, valid, internal, best, group-
Origin codes: i - IGP, e - EGP, ? - incomplete best, import-candidate, imported
Network Next Hop Metric LocPrf Weight Path Received Path ID 0, Local Path ID 0, version 55
Route Distinguisher: 11:11 (default for vrf epn) Extended community: Color:10 RT:1:1
*> 8.8.8.11/32 0.0.0.0 0 32768 ? Originator: 2.2.2.21, Cluster list: 4.4.4.4
*>i8.8.8.21/32 2.2.2.21 C:10 0 100 0? SR ODN policy color 10, up, registered, bsid 24018, if-handle
*> 9.9.9.11/32 0.0.0.0 0 32768 ? 0x00000190
*>i9.9.9.21/32 2.2.2.21 C:20 0 100 0? SR Policy Color
Processed 4 prefixes, 4 paths Source AFI: VPNv4 Unicast, Source VRF: default, Source Route
Color Distinguisher: 21:21
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 55
Verification
L3VPN Service Validation
Forwarding Plane Forwarding Plane
RP/0/0/CPU0:A11#sh segment-routing traffic-eng policy A11 RP/0/0/CPU0:A11#sh segment-routing traffic-eng policy A11
Mon Jan 29 15:16:29.444 UTC Mon Jan 29 15:16:29.444 UTC
SR-TE policy database Policy Color SR-TE policy database Policy Color
--------------------- and End Point --------------------- and End Point
Name: bgp_AP_1 (Color: 20, End-point: 2.2.2.21) Name: bgp_AP_8 (Color: 10, End-point: 2.2.2.21)
Status: Status:
Admin: up Operational: up for 1d22h (since Jan 27 16:40:54.734) Admin: up Operational: up for 2d09h (since Jan 27 05:41:18.356)
Candidate-paths: Candidate-paths:
Preference 100: Preference 100:
Dynamic (pce 4.4.4.4) (active) Dynamic (pce 4.4.4.4) (active)
Weight: 0, Metric Type: IGP Weight: 0, Metric Type: TE
TE Path
16111 [Prefix-SID, 3.3.3.111] 16112 [Prefix-SID, 3.3.3.112]
16121 [Prefix-SID, 3.3.3.121]
IGP Path 16122 [Prefix-SID, 3.3.3.122]
16021 [Prefix-SID, 2.2.2.21] 24006 [Adjacency-SID, 121.122.2.122 - 121.122.2.121]
Attributes: 16021 [Prefix-SID, 2.2.2.21]
Binding SID: 24013 Attributes:
Allocation mode: dynamic Binding SID: 24018
State: Programmed Allocation mode: dynamic
Policy selected: yes State: Programmed
Forward Class: 0 Policy selected: yes
Distinguisher: 0 Forward Class: 0
Auto-policy info: Distinguisher: 0
Creator: BGP Auto-policy info:
IPv6 caps enable: no Creator: BGP
IPv6 caps enable: no
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 56
Data Plane (IGP Metric) 4.4.4.4/32
NSO
XTC-RR4
3.3.3.111/32 3.3.3.121/32
1.1.1.11/32 2.2.2.21/32
11.111.0/24 111.121.1/24 21.121.0/24
A11 Gig0/0/0/0
PE111 Gig0/0/0/1
PE121 Gig0/0/0/0 A21
Gig0/0/0/1 OSPF 1 ISIS 3 ISIS 2
Gig0/0/0/1
111.112.3/24
111.112.2/24
121.122.2/24
Prefix-SID-List [16111,16121,16021]
121.122.3/24
Gig0/0/0/3
Gig0/0/0/2
1.1.1.12/32
Gig0/0/0/2
Gig0/0/0/3
2.2.2.22/32
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 57
16112
4.4.4.4/32
Data Plane 16122 NSO
Adj-SID
(TE Metric) XTC-RR4 16021
16021
service service
service
frame frame frame
frame
3.3.3.111/32 3.3.3.121/32
1.1.1.11/32 2.2.2.21/32
11.111.0/24 TE Metric 100
111.121.1/24 21.121.0/24
A11 Gig0/0/0/0
PE111 Gig0/0/0/1
PE121 Gig0/0/0/0 A21
Gig0/0/0/1
OSPF 1 ISIS 3 ISIS 2 Gig0/0/0/1
TE Metric 100
111.112.3/24
111.112.2/24
121.122.2/24
16112
121.122.3/24
Gig0/0/0/3
Gig0/0/0/2
1.1.1.12/32
Gig0/0/0/2
Gig0/0/0/3
2.2.2.22/32
A12
16122 A22
Adj-SID
16021
Gig0/0/0/2
3.3.3.112/32 3.3.3.122/32 Gig0/0/0/2
16122 Adj-SID
Adj-SID 16021
16021 service
service frame
frame BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 58
Verification
L3VPN Service Validation Forwarding Plane
Forwarding Plane
RP/0/0/CPU0:XTC-RR4#show pce lsp detail XTC-RR4
RP/0/0/CPU0:A11#sh cef vrf epn 8.8.8.21/32 A11
Mon Jan 29 15:18:16.686 UTC Mon Jan 29 15:20:36.485 UTC
8.8.8.21/32, version 38, internal 0x5000001 0x0 (ptr 0xa134e4a4) [1], PCE's tunnel database:
0x0 (0x0), 0x208 (0xa15d54d8) ----------------------
Updated Jan 27 05:41:18.405 PCC 1.1.1.11:
Prefix Len 32, traffic index 0, precedence n/a, priority 3
SR Policy Status
via local-label 24018, 3 dependencies, recursive [flags 0x6000] Tunnel Name: bgp_AP_1
path-idx 0 NHID 0x0 [0xa163e96c 0x0] LSPs:
recursion-via-label
Primary Path & LSP[0]:
next hop VRF - 'default', table - 0xe0000000 Label Imposed source 1.1.1.11, destination 2.2.2.21, tunnel ID 1, LSP ID 84
next hop via 24018/0/21 State: Admin up, Operation active
next hop bgp_AP_8 labels imposed {ImplNull 24007} Setup type: Segment Routing
! Binding SID: 24013
Reported Path
RP/0/0/CPU0:A11#traceroute 8.8.8.21 source 8.8.8.11 vrf epn Bandwidth: signaled 0, applied 0
Type escape sequence to abort. ! [Output Trimmed]
Tracing the route to 8.8.8.21 TE Path Reported path:
Metric type: IGP, Accumulated Metric 0
1 11.111.0.111 [MPLS: Labels 16112/16122/24006/16021/24007 Exp SID[0]: Node, Label 16111, Address 3.3.3.111
0] 29 msec 19 msec 19 msec SID[1]: Node, Label 16121, Address 3.3.3.121
2 111.112.2.112 [MPLS: Labels 16122/24006/16021/24007 Exp 0] 29 SID[2]: Node, Label 16021, Address 2.2.2.21
msec 19 msec 19 msec Computed path: (Local PCE)
3 112.122.1.122 [MPLS: Labels 24006/16021/24007 Exp 0] 29 Computed Time: Mon Jan 29 15:10:39 2018 (00:09:57 ago)
msec 29 msec 19 msec Metric type: IGP, Accumulated Metric 21
4 121.122.2.121 [MPLS: Labels 16021/24007 Exp 0] 19 msec 19 SID[0]: Node, Label 16111, Address 3.3.3.111
msec 19 msec SID[1]: Node, Label 16121, Address 3.3.3.121
5 21.121.0.21 29 msec * 29 msec SID[2]: Node, Label 16021, Address 2.2.2.21
!
[SNIP] Computed Path
© 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public
Summary
• Multi-domain Segment Routing (SR-TE) policies
computed by a stateful SR PCE
• Coupled with SR On-Demand Next-hops (ODN)
XTC-RR NSO
• Scalable – automatic SR-TE policies triggered by service
(VPN) routes
• Auto-Steering – automatic steering of service traffic into SR-
TE policies
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 62
Summary
PCEP Session between PCE and PCC
XTC-RR as SR PCE
XTC-RR NSO
PCEP PCEP
A1x as SR PCC
A2x as SR PCC
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 63
Summary
Step 1 – NSO Instantiate the L3VPN Service
NSO
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 64
Summary
Step 2 - VPN routes propagated via BGP
XTC- XTC-RR as BGP RR
RR
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 65
Summary
Step 2 - VPN routes propagated via BGP
XTC- XTC-RR as BGP RR
RR
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 66
Summary
Step 2 - VPN routes propagated via BGP
XTC- XTC-RR as BGP RR
BGP VPNv4 RR BGP VPNv4
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 67
Summary
Step 3 - PCE Path Computation - Request
XTC- XTC-RR as SR PCE
RR
A11 as SR PCC
A11 PE111 PE121 A21
VPN acme VPN acme
Site 1 Site 2
OSPF ISIS
A13 PE112 PE122 A23
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 68
Summary
Step 3 - PCE Path Computation - Request
XTC- XTC-RR as SR PCE
RR
• Ingress PE matches on user-specified BGP community
3 • Ingress PE enforces policy associated with the community
A11 as SR PCC
A11 PE111 PE121 A21
VPN acme VPN acme
Site 1 Site 2
OSPF ISIS
A13 PE112 PE122 A23
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 69
Summary
Step 3 - PCE Path Computation - Request
<policy_sample>
XTC- XTC-RR as SR PCE
IF color = 10
THEN RR
PCEP
contact PCE
Need a path to node (A21)
request path to BGP NH Rule: Minimize TE metric • Ingress PE matches on user-specified BGP community
minimize TE metric 3 • Ingress PE enforces policy associated with the community
A11 as SR PCC
A11 PE111 PE121 A21
VPN acme VPN acme
Site 1 Site 2
OSPF ISIS
A13 PE112 PE122 A23
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 70
Summary
Step 4 - PCE Path Computation - Response
XTC- XTC-RR as SR PCE
RR
PCEP
SR-EROs
• PCE computes path
Label 1 4 • PCE replies to PCC with SR-EROs (segment (SID) list)
A11 as SR PCC Label 2
Label 3
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 71
Summary
Step 5 - Service Up and Running with the path established.
FIB
Y/24 via label 24018
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 72
Summary
Step 5 - Service Up and Running with the path established.
B-SID = 24018
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 73
Summary
Step 5 - Service Up and Running with the path established.
FIB
Y/24 via label 24018
B-SID = 24018
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 74
Summary
Step 5 - Service Up and Running with the path established.
B-SID = 24018
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 75
Conclusions
Controllers, Orchestrators
Programmatic Approach
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 77
References
• LTRMPL-2104 - Cisco WAN Automation Engine (WAE) Network Programmability with
Segment Routing
• Agile Carrier Ethernet Demonstration on Youtube -
https://www.youtube.com/watch?v=biYqyAn9rl0
• Segment Routing .net - http://www.segment-routing.net/
• Segment Routing Demo Friday - https://www.sdxcentral.com/resources/sdn-
demofriday/segment-routing-cisco-demofriday/
• Cisco Programmability Yang blog - http://blogs.cisco.com/tag/yang
• Tail-f netconf yang tutorials - http://www.tail-f.com/education/
• BGP-LS linkedin blog: https://www.linkedin.com/pulse/introduction-open-api-bgp-link-state-
bgp-ls-source-controller-abeer?trk=prof-post
• Netconf linkedin blog: https://www.linkedin.com/pulse/netconf-rfc-6242-protocol-tutorial-
ahmed-n-abeer?trk=prof-post
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 78
Cisco Spark
Questions?
Use Cisco Spark to communicate
with the speaker after the session
How
1. Find this session in the Cisco Live Mobile App
2. Click “Join the Discussion”
3. Install Spark or go directly to the space
4. Enter messages/questions in the space
cs.co/ciscolivebot#BRKSPG-2210
© 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public
• Please complete your Online Complete Your Online
Session Evaluations after each
session
Session Evaluation
• Complete 4 Session Evaluations
& the Overall Conference
Evaluation (available from
Thursday) to receive your Cisco
Live T-shirt
• All surveys can be completed via
the Cisco Live Mobile App or the
Communication Stations
Don’t forget: Cisco Live sessions will be available
for viewing on-demand after the event at
www.ciscolive.com/global/on-demand-library/.
© 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public
Continue Your Education
• Demos in the Cisco campus
• Walk-in Self-Paced Labs
• Tech Circle
• Meet the Engineer 1:1 meetings
• Related sessions
BRKSPG-2210 © 2018 Cisco and/or its affiliates. All rights reserved. Cisco Public 81
Thank you