VLAN Lab
VLAN Lab
You work as Junior Network Engineer for RADO Network Ltd Company. Your colleague has set up a Layer 2 network
for testing purpose in one of your client locations.
You must verify the configuration and fix if any issues identified as per customer requirements.
Topology Details:
- Three switches (SW1, SW2 and SW3) are connected using Ethernet link as shown in the topology diagram.
- Server1 and PC1 are connected to SW1 and are assigned to VLAN 500 and VLAN 600 respectively.
- Server2 and PC2 are connected to SW2 and are assigned to VLAN 500 and VLAN 600 respectively.
- PC3 is connected to SW3 and assigned to VLAN 600.
Customer requirements:
- Verify if switch ports are assigned in correct VLANs as per topology diagram. Identify and fix any
misconfigurations found in three switches.
- Verify if trunk links are operational between switches and the IEEE 802.1q trunk encapsulation method is used.
Identify and fix if any misconfigurations are found in the trunk configuration.
- You must make sure the ports connected between switches are set as trunk ports.
Special Note: To gain the maximum number of points you must make sure that VLANs are assigned to switch ports as
per customer requirements and make sure the trunk links are operational between switches. Do not change VLAN
names and VLAN number that are already configured in the switches.
Answer
SW1
1. VLAN configuration:
SW1>enable
SW1#conf t
SW1(config)#interface e0/2
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 500
SW1(config-if)#exit
SW1(config)#interface e0/3
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 600
SW1(config-if)#exit
2. Trunk configuration:
SW1(config)#interface e0/0
Sw1(config-if)#switchport trunk encapsulation dot1q
Sw1(config-if)#Switchport mode trunk
Sw1(config-if)#switchport trunk native vlan 1
Sw1(config-if)#exit
SW1(config)#exit
SW1#copy run start
SW2
VLAN configuration:
SW2>enable
SW2#conf t
SW2(config)#interface e0/2
SW2(config-if)#switchport mode access
SW2(config-if)#switchport access vlan 500
SW2(config-if)#exit
SW2(config)#interface e0/3
SW2(config-if)#switchport mode access
SW2(config-if)#switchport access vlan 600
SW2(config-if)#exit
SW2(config)#exit
SW2#copy run start
SW3
Trunk configuration:
SW3>enable
SW3#conf t
SW3(config)#interface e0/0
Sw3(config-if)#switchport trunk encapsulation dot1q
Sw3(config-if)#Switchport mode trunk
Sw3(config-if)#switchport trunk native vlan 1
Sw3(config-if)#exit
SW3(config)#exit
SW3#copy run start