0% found this document useful (0 votes)
110 views

Script Low Version (Mangle Dan Queue Tree)

The document configures traffic shaping and marking on a firewall. It marks different types of traffic like gaming, YouTube, social media, browsing and downloads. It then prioritizes gaming traffic and sets bandwidth limits for different traffic classes in the queue tree for downstream and upstream traffic.

Uploaded by

Bejoy w
Copyright
© © All Rights Reserved
Available Formats
Download as TXT, PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
110 views

Script Low Version (Mangle Dan Queue Tree)

The document configures traffic shaping and marking on a firewall. It marks different types of traffic like gaming, YouTube, social media, browsing and downloads. It then prioritizes gaming traffic and sets bandwidth limits for different traffic classes in the queue tree for downstream and upstream traffic.

Uploaded by

Bejoy w
Copyright
© © All Rights Reserved
Available Formats
Download as TXT, PDF, TXT or read online on Scribd
You are on page 1/ 3

/ip firewall mangle

add action=change-ttl chain=postrouting comment="Block Shared WiFi" new-ttl=\


set:1 out-interface="ether3-INTERNET(EvRa@WiFi)" passthrough=no
add action=change-ttl chain=postrouting new-ttl=set:1 out-interface=\
"ether4-INTERNET(EvRa@Hotspot)" passthrough=no
add action=mark-connection chain=prerouting comment="Mangle Game" \
new-connection-mark="conn=Gaming" passthrough=yes protocol=icmp \
src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting connection-rate=0-200k \
dst-address-list="!IP LOCAL" dst-port=!0-1023,8080 new-connection-mark=\
"conn=Gaming" passthrough=yes protocol=tcp src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting connection-rate=0-200k \
dst-address-list="!IP LOCAL" dst-port=!0-1023,8080 new-connection-mark=\
"conn=Gaming" passthrough=yes protocol=udp src-address-list="IP LOCAL"
add action=mark-packet chain=forward connection-mark="conn=Gaming" \
in-interface=ether1-INDIHOME new-packet-mark="packet=Gaming Down" \
passthrough=yes
add action=mark-packet chain=forward connection-mark="conn=Gaming" \
new-packet-mark="packet=Gaming Up" out-interface=ether1-INDIHOME \
passthrough=yes
add action=mark-connection chain=prerouting comment="Mangle Youtube" content=\
googlevideo.com dst-address-list="!IP LOCAL" new-connection-mark=\
"conn=Youtube" passthrough=yes src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting content=.ytimg.com \
dst-address-list="!IP LOCAL" new-connection-mark="conn=Youtube" \
passthrough=yes src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting content=.youtube \
dst-address-list="!IP LOCAL" new-connection-mark="conn=Youtube" \
passthrough=yes src-address-list="IP LOCAL"
add action=mark-packet chain=forward connection-mark="conn=Youtube" \
in-interface=ether1-INDIHOME new-packet-mark="packet=Youtube Down" \
passthrough=yes
add action=mark-packet chain=forward connection-mark="conn=Youtube" \
new-packet-mark="packet=Youtube Up" out-interface=ether1-INDIHOME \
passthrough=yes
add action=mark-connection chain=prerouting comment="Mangle Sosmed" content=\
.cdninstagram.com dst-address-list="!IP LOCAL" new-connection-mark=\
"conn=Sosmed" passthrough=yes src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting content=\
scontent-sin6-2.cdninstagram.com dst-address-list="!IP LOCAL" \
new-connection-mark="conn=Sosmed" passthrough=yes src-address-list=\
"IP LOCAL"
add action=mark-connection chain=prerouting content=.instagram.com \
dst-address-list="!IP LOCAL" new-connection-mark="conn=Sosmed" \
passthrough=yes src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting content=.whatsapp.net \
dst-address-list="!IP LOCAL" new-connection-mark="conn=Sosmed" \
passthrough=yes src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting content=.whatsapp.com \
dst-address-list="!IP LOCAL" new-connection-mark="conn=Sosmed" \
passthrough=yes src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting content=.facebook.com \
dst-address-list="!IP LOCAL" new-connection-mark="conn=Sosmed" \
passthrough=yes src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting content=.facebook.net \
dst-address-list="!IP LOCAL" new-connection-mark="conn=Sosmed" \
passthrough=yes src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting content=.fbcdn.net \
dst-address-list="!IP LOCAL" new-connection-mark="conn=Sosmed" \
passthrough=yes src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting content=.twitter.com \
dst-address-list="!IP LOCAL" new-connection-mark="conn=Sosmed" \
passthrough=yes src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting content=twitter.com \
dst-address-list="!IP LOCAL" new-connection-mark="conn=Sosmed" \
passthrough=yes src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting content=.twimg.com \
dst-address-list="!IP LOCAL" new-connection-mark="conn=Sosmed" \
passthrough=yes src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting content=.telegram.org \
dst-address-list="!IP LOCAL" new-connection-mark="conn=Sosmed" \
passthrough=yes src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting content=telegram.org \
dst-address-list="!IP LOCAL" new-connection-mark="conn=Sosmed" \
passthrough=yes src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting content=tiktokcdn.com \
dst-address-list="!IP LOCAL" new-connection-mark="conn=Sosmed" \
passthrough=yes src-address-list="IP LOCAL"
add action=mark-packet chain=forward connection-mark="conn=Sosmed" \
in-interface=ether1-INDIHOME new-packet-mark="packet=Sosmed Down" \
passthrough=yes
add action=mark-packet chain=forward connection-mark="conn=Sosmed" \
new-packet-mark="packet=Sosmed Up" out-interface=ether1-INDIHOME \
passthrough=yes
add action=mark-connection chain=prerouting comment="Mangle Browsing" \
connection-mark="!conn=Gaming" connection-rate=200k-500k \
dst-address-list=!Gaming new-connection-mark="conn=Browsing" passthrough=\
yes protocol=!icmp src-address-list="!IP LOCAL"
add action=mark-packet chain=forward connection-mark="conn=Browsing" \
in-interface=ether1-INDIHOME new-packet-mark="packet=Browsing Down" \
passthrough=yes
add action=mark-packet chain=forward connection-mark="conn=Browsing" \
new-packet-mark="packet=Browsing Up" out-interface=ether1-INDIHOME \
passthrough=yes
add action=mark-connection chain=prerouting comment="Mangle Berat" \
connection-mark="!conn=Gaming" connection-rate=500k-999M \
dst-address-list="!IP LOCAL" dst-port=!1024-65535 new-connection-mark=\
"conn=Download" passthrough=yes protocol=tcp src-address-list="IP LOCAL"
add action=mark-connection chain=prerouting connection-mark="!conn=Gaming" \
connection-rate=500k-999M dst-address-list="!IP LOCAL" dst-port=\
!1024-65535 new-connection-mark="conn=Download" passthrough=yes protocol=\
udp src-address-list="IP LOCAL"
add action=mark-packet chain=forward connection-mark="conn=Download" \
in-interface=ether1-INDIHOME new-packet-mark="packet=Download Down" \
passthrough=yes
add action=mark-packet chain=forward connection-mark="conn=Download" \
new-packet-mark="packet=Download Up" out-interface=ether1-INDIHOME \
passthrough=yes

===============================================================================

/queue tree
add name="SEMUA TRAFIK" parent=global
add name="A.Trafik Down" parent="SEMUA TRAFIK"
add name=LOKAL packet-mark=no-mark parent="SEMUA TRAFIK"
add name=DOWNLOAD parent="A.Trafik Down" queue=pcq-download-default
add name=UPLUAD parent="A.Trafik Down" queue=pcq-upload-default
add name="1.GAME DOWN" packet-mark="packet=Gaming Down" parent=DOWNLOAD \
priority=1 queue=pcq-download-default
add max-limit=35M name="2.All Trafik Down" parent=DOWNLOAD priority=2 queue=\
pcq-download-default
add name="a.Sosmed Down" packet-mark="packet=Sosmed Down" parent=\
"2.All Trafik Down" priority=2 queue=pcq-download-default
add name="d.Berat Down" packet-mark="packet=Download Down" parent=\
"2.All Trafik Down" priority=2 queue=pcq-download-default
add name="1.GAME UP" packet-mark="packet=Gaming Up" parent=UPLUAD priority=1 \
queue=pcq-upload-default
add max-limit=5M name="2.All Trafik Up" parent=UPLUAD priority=2 queue=\
pcq-upload-default
add name="a.Sosmed Up" packet-mark="packet=Sosmed Up" parent=\
"2.All Trafik Up" priority=2 queue=pcq-upload-default
add name="d.Download Up" packet-mark="packet=Download Up" parent=\
"2.All Trafik Up" priority=2 queue=pcq-upload-default
add name="b.Youtube Down" packet-mark="packet=Youtube Down" parent=\
"2.All Trafik Down" priority=2 queue=pcq-download-default
add name="b.Youtube Up" packet-mark="packet=Youtube Up" parent=\
"2.All Trafik Up" priority=2 queue=pcq-upload-default
add name="c.Browsing Down" packet-mark="packet=Browsing Down" parent=\
"2.All Trafik Down" priority=2 queue=pcq-download-default
add name="c.Browsing Up" packet-mark="packet=Browsing Up" parent=\
"2.All Trafik Up" priority=2 queue=pcq-upload-default

You might also like