Flow-Based Per Port-Channel Load Balancing: Finding Feature Information
Flow-Based Per Port-Channel Load Balancing: Finding Feature Information
Flow-Based Per Port-Channel Load Balancing: Finding Feature Information
The Flow-Based per Port-Channel Load Balancing feature allows different flows of traffic over a Gigabit
EtherChannel (GEC) interface to be identified based on the packet header and then mapped to the different
member links of the port channel. This feature enables you to apply flow-based load balancing and
VLAN-manual load balancing to specific port channels.
The figure below illustrates an example of 16 buckets distributed among three member links. The numbers
shown in the buckets are the bucket IDs. Note that the first member link has an extra bucket.
If you change the load-balancing method, the bucket-to-member link mappings for flow-based load balancing
are deleted. The mappings are also deleted if the port channel is deleted or the last member link in the port
channel is deleted or goes down.
Flow-based Flow-based
VLAN-manual VLAN-manual
Flow-based Flow-based
VLAN-manual VLAN-manual
The table below lists the configuration that results if you change the global load-balancing method.
The table below lists the configuration that results if you change the port-channel load-balancing method.
SUMMARY STEPS
1. enable
2. configure terminal
3. interface port-channel channel-number
4. load-balancing {flow | vlan}
5. end
DETAILED STEPS
Example:
Router# configure terminal
Step 3 interface port-channel channel-number Enters interface configuration mode and defines the interface as
a port channel.
Example:
Router(config)# interface port-channel 1
Step 4 load-balancing {flow | vlan} Applies a load-balancing method to the specific port channel.
• If you do not configure this command, the port channel
Example: uses the global load-balancing method configured with the
Router(config-if)# load-balancing flow port-channel load-balancing vlan-manual command.
The global default is flow-based.
Example:
Router(config-if)# end
SUMMARY STEPS
DETAILED STEPS
Example:
Router# show running-config interface port-channel 1
Building configuration...
Example:
Router# show etherchannel load-balancing
Port-Channel: LB Method
Port-channel1 : flow-based
Example:
Router(config)# show interface port-channel 2 etherchannel
Port: GigabitEthernet2/1/7
!
no aaa new-model
port-channel load-balancing vlan-manual
ip source-route
.
.
.
interface Port-channel2
ip address 10.0.0.1 255.255.255.0
no negotiation auto
load-balancing flow
!
interface Port-channel2.10
ip rsvp authentication key 11223344
ip rsvp authentication
!
interface Port-channel2.50
encapsulation dot1Q 50
!
interface GigabitEthernet2/1/0
no ip address
negotiation auto
cdp enable
channel-group 2
!
Earlier, the GEC flow-based load balancing feature was applicable only for layer 3 (network layer). With the
five-tuple hash support, it’s applicable for layer 4 (TCP/IP layer) also. But it is supported only for the TCP
and UDP, layer 4 protocols.
Restrictions for Five-Tuple Hash Support for GEC Flow-based Load Balancing
The five-tuple hash support for GEC flow-based load balancing feature is not supported for MPLS traffic.
The src-dst-mixed-ip-port option specifies load distribution based on the hash value obtained from the
calculation of five parameters: source ip address, destination ip address, source port, destination port, and L4
protocol.
Additional References
The following sections provide references related to the Flow-Based per Port-Channel Load Balancing feature.
Related Documents
Standards
Standard Title
No new or modified standards are supported by this --
feature, and support for existing standards has not
been modified by this feature.
MIBs
RFCs
RFC Title
No new or modified RFCs are supported by this --
feature, and support for existing standards has not
been modified by this feature.
Technical Assistance
Description Link
The Cisco Support website provides extensive online http://www.cisco.com/cisco/web/support/index.html
resources, including documentation and tools for
troubleshooting and resolving technical issues with
Cisco products and technologies.
To receive security and technical information about
your products, you can subscribe to various services,
such as the Product Alert Tool (accessed from Field
Notices), the Cisco Technical Services Newsletter,
and Really Simple Syndication (RSS) Feeds.
Access to most tools on the Cisco Support website
requires a Cisco.com user ID and password.
IPv6 Loadbalancing on GEC Cisco IOS XE Release 3.4S The IPv6 Loadbalancing on GEC
feature provides load balancing for
IPv6 traffic on Gigabit
EtherChannel.
Five-Tuple Hash Support for GEC Cisco IOS XE Everest 16.4.1 The five-tuple hash support for
Flow-based Load Balancing gigabit etherchannel (GEC)
flow-based load balancing feature
decides which member link to use
for routing traffic based on the hash
value obtained from the calculation
of 5 parameters: source ip address,
destination ip address, source port,
destination port, and L4 protocol.