Test
Test
Ruckus ICX
Administrator
Lab Guide
Brocade University
Revision 0817
Corporate Headquarters - San Jose, CA USA
T: (408) 333-8000
[email protected]
ADX, Brocade, Brocade Assurance, the B-wing symbol, DCX, Fabric OS, HyperEdge, ICX, MLX,
MyBrocade, OpenScript, The Effortless Network, VCS, VDX, Vplane, and Vyatta are registered
trademarks, and Fabric Vision and vADX are trademarks of Brocade Communications Systems, Inc., in
the United States and/or in other countries. Other brands, products, or service names mentioned may be
trademarks of others.
Notice: This document is for informational purposes only and does not set forth any warranty, expressed
or implied, concerning any equipment, equipment feature, or service offered or to be offered by Brocade.
Brocade reserves the right to make changes to this document at any time, without notice, and assumes
no responsibility for its use. This informational document describes features that may not be currently
available. Contact a Brocade sales office for information on feature and product availability. Export of
technical data contained in this document may require an export license from the United States
government.
Revision 0817
Contents
Module 3 Lab: Basic Switch Administration and Stacking
Objectives . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1
Connecting to the RSL . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
CLI Basics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
Command Mode Hierarchy . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
Using the CLI Help (?) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3
Tab Completion . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
Abbreviating Commands . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6
Configuration File Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6
Local Account and SSH Enablement . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10
Preparation for Next Lab Section . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Enable Stacking . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Removing the Stacking Configuration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Close Open Sessions and Exit Remote Connection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
Objectives
In this laboratory exercise, you will perform tasks related to initial switch configuration and other basic
administration including:
• Establishing both serial console and Telnet management sessions to the switches
• Understanding CLI basics
• Managing system software
• Managing configuration files
• Controlling user access
CLI Basics
The following sections will introduce the multiple aspects of the CLI including the available commands
at each command mode level and how to retrieve command help.
1. RKUS-04>
2. User EXEC mode.
3. The “No password has been assigned yet...” message is displayed. The prompt now ends with a “#” sign.
4. RKUS-04(config)# The (config) has been added to indicate that you are now in Global Configuration mode.
6. On RKUS-04, move back to the interface configuration mode by entering the interface
ethernet 1/1/1 command.
7. On RKUS-04, return directly to the Privileged EXEC mode by pressing CTRL+Z at the same time.
This will change your prompt back to #. (optionally use the command end with the same results)
RKUS-04(config)# interface ethernet 1/1/1
RKUS-04(config-if-e1000-1/1/1)# ^Z
RKUS-04#
8. On RKUS-04, try to move directly to the Interface Configuration mode from the Privileged EXEC
mode by entering the configure terminal interface ethernet 1/1/1 command.
RKUS-04# configure terminal interface ethernet 1/1/1
5. RKUS-04(config-if-e1000-1/1/1)# The (conf-if-e1000-1/1/1) has been added to indicate that you are
now in Interface Configuration mode ready to edit STACKID 1, SLOT 1, PORT interface 1.
6. Invalid input -> int eth 1/1/1. You are only allowed to move down one level at a time.
Notice that terminal is the available operand to directly follow the configure command. Also
find that the prompt automatically returns with the configure command waiting for the next
operand.
11. On RKUS-04, complete the configure command by entering the terminal operand to enter
the switch configuration mode.
RKUS-04# configure terminal
RKUS-04(config)#
12. On RKUS-04, enter the exit command to return to the Privileged EXEC prompt.
13. On RKUS-04, use the ? command to show which commands are available with a certain prefix.
Enter the co? command (no space before the ?) to see a list of commands that start with ‘co’.
• What operands are available? ________________________________________7
RKUS-04# co?
configure Enter configuration mode
copy Copy between flash, tftp, config/code
14. On RKUS-04, when the prompt returns with ‘co’, press the [Enter] key without adding any
additional characters.
• What is the response?
____________________________________________________________________8
RKUS-04# co
Ambiguous input -> co
9. Tab completion finishes the configure command since con is unique to it.
10. Tab completion finishes the configure command by adding terminal since it is the only available operand
for configure.
Note
Remember from earlier the full command is actually configure terminal.
20. On RKUS-04, enter the exit command to return to the Privileged EXEC mode.
Note
The contents of the configuration is a list of CLI commands that reflect the current state of
each item.
NOTE
The full syntax is interface ethernet 1/1/9
RKUS-04(config-if-e1000-1/1/9)# enable
RKUS-04(config-if-e1000-1/1/9)# end
RKUS-04#
24. On RKUS-04, compare the two configurations. To display the contents of the configuration file
currently running on the system, enter the show running-config command.
• Do you have an entry for interface ethernet 1/1/9? (Yes / No)13
RKUS-04# show running-config
<Truncated Output>
25. On RKUS-04, display the contents of the configuration stored in flash using the show
configuration command.
• Do you have an entry for interface ethernet 1/1/9? (Yes / No)14
RKUS-04# show configuration
Startup configuration:
!
ver 08.0.30hT211
<Truncated Output>
<Truncated Output>
26. On RKUS-04, save the current running configuration to the startup configuration by entering the
write memory command.
27. On RKUS-04, display the contents of the configuration stored in flash using the show
configuration command.
• Do you have an entry for interface ethernet 1/1/9? (Yes / No)15
RKUS-04# show configuration
Startup configuration:
!
ver 08.0.30hT211
<Truncated Output>
14. Yes
15. No
<Truncated Output>
<Truncated Output>
<Truncated Output>
Note
The privilege level options are 0-Super User, 4-Port Configuration, 5-Read-only
36. On RKUS-04, configure AAA authentication to consult local user accounts for access by entering
the following command:
RKUS-04(config)# aaa authentication login default local
37. On RKUS-04, enable SSH by generating a crypto key that will be used for SSH connectivity.
RKUS-04(config)# crypto key generate
Creating DSA key pair, please wait...
DSA Key pair is successfully created
Note
It will take a few moments before you received the confirmation that the key pair was suc-
cessfully generated.
38. On RKUS-04, verify your configuration by issuing the show ip ssh config command. (For
this command the config is not abbreviated and is the full command syntax.)
RKUS-04(config)# show ip ssh config
SSH server : Enabled
SSH port : tcp\22
Host Key : DSA 1024, RSA 2048
Encryption : aes256-cbc, aes192-cbc, aes128-cbc, aes256-ctr,
aes192-ctr, aes128-ctr, 3des-cbc
Permit empty password : No
Authentication methods : Password, Public-key, Interactive
Authentication retries : 3
Login timeout (seconds) : 120
Idle timeout (minutes) : 0
SCP : Enabled
<Output Truncated>
40. On the PC1 PuTTY session window, you should be prompted to login. Log in using the credentials
username: admin1 password: icx200 as seen below.
login as: admin1
Using keyboard-interactive authentication.
Password: icx200
41. On the PC1 PuTTY session window, enter into privileged exec mode by issuing the command
enable.
a. Were you prompted for a password?____________16
42. On the PC1 PuTTY session window, configure AAA authentication for enable mode by entering the
following command:
SSH@RKUS-04# config t
SSH@RKUS-04(config)# aaa authentication enable default local
43. On the PC1 PuTTY session window, return to User EXEC mode by issuing the quit command.
Once at the > prompt issue to enable command once again.
a. Were you prompted for credentials? ____________17
b. Enter the credentials above again to gain Privilege EXEC access.
16. No
17. yes
Enable Stacking
This portion of the lab you will enable the stacking ports and form a switch stack using the secure
setup feature.
• Enable stacking ports
• Enable stacking on a switch (planned active switch)
• Configure stack using the secure stack feature
Utilizing the following CLI commands:
47. On RKUS-03, RKUS-04 and RKUS-05, connect to the console, define and enable the stacking
ports for the switches and reload.
RKUS-04> enable
RKUS-04# conf t
RKUS-04(config)# stack unit 1
RKUS-04(config-unit-1)# default-ports 1/2/1 1/2/3
Reload required. Please write memory and then reload or power cycle.
RKUS-04(config-unit-1)# stack-trunk 1/2/1 to 1/2/2
RKUS-04(config-unit-1)# stack-trunk 1/2/3 to 1/2/4
RKUS-04(config-unit-1)# exit
RKUS-04(config)# interface eth 1/2/1 to 1/2/4
RKUS-04(config-mif-1/2/1-1/2/4)# enable
RKUS-04(config-mif-1/2/1-1/2/4)# end
RKUS-04# write memory
Flash Memory Write (1048576 bytes per dot) .
Write startup-config done.
Copy Done.
RKUS-04# reload
Are you sure? (enter 'y' or 'n'): y
49. On RKUS-05, document the MAC associated with the switch, by executing the show interface
brief ethernet 1/1/1 command.
____________________________________________________________________
RKUS-05> en
RKUS-05# sh int br e 1/1/1
Port Link State Dupl Speed Trunk Tag Pvid Pri MAC Name
1/1/1 Disable None None None None No 1 0 0024.38b7.4bc0
50. On RKUS-03, document the MAC associated with the switch, by executing the show interface
brief ethernet 1/1/1 command.
____________________________________________________________________
RKUS-03> en
RKUS-03# sh int br e 1/1/1
Port Link State Dupl Speed Trunk Tag Pvid Pri MAC Name
1/1/1 Disable None None None None No 1 0 0024.38b7.6840
51. On RKUS-03 enable stacking and initiate the stacking setup by supplying the answer to the
prompts below:
RKUS-03# config t
RKUS-03(config)# stack enable
Enable stacking. This unit actively participates in stacking
stacking is enable. optical monitoring for stacking ports 1/2/1, 1/2/
3 is not available.
RKUS-03(config)# exit
RKUS-03# stack secure-setup (also answer “2” and “y” as shown below)
RKUS-03#Discovering the stack topology...
Available UPSTREAM units
Hop(s) Id Type Mac Address
1 new ICX7450-24 0024.38b7.7040
2 new ICX7450-24 0024.38b7.4bc0
Selected Topology:
Active Id Type Mac Address
1 ICX7450-24 0024.38b7.6840
Config changed due to add/del units. Do write mem if you want to keep it
T=2m59.0: reset unit 2: u2 bo-id=1
T=2m59.0: reset unit 3: u3 bo-id=1
T=2m59.4: Unit 1 loses all neighbors.
T=3m7.9: Active U1 deletes U2 and its config because it is learned.
T=3m12.1: Active U1 deletes U3 and its config because it is learned.
T=4m45.4: Election, was active, no change, ID=1, pri=128, 3U(1-3), A=u1,
nbr#=2 0, reason: u2: port-up, ,
The period is 25
Detect stack unit 2 has different startup config flash, will synchronize it
T=4m47.0: Synchronize webauth files to u2
Detect stack unit 3 has different startup config flash, will synchronize it
T=4m47.0: Synchronize webauth files to u3
Detect stack member 2 POE capable
Detect stack member 3 POE capable
T=4m47.5: Election, was active, no change, ID=1, pri=128, 3U(1-3), A=u1,
nbr#=2 0, reason: u1: stk-po-chg, ,
T:4m48.5: Done hot swap: active controller u1 sets u2 to Ready.
T:4m48.5: Done hot swap: active controller u1 sets u3 to Ready.
T=4m49.0: Synchronize startup config to u2
Flash Memory Write (8192 bytes per dot) .
Write startup-config done.
T=4m50.0: Synchronize startup config to u3
Flash Memory Write (8192 bytes per dot) .
Write startup-config done.
Stack unit 3 Power supply 1 is down
PoE: Stack unit 3 Power supply 2 with 748000 mwatts capacity is up
Config changed due to add/del units. Do write mem if you want to keep it
Stack unit 2 Power supply 1 is down
Important
Watch the console messages and note the tasks being performed. The message “Running con-
fig sync to standby is complete” will be displayed when the stacking configuration is
complete.
standby active
+---+ +---+ +---+
| 3 |2/3==2/1| 2 |2/3==2/1| 1 |2/3
+---+ +---+ +---+
Standby u2 - protocols ready, can failover
Current stack management MAC is 0024.38b7.6840
a. Using the output, which switch is the active controller (based on MAC addresses recorded
earlier)? ___________18
b. How many downstream units are there? _______________________19
53. Document the unit IDs assigned. RKUS-03 should be assigned unit 1, RKUS-04 should be
assigned unit 2, and RKUS-05 should be assigned unit 3.
18. RKUS-03
19. Two
U# Stack-port1 Stack-port2
1 up (1/2/1-1/2/2) dn (1/2/3-1/2/4)
up ports: 1/2/1, 1/2/2
2 up (2/2/1-2/2/2) up (2/2/3-2/2/4)
up ports: 2/2/1, 2/2/2
up ports: 2/2/3, 2/2/4
3 none up (3/2/3-3/2/4)
up ports: 2/2/1, 2/2/2
up ports: 3/2/3, 3/2/4
20. Two. It is connected to unit 1 through port 2/2/1-2/2/2 and unit 3 through port 2/2/3-2/2/4.
21. Linear
Port Link State Dupl Speed Trunk Tag Pvid Pri MAC Name
1/2/1 Up Forward Full 10G None No N/A 0 0024.38b7.6859
1/2/2 Up Forward Full 10G None No N/A 0 0024.38b7.685a
1/2/3 Down None None None None No N/A 0 0024.38b7.685b
1/2/4 Down None None None None No N/A 0 0024.38b7.685c
2/2/1 Up Forward Full 10G None No N/A 0 0024.38b7.7059
2/2/2 Up Forward Full 10G None No N/A 0 0024.38b7.705a
2/2/3 Up Forward Full 10G None No N/A 0 0024.38b7.705b
2/2/4 Up Forward Full 10G None No N/A 0 0024.38b7.705c
3/2/3 Up Forward Full 10G None No N/A 0 0024.38b7.4bdb
3/2/4 Up Forward Full 10G None No N/A 0 0024.38b7.4bdc
a. What speed are the stacking interfaces configured for? ___________22
b. What duplex is used? __________23
22. 10 Gbps.
23. Full duplex.
This ends Module 3 Lab: Basic Switch Administration and Stacking lab exercise.
Objectives
In this laboratory exercise, you perform tasks related to configuring LAGs:
• Configure a two port static trunk group and deploy it
• Observe failover from one trunk member to another
• Enable dynamic link aggregation on ports between a pair of switches
• Observe failover from one trunk member to another
• Disable ports within a LAG while LAG is deployed
You will also perform tasks related to configuring VLANs and tagging:
• Configure 802.1Q tagged ports and untagged ports in the same network
• Verify that traffic from multiple VLANs can use one physical link, and still be distinguishable as
separate VLAN traffic
• Change a PC’s VLAN membership without changing its physical port position
Dynamic LAG
You configure a dynamic LAG using LACP between the RKUS-03 and RKUS-04 using ports 21 and 22
on each switch.
1. On RKUS-03, create a dynamic LAG and configure LACP to use a LAG Key ID you assign. (LAG ID is
optional and will be automatically assigned if not configured)
RKUS-03(config)# lag Blue dynamic id 123
2. On RKUS-03, associate ports 21 and 22 to the LAG group and identify the primary port.
RKUS-03(config-lag-Blue)# ports e 1/1/21 to 1/1/22
RKUS-03(config-lag-Blue)# primary-port 1/1/21
3. On RKUS-03, deploy the LAG on the switch.
RKUS-03(config-lag-Blue)# deploy
LAG Blue deployed successfully!
4. On RKUS-04, repeat the steps above to configure the LAG, associate eth 21 and eth 22 interfaces
and identify the primary port. Configure LACP to use a LAG Key ID of 321.
RKUS-04(config)# lag Blue dynamic id 321
RKUS-04(config-lag-Blue)# ports e 1/1/21 to 1/1/22
RKUS-04(config-lag-Blue)# primary-port 1/1/21
RKUS-04(config-lag-Blue)# deploy
LAG Blue deployed successfully!
RKUS-04(config-lag-Blue)# exit
5. On RKUS-04, execute the show lag command.
RKUS-04# show lag
Total number of LAGs: 1
Total number of deployed LAGs: 1
Total number of trunks created:1 (255 available)
LACP System Priority / ID: 1 / 0024.38b7.7040
LACP Long timeout: 90, default: 90
LACP Short timeout: 3, default: 3
NOTE
Because you enabled the primary port all ports that are members of the LAG are enabled. Any
configuration performed under the primary ports stanza will be reflected on all member ports.
7. On RKUS-04, reissue the show lag command and verify both ports are in operational [ope]
state.
Important
If they are not operational troubleshoot the LAG.
Do not proceed until both LAG ports are in an operational state.
11. On RKUS-03, execute show statistics a couple of times to identify which link is carrying the
traffic.
RKUS-03(config-if-e1000-1/1/11)# show statistics
13. On RKUS-04, verify that the disabled port is not operational in the lag by issuing the show lag
command.
RKUS-04(config-lag-Blue)# show lag
Total number of LAGs: 1
Total number of deployed LAGs: 1
Total number of trunks created:1 (255 available)
LACP System Priority / ID: 1 / 0024.38b7.7040
LACP Long timeout: 90, default: 90
LACP Short timeout: 3, default: 3
• Why was it important to disable the port within the LAG stanza and not under the physical
port?________________5
14. On RKUS-03 and RKUS-04, remove the lag configuration and disable the ports to prepare for the
next section.
Example:
RKUS-03(config-if-e1000-1/1/11)# no lag Blue
Secondary port 1/1/22 disabled automatically upon LAG un-deploy to
avoid potential loop
LAG Blue un-deployed successfully!
RKUS-03(config)# int e 1/1/21
RKUS-03(config-if-e1000-1/1/21)# disable
RKUS-03(config-if-e1000-1/1/21)# exit
RKUS-03(config)#
5. Because if the port being disabled is the primary port then all ports would reflect the same configuration causing the
LAG to be disabled.
Note
The port’s State changes during its initialization due to the Spanning Tree Protocol. Rerun
the show lag command several times to see the state changes. This process takes approx-
imately 30 seconds to complete.
18. On RKUS-03, attempt to configure both ports of the trunk or the secondary port by entering the
int eth 1/1/1 to 1/1/2 command.
RKUS-03(config-lag-Green)# int eth 1/1/1 to 1/1/2
RKUS-03(config-lag-Green)# int e 1/1/2
VLAN 222 and VLAN 333 will be created on each of the three switches in your environment. The PCs
are dual attached to RKUS-04 and RKUS-05 on ports 9 and 10 on each switch. Port 9 of the PC
attachments will be added to VLAN 222 while port 10 will be added to VLAN 333. The links between
switches will be tagged to allow traffic from both VLANs to traverse.
Your environment begins with a static LAG between RKUS-04 and RKUS-03 with all ports on all
devices in the default VLAN 1. You are configuring the ports listed in the diagram to be members of
VLAN 222 and VLAN 333.
6. Up, Up
7. Listen, then Learn, then Forward. Final state: Forward
8. Error - cannot use the interface group to configure trunk port, 1/1/1.
and
Error - cannot configure secondary ports of a trunk
Note
Because port e 1/1/1 was the primary port of the static lag, the tagging of the port to the
VLAN causes both ports of the LAG to be added to the VLAN.
22. On RKUS-04, execute the show interface brief command and look at the Tag column:
RKUS-04(config-vlan-333)# show interface brief
11. 9
12. 1 and 2
13. 10
14. 1 and 2
15. Since ports 1 and 2 are trunked, any
configuration that you make to the primary port (in this case
port 1) will be reflected on all members of that trunk group.
16. 2
Note
Leave the continuous ping running. You will be referring to it again later in the lab.
Important
Do not continue until you are able to ping successfully between the two PCs.
27. On the RKUS-05, disable the port that PC2 is currently using to access the network (port 9), then
enable port 10.
Note
This effectively is moving PC2 from VLAN 222 to VLAN 333.
17. Yes
18. No
19. PC1 Pings are now kept within VLAN 222, while PC2 is now in VLAN 333.
20. error - port ethe 1/1/10 are not member of default VLAN
Note
It will take approximately 30 seconds for the pings to be successful.
Important
Do not continue until ping replies are successful.
32. On RKUS-05, return 10 to VLAN 333 in preparation for the next lab.
RKUS-05(config-vlan-222)# no untagged e 1/1/10
RKUS-05(config-vlan-222)# vlan 333
RKUS-05(config-vlan-333)# untagged e 1/1/10
Added untagged port(s) ethe 1/1/10 to port-vlan 333.
21. Yes
This ends Module 4 Lab: Link Aggregation Groups and VLANs lab exercise.
Objectives
In this laboratory exercise, you perform tasks related to Spanning Tree and RSTP:
• Create a second static LAG between RKUS-03 and RKUS-04
• Observe the network impact when transitioning from 802.1d (STP) to 802.1w (RSTP)
• Record the 802.1w states
• Load balance traffic across two uplinks using 802.1 w port priorities
• Observe 802.1w failover time
• Configure 802.1w Edge Ports
• Observe Edge Port recovery time
Utilizing the following CLI commands:
5. On the PC1 desktop, establish a continuous ping to PC2 (10.10.200.200). If pings timeout,
troubleshoot until it succeeds. Keep this session open during the completion of the next steps.
Note
By default, STP is enabled on devices running switching code.
6. On RKUS-03, enter the clear stat command to reset all traffic counters to zero.
Note
Look for ports that have incrementing counters for send and receive packets.
8. On RKUS-03, simulate failing the trunk on ports 1 and 2 by disabling port 1/1/1. Observe the fail-
over time by counting the number of lost pings:
RKUS-03(config-vlan-333)# int eth 1/1/1
RKUS-03(config-if-e1000-1/1/1)# disable
1. 1 or 2 (trunk group 1)
2. Approximately 6 pings, or 30 seconds.
Note
Traffic interruptions are not only caused by failures in links, but also additions to available
paths in the network.
Note
Note
In 802.1w DISCARDING state is the equivalent of the 802.1D BLOCKING state
13. On RKUS-03, change the RSTP port priority for port 21 in VLAN 222 so that on RKUS-04 port
21 transitions to the FORWARDING state for VLAN 222 and port 1 transitions to DISCARDING
state:
RKUS-03(config-vlan-333)# vlan 222
RKUS-03(config-vlan-222)# span 8 eth 1/1/21 pri 16
Note
On ICX switches, port priority can range between 0 and 240 in increments of 16, with a
default of 128. A lower number of 16 received in the BPDU at RKUS-04 port eth 1/1/21
takes priority over the default of 128 received at RKUS-04 port eth 1/1/1.
4. ALTERNATE/DISCARDING
5. 128 (the default priority)
• How has the output changed for port e 1/1/21 from Step 12?
_______________________________________________________6
15. On RKUS-03, enter the clear stat command to reset all traffic counters to zero.
16. On RKUS-03, enter the show stat command a few times to identify the ports used by the ping
traffic.
RKUS-03(config-vlan-222)# show stat
• What ports are carrying the ping traffic between RKUS-03 and RKUS-04?
___________________7
8. Approximately 1 ping.
9. Approximately 5-6 pings, or 30 seconds.
RKUS-04(config-vlan-333)# show 8
22. On RKUS-04, invoke the sh 8 detail command and familiarize yourself with the spanning tree
details for ports in VLAN 222.
RKUS-04(config-vlan-333)# sh 8 detail
======================================================================
VLAN 222 - SPANNING TREE (IEEE 802.1W) ACTIVE
======================================================================
BridgeId 8000002438143140, forceVersion 2, txHoldCount 3
======================================================================
VLAN 333 - SPANNING TREE (IEEE 802.1W) ACTIVE
======================================================================
BridgeId 8000002438143140, forceVersion 2, txHoldCount 3
RKUS-04(config-vlan-333)# sh 8
Objectives
In this lab exercise, you will perform tasks related to layer 3 redundancy and the configuration of
VRRP-Extended protocol. Upon completion you should be able to:
• Demonstrate ability to configure VRRP-E on Layer 3 ICX switches
• Distinguish the different states of VRRP-E routers using the ICX CLI
• Solve problems related to VRRP-E configuration errors
Utilizing the following CLI commands:
1. On RKUS-03, RKUS-04 and RKUS-07, execute the commands to erase the startup-config file and
reload the switch to router code located on the secondary flash.
RKUS-03# erase start
RKUS-03# boot sys flash secondary
- Answer “y” to any prompts
2. On RKUS-03, RKUS-04 and RKUS-07, configure the hostnames as described in Table 1 above.
ICX7450-24 Router> enable
ICX7450-24 Router# conf t
ICX7450-24 Router(config)# hostname R3-RouterA
R3-RouterA(config)#
3. On R3-RouterA, R4-RouterB and R7-Internet, execute the Global Configuration command to
ensure the device boots from the secondary flash on all reloads.
R3-RouterA(config)# boot sys flash sec
4. On R3-RouterA, R4-RouterB and R7-Internet, enable route-only globally.
R3-RouterA(config)# route-only
5. On R3-RouterA and R4-RouterB, disable all interfaces to avoid loops in lab environment.
(config)# int eth 1/1/1 to 1/1/24
(config-mif-1/1/1-1/1/24)# disable
(config-mif-1/1/1-1/1/24)# interface eth 1/2/1 to 1/2/4
(config-mif-1/2/1-1/2/4)# disable
(config-mif-1/2/1-1/2/4)# interface m1
(config-if-mgmt-1)# disable
Configure Routers
10. On R3-RouterA, configure an IP address and enable interfaces e 1/1/5 and e 1/1/23 and create
a static route to the 144.49.10.0/24 WAN network.
R3-RouterA(config-if-mgmt-1)# int eth 1/1/5
R3-RouterA(config-if-e1000-1/1/5)# ip address 10.10.200.11/24
R3-RouterA(config-if-e1000-1/1/5)# enable
R3-RouterA(config-if-e1000-1/1/5)# int eth 1/1/23
R3-RouterA(config-if-e1000-1/1/23)# ip address 172.16.10.1/30
R3-RouterA(config-if-e1000-1/1/23)# enable
R3-RouterA(config-if-e1000-1/1/23)# exit
R3-RouterA(config)# ip route 144.49.10.0/24 172.16.10.2
11. On R4-RouterB, configure an IP address and enable interfaces e 1/1/3 and e 1/1/23 and create
a static route to the 144.49.10.0/24 WAN network.
R4-RouterB(config-if-mgmt-1)# int eth 1/1/3
R4-RouterB(config-if-e1000-1/1/3)# ip address 10.10.200.12/24
R4-RouterB(config-if-e1000-1/1/3)# enable
R4-RouterB(config-if-e1000-1/1/3)# int eth 1/1/23
R4-RouterB(config-if-e1000-1/1/23)# ip address 172.16.10.5/30
R4-RouterB(config-if-e1000-1/1/23)# enable
R3-RouterB(config-if-e1000-1/1/23)# exit
R3-RouterB(config)# ip route 144.49.10.0/24 172.16.10.6
Configure VRRP-E
In the following steps you will enable and configure VRRP-E on R3-RouterA and R4-RouterB.
14. On R4-RouterB, invoke the command that globally enables the VRRP-Extended protocol
R4-RouterB(config)# router vrrp-extended
15. On R4-RouterB, configure VRRP-E parameters on int eth 1/1/3
R4-RouterB(config-vrrpe-router)# int eth 1/1/3
R4-RouterB(config-if-e1000-1/1/3)# ip vrrp-extended vrid 1
R4-RouterB(config-if-e1000-1/1/3-vrid-1)# backup pri 100 track-priority 9
R4-RouterB(config-if-e1000-1/1/3-vrid-1)# ip-address 10.10.200.1
R4-RouterB(config-if-e1000-1/1/3-vrid-1)# track-port e 1/1/23
R4-RouterB(config-if-e1000-1/1/3-vrid-1)# activate
VRRPE router 1 for this interface is activating
16. On R4-RouterB, execute the show ip vrrp-extended command.
R4-RouterB(config-if-e1000-1/1/3)# show ip vrrp-extended
Total number of VRRP-Extended routers defined: 1
Interface ethernet 1/1/3
auth-type no authentication
VRID 1
state master
administrative-status enabled
priority 100
current priority 100
1. Master
2. Master
Important
Do not proceed unless the ping is successful
3. Backup
4. R3-RouterA has a higher priority (110 vs. 100)
5. Yes
6. 1/1/5
7. Yes
8. No
9. Master
10. Backup
11. R3-RouterA still has a higher priority (101 vs. 100)
12. track-priority
13. Any value greater than 10
14. Backup
15. Master
Important
Do not proceed unless the ping is successful
29. On R1-AccessSW, view the switch MAC address table by executing the show mac-address
command
R1-AccessSw(config)# sh mac-add
Total active entries from all ports = 6
Type D:Dynamic S:Static L:Lock Address M:Secure Mac
MAC Address Port Age Type DMA Valid Flags VLAN DMA:CAM Index ...
0024.38b6.f9c2 3 25 D 00000000-00000001 1
0024.38b6.f9c0 3 5 D 00000000-00000001 1
0024.38b6.f100 5 95 D 00000000-00000001 1
001b.edec.a254 9 10 D 00000000-00000001 1
0050.5697.009d 9 25 D 00000000-00000001 1
02e0.52f2.2f01 3 5 D 00000000-00000001 1
16. Yes
17. 1/1/3
18. Yes
Objectives
In this laboratory exercise, you will perform tasks related to the OPSF neighbor adjacency process,
including:
• Recording OSPF packet contents from the neighboring process
• Changing the reference bandwidth to influence path selection based on interface link speed
• Configuring OSPF interfaces for MD5 Authentication
• Troubleshooting the common OSPF problems as they are encountered, if required
Utilizing the following CLI commands:
Commands Context Comment
ip show-subnet-length Global Configuration Change subnet mask display to prefix
format
router ospf Global Configuration Enables the OSPF routing protocol globally
on the switch
area <area-id> OSPF Configuration Defines the OSPF area(s) this switch can
participate in
auto-cost reference-bandwidth OSPF Configuration Adjusts the reference value to automatically
<ref-value> determining link cost based on link speed.
Default is 100.
ip ospf area <area-id> Interface Configuration Defines the area the interface belongs in
ip ospf md5-authentication Interface Configuration Defines the MD5 authentication key ID and
key-id <key-id> key <key- key value to be exchanged with OSPF
value> neighbors
ip ospf auth-change-wait-time Interface Configuration Defines the delay before enforcing OSPF
<time> MD5 policies
show ip ospf neighbor Any Displays information about OSPF neighbors
debug ip ospf packet Privileged EXEC Displays debug level information about
OSPF packets exchanged between OSPF
neighbors
no debug all Privileged EXEC Disables all debugging
RKUS-01 R1-SaltLake
RKUS-03 R3-SanJose
RKUS-04 R4-SanDiego
RKUS-05 R5-Seattle
RKUS-06 R6-BackboneSW
RKUS-07 R7-Portland
RKUS-08 R8-Vancouver
8. On RKUS-01, RKUS-03, RKUS-04, RKUS-05, RKUS-06, RKUS-07 and RKUS-08, enable LLDP.
R4-SanDiego(config)# lldp run
OSPF Adjacency
Configure R6-Backbone
9. On R6-BackboneSW, configure ports 1/1/1, 4 and 11 to operate at 100Mb.
R6-BackboneSW(config)# interface e1/1/1 e1/1/4 e1/1/11
R6-BackboneSW(config-mif-1/1/1,1/1/4,1/1/11)# speed-duplex 100-full
R6-BackboneSW(config-mif-1/1/1,1/1/4,1/1/11)# enable
Note
The configuration of port speed to 100Mb will be used to demonstrate route selection based
on link costs.
10. On R6-BackboneSW, execute the write mem command to save the running configuration to
flash.
Configure R4-SanDiego
11. On R4-SanDiego, enable OSPF globally and create area 0.
R4-SanDiego(config)# router ospf
R4-SanDiego(config-ospf-router)# area 0
12. On R4-SanDiego, configure port 1/1/11 to operate at 100Mb.
R4-SanDiego(config)# interface e1/1/11
R4-SanDiego(config-if-e1000-1/1/11)# speed-duplex 100-full
13. On R4-SanDiego, configure IP addresses, assign an OSPF area and enable interfaces as
described in Table 4 below.
TABLE 4 R4-SanDiego IP/OSPF Interfaces
Interface IP Address OSPF Enabled?
Area
loopback1 10.2.0.1/32 0
e1/1/3 192.168.10.1/30 0
e1/1/11 192.168.20.1/29 0
Important
Make sure to configure interface Loopback 1 before configuring any physical interfaces. This will
ensure the correct RouterID is used.
Example
R4-SanDiego(config)# interface e1/1/3
R4-SanDiego(config-if-e1000-1/1/3)# ip address 192.168.10.1/30
R4-SanDiego(config-if-e1000-1/1/3)# ip ospf area 0
R4-SanDiego(config-if-e1000-1/1/3)# enable
loopback1 10.0.3.1/32 0
e1/1/1 192.168.20.2/29 0
e1/1/5 192.168.50.2/24 0 Do not enable
at this time
Important
Make sure to configure interface Loopback 1 before configuring any physical interfaces. This will
ensure the correct RouterID is used.
Configure R3-SanJose
17. On R3-SanJose, enable OSPF globally and create area 0.
18. On R3-SanJose, configure port 1/1/4 to operate at 100Mb.
R3-SanJose(config)# interface e1/1/4
R3-SanJose(config-if-e1000-1/1/4)# speed-duplex 100-full
19. On R3-SanJose, configure IP addresses, assign an OSPF area and enable interfaces as described
in Table 6 below.
TABLE 6 R3-SanJose IP/OSPF Interfaces
Interface IP Address OSPF Enabled?
Area
loopback1 10.0.0.1/32 0
e1/1/4 192.168.20.3/29 0
Important
Make sure to configure interface Loopback 1 before configuring any physical interfaces. This will
ensure the correct RouterID is used.
loopback1 10.3.3.1/32 0
e1/1/5 192.168.50.1/24 0
Important
Make sure to configure interface Loopback 1 before configuring any physical interfaces. This will
ensure the correct RouterID is used.
Configure R1-SaltLake
22. On R1-SaltLake, enable OSPF globally and create area 0.
23. On R1-SaltLake, configure IP addresses, assign an OSPF area and enable interfaces as described
in Table 8 below.
TABLE 8 R1-SaltLake IP/OSPF Interfaces
Interface IP Address OSPF Enabled?
Area
loopback1 10.2.2.1/32 0
e1/1/3 192.168.10.2/30 0
Important
Make sure to configure interface Loopback 1 before configuring any physical interfaces. This will
ensure the correct RouterID is used.
Note
The interfaces connecting R7-Portland and R5-Seattle are not enabled yet. R7-Portland,
which is not connected to any neighbors, shows the following output:
No ospf neighbor entries available.
25. On R4-SanDiego, verify LLDP neighbor advertisements and identify what neighbors are directly
connected.
R4-SanDiego(config-if-e1000-1/1/3)# show lldp neighbor
Lcl Port Chassis ID Port ID Port Description System Name
1/1/3 748e.f87b.fe40 748e.f87b.fe42 GigabitEthernet1/1/3 R1-SaltLake
1/1/11 0024.382e.6c00 0024.382e.6c0a GigabitEthernet1/11 R6-Backbone
27. On R7-Portland, invoke the debug ip ospf packet command in Privilege EXEC mode.
R7-Portland# debug ip ospf packet
28. On R5-Seattle, enable port 1/1/5.
29. On R7-Portland, observe the debug ip ospf packet output. (Many lines of output will scroll
onto your screen)
30. On R7-Portland, when the debug output stops scrolling and only hello packets are seen
(approximately 30 seconds), execute the undebug all command.
1. LLDP is a protocol that detects directly connected devices. Although there might be other deives within the same
broadcast domain only directly connected devices will be discovered.
2. bridge, router
3. bridge
____________________________________________________________________4
b. Locate the Link State Request (LS-Req) sent by B7-Portland.
Are the Type 2 LSAs seen in the above Database Description packet present? _______5
c. Locate the LS-Update (LS-Upd) that fulfills the R7-Portland request.
Are these same Type 2 LSAs being supplied? ________6
Note
The traceroute command can only be executed from Privileged EXEC mode.
8. R5-Seattle
9. Higher Router ID (10.0.3.1 vs. 10.0.0.1)
10. 2
11. 192.168.20.2 (R5-Seattle, via port e4) and 192.168.30.2 (R5-Seattle, via port 1/1/11)
12. 2
13. 100M
14. 1G
15. The OSPF auto-cost reference-bandwidth is at the default value of 100
16. 192.168.20.2 (R5-Seattle, via port 1/1/4)
17. 1000
18. Yes
19. 192.168.30.2 (R5-Seattle, via port e11)
20. 2
21. The auto-cost reference-bandwidth command has given the 1Gbps interface a lower cost than the 100M
interface
22. 1
23. No
24. 3
25. Yes
This ends Module 9 Lab A: OSPF Neighbor Adjacency and Link Cost exercise.
Objectives
In this laboratory exercise, you will perform tasks related to:
• Partitioning a single area in multiple areas.
• Recording the effect on the Link State Databases when one area is broken up into 3 areas.
• Troubleshooting the common OSPF problems encountered, if required.
Utilizing the following CLI commands:
Command Context Comment
show ip ospf database link-state Any Displays the contents of the OSPF Link State
database. It does not include external routes
show ip ospf database external-link- Any Displays the contents of the OSPF External
state Link State database
Note
Type 5 External LSAs are listed with show ip ospf database external-link-
state command.
2. Record the number of each of these LSA Types in the Table 10 below.
TABLE 10 LSA Types for OSPF Area 0
OSPF Area ID Router LSA Network LSA Summary LSA ASBR LSA External LSA NSSA LSA
Type 1 Type 2 Type 3 Type 4 Type 5 Type 7
Note
All interfaces of R7-Portland now belong to OSPF area 3. You can verify port area member-
ship as well as port OSPF configuration by using the show ip ospf interface com-
mand.
Note
Port 1/1/5 of R5-Seattle now belongs to area 3. All other interfaces, including the loopback,
still belong to area 0.
Note
All interface of R1-SaltLake now belong to area 2.
Note
Port 1/1/3 of R4-SanDiego now belongs to area 2. All other interfaces, including the loop-
back, still belong to area 0.
• Now that R5-Seattle and R4-SanDiego have interfaces in different areas, what type of
OSPF router are they? _________________________1
Note
Because all routers in Area 0 have identical LSDBs, there may be four LSDB entries that can-
not be flushed. They will only be flushed when the entry ages out (60 minutes max). There-
fore, Area 0 LSAs will vary from a total of 13 down to 9 after all old LSAs have aged out.
If time permits, you may choose to reload all area 0 routers (R3-SanJose, R4-SanDiego and
R5-Seattle) in order to remove these aging entries. Make sure to save the running configura-
tion on each router before executing the reload command
Example
R3-SanJose# wr mem
R3-SanJose# reload
- Answer “y” to any prompts
• What additional LSA types are present in Table 11 that were not present in Table 10
above?
____________________________________________________________________2
8. On all routers, invoke the write memory command to save the current configuration.
13. On R7-Portland, configure the redistribution of OSPF and connected routes into RIP.
R7-Portland(config-ospf-router)# router rip
R7-Portland(config-rip-router)# redistribute ospf
R7-Portland(config-rip-router)# redistribute connected
Important
Do not continue unless the above answers are YES and all routers have 18 routes
3. Yes
4. Yes
5. 18
15. On R1-SaltLake, configure interface loopback 7 as a multi-netted interface with the following
addresses:
192.168.40.129/28
192.168.40.145/28
192.168.40.161/28
192.168.40.177/28
16. On R1-SaltLake, add interface loopback7 to Area 2 by invoking the ip ospf area 2 command.
17. On R8-Vancouver, view the IP routing table.
• Are the newly added 192.168.40.0 subnets present? ______6
18. On all remaining routers, view the IP routing table.
• How many routes are present in the IP routing table? ______7
Important
Do not continue unless the answer to Step 17 is “yes” and Step 18 is “22”.
6. Yes
7. 22
01 N/A
22 N/A
33 N/A N/A
8. Type 4 ASBR Summary LSAs are generated by the ABR into adjacent areas
9. 8
10. Type 5 - AS External LSAs
11. 4
12. Type 3 - Summary LSAs
13. 4
14. Type 3 - Summary LSAs
15. 22 routes
This ends Module 9 Lab B: Partitioning OSPF Areas and Redistribution between RIP exercise.
Objectives
In this laboratory exercise, you will perform tasks related to:
1. 9
2. 8
2nd 3 4
5 6
7th
7 8
8th
1. 192.168.60.65
2. 01000001
3. 192.168.60.73
4. 01001001
5. 192.168.60.113
6. 01110001
7. 192.168.60.121
8. 01111001
3. 26
4. 192.168.60.64
5. 255.255.255.192 (/26)
6. R7-Portland (ASBR)
7. 2
8. 1
5 6
3rd
7 8
4th
1. 192.168.40.129
2. 10000001
3. 192.168.40.145
4. 10010001
5. 192.168.40.161
6. 10100001
7. 192.168.40.177
8. 10110001
9. 4
10. No
11. Type 3 - Summary LSAs
12. 26
13. 192.168.40.128
14. 255.255.255.192 (/26)
15. R4-SanDiego (ABR)
16. 1
Note
Its important to know that anytime you configure a device to redistribute into OSPF it
becomes an ASBR regardless of its location in the network. You can verify this by issuing the
show ip ospf database link-state and you can now see a type 4 LSA (ASBR)
being advertised for R3-SanJose (Router ID 10.0.0.1)
17. 1
18. Was 4, now 1
19. Was 22, now 12
20. 2
21. 6
18. On R4-SanDiego, perform the following steps to reconfigure area 2 as a stub area.
a. Remove port 1/1/3 from OSPF area 2.
b. Under router ospf, remove the area 2 range 192.168.40.128/26 configuration.
c. Under router ospf, remove area 2
d. Under router ospf, create area 2 as a stub area with an external metric of 100.
R4-SanDiego(config-ospf-router)# area 2 stub 100
Note
The area 2 stub 100 command creates a new OSPF area, which is a stub area with an
advertised external route metric of 100, in this case.
Note
In stub areas, the ABR generates a default route into the stub area with cost value defined in
the area 2 stub 100 command. This value plus the cost of the 1Gbps interface between
R1-SaltLake and R4-SanDiego equals 101.
Note
With the no-summary argument, the ABR will no longer forward Type 3 summary LSAs into
the stub area. This argument only needs to be applied at the ABR, not all routers in the stub
area.
22. Because OSPF adjacency requires not only the area # but also the area type to match. R4-SanDiego is now
advertising area 2 as a stub area.
23. From the ABR (R4-SanDiego)
24. There are now no external LSDB entries
25. Yes
26. 1
27. The ABR will still generate the default route in a Type 3 summary LSA when no-summary is configured.
28. Totally Stubby Area
29. 0.0.0.0/0 (default route) because the 192.168.50.1 is not listed in the routing table.
30. The summary LSA generated by the ABR
c. Verify neighbor adjacency on interface e 1/1/3 by issuing show ipv6 ospf neighbor
command.
Note
Do not move forward if there is not an OSPFv3 neighbor adjacency on interface 1/1/3 and
troubleshoot.
d. On R4-SanDiego, verify IPv6 addresses assigned to SaltLakes loopback addresses are in the
IPv6 routing table.
R4-SanDiego(config-if-e1000-1/1/11)# show ipv6 route
IPv6 Routing Table - 2 entries:
Type Codes - B:BGP C:Connected I:ISIS L:Local O:OSPF R:RIP S:Static
BGP Codes - i:iBGP e:eBGP
OSPF Codes - i:Inter Area 1:External Type 1 2:External Type 2
STATIC Codes - d:DHCPv6
• Why do you not see the link-local addresses populating the routing table?
_________________31
33. On R5-Seattle, enable IPv6 and OSPFv3 by performing the following tasks.
R5-Seattle(config)# ipv6 unicast-routing
R5-Seattle(config)# ipv6 router ospf
R5-Seattle(config-ospf6-router)# area 0
R5-Seattle(config-ospf6-router)# area 3
R5-Seattle(config-ospf6-router)# interface e 1/1/1
R5-Seattle(config-if-e1000-1/1/1)# ipv6 ena
R5-Seattle(config-if-e1000-1/1/1)# ipv6 ospf area 0
R5-Seattle(config-if-e1000-1/1/1)# int e 1/1/11
R5-Seattle(config-if-e1000-1/1/11)# ipv6 ena
R5-Seattle(config-if-e1000-1/1/11)# ipv6 ospf area 0
34. On R5-Seattle, verify OSPFv3 neighbor adjacencies by issuing the show ipv6 ospf
neighbor command
R5-Seattle(config-if-e1000-1/1/11)# show ipv6 ospf neighbor
35. On R3-SanJose, enable IPv6, OSPFv3 and assign an IPv6 address to the loopback 1 interface by
performing the following tasks.
R3-SanJose(config-ospf-router)# ipv6 unicast
R3-SanJose(config-ospf-router)# ipv6 router ospf
R3-SanJose(config-ospf6-router)# area 0
R3-SanJose(config-ospf6-router)# int e 1/1/11
R3-SanJose(config-if-e1000-1/1/11)# ipv6 ena
R3-SanJose(config-if-e1000-1/1/11)# ipv6 ospf area 0
R3-SanJose(config-if-e1000-1/1/11)# int e 1/1/4
R3-SanJose(config-if-e1000-1/1/4)# ipv6 ena
R3-SanJose(config-if-e1000-1/1/4)# ipv6 ospf area 0
R3-SanJose(config-if-e1000-1/1/4)# int lo 1
R3-SanJose(config-lbif-1)# ipv6 address 2001:db10::/32
R3-SanJose(config-lbif-1)# ipv6 ospf area 0
31. Because link-local addresses are used on a single link or a non-routed network. They do not need to be
unique outside of that link.
37. On R3-SanJose, examine the OSPF link state database by issuing the show ipv6 ospf
database command.
38. On R3-SanJose, examine the OSPFv3 intra and inter area prefix LSAs within the link state
database
R3-SanJose(config-lbif-1)# show ipv6 ospf database inter-prefix
Area ID Type LSID Adv Rtr Seq(Hex) Age Cksum Len Sync
0 Inap 3 192.168.10.1 80000006 1152 1039 44 Yes
Metric: 1
Prefix Options:
Prefix: 2001:db9::/128
Area ID Type LSID Adv Rtr Seq(Hex) Age Cksum Len Sync
0 Inap 1 192.168.10.1 80000006 1152 1636 44 Yes
Metric: 1
Prefix Options:
Prefix: 2001:db8::/128
39. On R3-SanJose, ping one of the IPv6 addresses configured on R1-SaltLake to confirm
connectivity.
R3-SanJose(config-lbif-1)# end
R3-SanJose# ping ipv6 2001:db8::
Sending 1, 16-byte ICMPv6 Echo to 2001:db8::
timeout 5000 msec, Hop Limit 64
Type Control-c to abort
This ends Module 9 Lab C: OSPF Route Summarization and Area Types exercise.
Objectives
In this laboratory exercise, you will perform tasks related to configuring and verifying the operation of
Multi-Chassis Trunking.
• Configure Multi-Chassis Trunking on ICX switches
• Verify the operation of MCT using the ICX CLI
• Analyze switch logs during MCT failures
Utilizing the following CLI commands:
Commands Context Comment
cluster <name> <id> Global Configuration Creates an MCT cluster
rbridge-id <id> Cluster Configuration Defines the local RBridge ID
session-vlan <vlan-id> Cluster Configuration Defines the VLAN used for CCP
keep-alive-vlan <vlan-id> Cluster Configuration Defines the VLAN used for keep-alive
messages
member-vlan <vlan-id> Cluster Configuration Defines member VLAN to used in the cluster
icl <name> ethernet <if> Cluster Configuration Defines the interface to use for CCP
peer <ip> rbridge-id <id> icl Cluster Configuration Defines the MCT peer switch
<icl>
deploy Cluster Configuration Activates the cluster configuration
client <name> Cluster Configuration Creates an MCT client
rbridge-id <id> Cluster Client Defines MCT client RBridge ID
Configuration
client-interface ethernet Cluster Client Defines interfaces connecting to the MCT
<if> Configuration client
deploy Cluster Client Activates the client configuration
Configuration
RKUS-04 RKUS-04
RKUS-05 RKUS-05
RKUS-07 R7-MCT1
RKUS-08 R8-MCT2
Example:
ICX7450-24 Switch> enable
ICX7450-24 Switch# conf t
ICX7450-24 Switch(config)# hostname RKUS-04
RKUS-04(config)#
4. On RKUS-04 and RKUS-05 disable interfaces e1/1/1 to e1/1/24.
(config)# int eth 1/1/1 to 1/1/24
(config-mif-1/1/1-1/1/24)# disable
(config-mif-1/1/1-1/1/24)# interface eth 1/2/1 to 1/2/4
(config-mif-1/2/1-1/2/4)# disable
(config-mif-1/2/1-1/2/4)# interface m1
(config-if-mgmt-1)# disable
Note
Client Isolation Mode: Loose is the default on MCT cluster devices.
Check Point: Do not proceed unless all answers in the above step match the answer key at the bottom
of this page.
18. On R7-MCT1, execute the show cluster 1 client command.
What is the FSM-State of both cluster clients? ________________9
Why? ____________________________________________________10
19. On PC1, start a continuous ping to PC2 (10.10.200.200). Leave the PC1 window open.
C:\Documents and Settings\Administrator> ping 10.10.200.200 -t
Is the ping successful? ______11
Important
Do not continue unless the ping is successful in the above step.
1. 1
2. 150
3. Loose
4. 1.1.1.2
5. 2
6. ICL
7. CCP Down
8. ICL interface down
9. Master
10. MCT peer is not active. It has not been configured yet.
11. Yes
____________________________________________________________________13
Why did this occur:
____________________________________________________________________
____________________________________________________________________14
12. No
13. The ports configured as cluster-client edge ports (CCEP) have been disabled
14. When client isolation mode strict is configured, all CCEP ports are disabled when the ICL is down
Important
Do not continue unless the ping is successful in the above step.
15. Yes
16. CCP Up (was CCP Down in step 16)
17. Up
Note
A keepalive VLAN cannot be assigned to an actively deployed MCT cluster. The no deploy
command must be used prior to defining the keepalive VLAN, then the cluster must be
deployed again.
Important
Do not continue unless the ping is successful in the above step.
18. Yes
19. Master Peer Reachable
20. Slave
21. R7-MCT1 has a lower RBridge ID (1) than R8-MCT2 (2)