AIX Commands
AIX Commands
COMMAND bootlist PARAMETER -m normal <dev1> <dev2> -a -ad /dev/rnt<x> -b <loc of bootimage> cfgmgr Configures devices by running the programs in /etc/methods directory. Redirects the system console to device or file, effective next startup -l <device> -a<params> Changes a device's characteristics. Changes the display used by the low-function terminal (LFT subsystem. Changes the default font selected at boot time. -a size=+<blocks> /<FS> Users=x,y,z <grp name> -n <nlvname> <olvname> -s<no. pps> <ps name> Changes attributes of a file system. This one will increase the Filesystem . Changes attributes for groups. Rename logical volume from olvname to nlvname DESCRIPTION Alters the list of boot devices (or the ordering of these devices in the list available to the system) Create a boot image on the default boot device Create a boot image at location and send to tape
bosboot
chcons
chdev chdisp
chfont chfs
chgroup chlv
chps chpv
Changes attributes of a paging space. Changes the characteristics of a physical volume in a volume group.
chque
chssys chtcb
Changes a subsystem definition in the subsystem object class. Changes or queries the trusted computing base attribute of a file.
chtz. chuser chvfs chvg crfs -v <fstype> (jfs) -d <lvname> -m <mount point> -Ayes crfs -v <fstype> (jfs) -g <vgname> -a size=<no blocks> -m <mount point> -Ayes crvfs exportvg grpck hvirprt importvg -y <vgname> <hdisk x> lpstat lsallq lsallqdev None -n ALL rlogin=true <username>
Changes the system time zone information Changes attributes for the specified user. Changes entries in the /etc/vfs file. Sets the characteristics of a volume group. Create a Filesystem on a pre-defined logical volume( which will automount at boot!)
Creates entries in the /etc/vfs file. Export a volume group Verifies the correctness of a group definition. Changes the attribute values of a virtual printer. Import a Volume Group onto hdisk x
List print queues Lists the names of all configured queues. Lists all configured printer and plotter queue device names within a specified queue.
lsattr lscfg
-El <devname>
-v -l scsi* lsdev -Cc tape -Cc disk -C -s scsi -H lsdisp lsfont lsfs -l
List in detail List all scsi IO devices List configured tape devices List configured disks on devices List all defined scsi devices Lists the displays currently available on the system. Lists the fonts available for use by the display. List all filesystems in /etc/filesystems quering the LVM descriptor area and superblocks Displays the characteristics of file systems.
Displays the attributes of groups.(checks NIS aswell!) Lists the records in the /etc/inittab file. Lists the keyboard maps currently available to the lowfunction terminal (LFT subsystem. Displays the number of fixed licenses and the status of floating licensing.
lslicense
lslpp lslv
-l <lvname> -l <lvname>
List all installed software List configuration details of a given Logical Volume List further configuration details of a given disk Shows print service information stored in the database. List pagaing space
lsprtsv lsps
-ch -a
lspv
List configured disks List configuration details of a given disk List Logical Volumes/Filesystems on a given disk Displays the queue stanza name. Displays the device stanza name.
lsque lsquedev lssrc lsuser lsvfs lsvg None <vgname> -l <vgname> mkcatdefs mkdev mkfont mkfontdir mkgroup mkitab mklv -y <lvname> <vgname> <no of pps> mklv -a
List all subsystems Displays attributes of user accounts. Lists entries in the /etc/vfs file. List configured Volume groups List configuration details of a given Volume group List Logical Volumes/Filesystems on a given Volume Group Preprocesses a message source file. Adds a device to the system. Adds the font code associated with a display to the system. Creates a fonts.dir file from a directory of font files. Creates a new group. Makes records in the /etc/inittab file. Create a Logical Volume
mklvcopy mknamsv mknotify mkprtsv mkps mkque mkquedev mkserver mkssys mksysb.
Adds copies to a logical volume. Configures TCP/IP-based name service on a host for a client. Adds a notify method definition to the notify object class. Configures TCP/IP-based print service on a host. Add an additional paging space to the system. Adds a printer queue to the system. Adds a printer queue device to the system. Adds a subserver definition to the subserver object class. Adds a subsystem definition to the subsystem object class. Backs up mounted file systems in the rootvg volume group for subsequent reinstallation Records size of mounted file systems in the rootvg volume group for reinstallation Sets the required values for starting TCP/IP on a host. Creates a new user account. Customizes a new user account. -y <vgname> -s <ppsize> <hdisk x> Create a Volume Group on hdisk x
mkszfile.
Creates a volume group. Makes a virtual printer. Adds objects to created object classes.
odmchange
Changes the contents of a selected object in the specified object class. Produces the .c (source and .h (include files necessary for ODM application development and creates empty objectclasses. Deletes selected objects from a specified object class. Removes an object class. Retrieves objects from the specified object classes and places them into an odmadd input file. Displays an object class definition on the screen. Verifies the correctness of local authentication information. Redefines the set of physical volumes of the given volume group in the device configuration database. Removes physical volumes from a volume group. When all physical volumes are removed from the volume group, the volume group is deleted. Reorganizes the physical partition allocation for a volume group. Restores customized information from the boot image. Removes a delta from a Source Code Control System (SCCS file. Removes a device from the system. Removes folders and the messages they contain. Removes a file system. Removes a group. Removes records in the /etc/inittab file. Removes logical volumes from a volume group.
odmcreate
reducevg
reorgvg
restbase rmdel
Removes copies from a logical volume. Removes messages. Unconfigures TCP/IP-based name service on a host. Removes a notify method definition from the notify object class. Unconfigures a print service on a client or server machine. Removes a paging space from the system. Removes a printer queue from the system. Removes a printer or plotter queue device from the system. Removes a subserver definition from the subserver object class. Removes a subsystem definition from the subsystem object class. Removes a user account. Removes entries in the /etc/vfs file. Removes a virtual printer. Pipes the output data from the mkcatdefs command to the gencat command. Saves base customized device data in the ODM onto the boot device. -s <subsystem> -s <subsystem> Start a subsystem Stop a subsystem Synchronizes logical volume copies that are not current. Verifies the correctness of a user definition.
rmssys
savebase
<vgname>
<vgname>