%define prefix /usr
###############################################################################
Summary: CPPLapack library header files
Name: cpplapack
Version: 2005_03_25
Release: 1
Source: cpplapack-%{version}.tar.gz
#Patch:
Copyright: GPL
Group: Applications/Engineering
#Packager:
BuildArch: noarch
Buildroot: %{_tmppath}/%{name}-root
%package doc
Summary: Documentation of CPPLapack
Group: Applications/Engineering
%description
CPPLapack is a C++ matrix library designed as the class wrapper
for BLAS and LAPACK. Its special features are the followings.
[1]Hi-speed matrix calculations using BLAS and LAPACK
[2]User-friendly object-oriented interface in C++
[3]Source code compatibility between CPPLapack for single CPU
computing and CPPScaLapack for parallel computing
[4]Minimized number of deep copy operations using its own
Smart-Temporary system
Please visit http://cpplapack.sourceforge.net/ to check update
information and to obtain the latest version.
%description doc
This package contains the html documentation, sample Makefies,
test programs, and benchmark programs of CPPLapack.
Please visit http://cpplapack.sourceforge.net/ to check update
information and to obtain the latest version.
###############################################################################
%prep
rm -rf $RPM_BUILD_ROOT
%setup
%build
echo Nothing to make since CPPLapack is a set of header files.
%install
#### lib ####
mkdir -p $RPM_BUILD_ROOT/%{prefix}/include/cpplapack
cp -r include/* $RPM_BUILD_ROOT/%{prefix}/include/cpplapack
cat include/cpplapack.h\
| sed -e 's/\#include\ \"/\#include\ \"cpplapack\//g'\
> $RPM_BUILD_ROOT/%{prefix}/include/cpplapack/cpplapack.h
ln -s %{prefix}/include/cpplapack/cpplapack.h \
$RPM_BUILD_ROOT/%{prefix}/include/cpplapack.h
%clean
rm -rf $RPM_BUILD_ROOT
###############################################################################
%files
%defattr(-,root,root)
/usr/include/cpplapack
/usr/include/cpplapack.h
%files doc
%doc benchmark doc makefiles test