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Welcome to Tenable for ServiceNow

Tenable applications are designed to help customers who use ServiceNow with Tenable
Vulnerability Management, Tenable Security Center, or Tenable OT Security.

The Service Graph Connector for Tenable application integrates Tenable assets with the
ServiceNow Configuration Management Database (CMDB). Assets are imported into the CMDB
through ServiceNow's Identification Reconciliation Engine (IRE). This application, once configured,
allows you to bring Tenable asset data into ServiceNow as Cls and to push ServiceNow Cls to
Tenable Security Center and Tenable Vulnerability Management as assets.

The Tenable OT Security for VR application integrates Tenable vulnerability findings with the
ServiceNow Security Operations Vulnerability Response module. This application, once configured,
syncs all of Tenable OT Security vulnerability findings into ServiceNow Vulnerable Items (VI) and
Tenable Plugin details into ServiceNow Third-Party Vulnerabilities.

The Tenable for ITSM application integrates Tenable vulnerability findings into a custom table used
to create incidents from the vulnerabilities. This application, once configured, syncs all of Tenable
vulnerability findings into a custom vulnerabilities table and Tenable Plugin details into a second
custom table.

Tenable Assets Service Graph Connector (ServiceNow App) or
ServiceNow Connector for Tenable Exposure Management?

This document covers the standard Tenable integration with ServiceNow. Tenable also now offers
the ServiceNow Connector for use with Tenable Exposure Management.

The ServiceNow App allows you to sync assets bi-directionally between Tenable Vulnerability
Management (TVM) and Tenable Security Center (TSC). This allows you to create and update
configuration items (Cls) in ServiceNow as well as create/update assets (TVM) or asset lists (TSC).
Due to limitations in the TVM asset import API, when pushing to TVM the app only passes network

details and servicenow sys_id.

The ServiceNow Connector for Tenable Exposure Management leverages the entire Tenable
Exposure Management data model while the Tenable-provided ServiceNow Integration utilizes the
TVM data model. This provides a greater ability to map ServiceNow fields to Tenable Exposure
Management fields, and you can also use Tenable Exposure Management custom fields and tags.
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The ServiceNow Connector for Tenable Exposure Management is not bi-directional like the

ServiceNow App. While the Tenable Exposure Management connector is certainly more robust,

setup configuration is much more involved than the ServiceNow App with regard to importing assets

to Tenable.

For more information, refer to ServiceNow Connector and Connectors.

Application Dependencies

* Platform compatibility:

* Tenable Vulnerability Management, Tenable Security Center 5.7+, or Tenable OT

Security

ServiceNow Yokohama, Zurich

* Plugins required:

ITOM Discovery License - 1.0.0

ITOM Licensing - 1.0.0

CMDB CI Class Models - 1.76.0

Integration Commons for CMDB - 2.20.0

SGC Central -2.2.0

(Optional - Required when using Domain Separation ) Domain Separation
(Optional - Required for VR) ServiceNow Vulnerability Response - 23.0.0

(Optional - Required for ITSM) Incident - 1.0.0


https://docs.tenable.com/exposure-management/Content/connectors/servicenow-connector.htm
https://docs.tenable.com/exposure-management/Content/connectors/connectors.htm

Application Installation

Users with the System administrator(admin) role can install the application from the ServiceNow
Store.

Required User Role: Administrator

To install the application from the ServiceNow Store:

1.

2.

Go to https://store.servicenow.com

Search for the “Service Graph Connector for Tenable” app in the search tab.

Click Service Graph Connector for Tenable.

Click the Get button.

Enter the ServiceNow ID credentials of your ServiceNow account.

A success message appears.

Open the instance and navigate to System Applications > All Available Applications > All.
Find the application using the filter criteria and search bar.

Next to the application listing, click Install.

Post-Installation

You can create cross scope privilege records for Tenable for ITSM and “Tenable.ot for VR” apps

respectively if they are installed.

Steps to install the application from the ServiceNow Store:

1.

2.

Click the globe icon to set the Application Scope to Service Graph Connector for Tenable.
Click the search filter and type "sys_scope_privilege.list."

Click Enter.

Click the New button in the top-right corner.

The Cross scope privilege New record form appears.
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5. Create six records using values from the following table.

Target .
Target Name Operation Status

Scope

1 Tenable X_tsirm_tio_itsm__ Table Read Allowed
for ITSM vulnerability

2 Tenable TenablelTSMHelper Script Execute Allowed
for ITSM Include API

3 Tenable TenablelTSM Script Execute Allowed
for ITSM Include API

4 Tenable TenableITSMScheduleHel  Script Execute Allowed
for ITSM per Include API

5 Tenable.ot TenableVRScheduleHelp Script Execute Allowed
for VR er Include API

6 Tenable.ot TenableVRHelper Script Execute Allowed
for VR Include API

6. After creating the records, go to the Schedule Import record and click Execute.

Upgrade from 5.x Version Apps

If you use the Service Graph Connector for Tenable for Assets and Tenable Connector apps follow
the steps outlined here for upgrades to avoid any unexpected issues in the future. This process is
not intended for any other applications

Required User Role: Administrator
To upgrade the application from the ServiceNow:
Upgrade the previous Tenable for ITSM and Tenable.ot for VR

1. Log into the instance and navigate to System Applications > All Available Applications > All.

2. Find the application with the filter criteria and search bar.
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3. Next to the application listing, select the version to update.

4. Click Update.

Uninstall the previous Tenable Connector and Service Graph Connector for Tenable for
Assets app from your instance

1. Navigate to System Applications > All Available Applications > All.
2. Alist of applications installed in the instance is displayed.

3. Locate Tenable Connector and Service Graph Connector for Tenable for Assets, select it,
and under the related links, click Uninstall.

Update records created from the previous Tenable apps

1. Navigate to System definition > Scripts - Background.
2. Run the following scripts:

* Run the following script in global scope.

var cmdbGr = new GlideRecord("cmdb_ci");
cmdbGr.addQuery("discovery_source", "SG-TenableForAssets");
cmdbGr.query();
while(cmdbGr.next()) {
cmdbGr.discovery _source = "SG-Tenable";
cmdbGr.update();
}
var vrItemsGr = new GlideRecord("sn_vul vulnerable_item");
vrItemsGr.addQuery("source"”, "Tenable.ot");
vrItemsGr.query();
while(vrItemsGr.next()) {
vrItemsGr.source = "Tenable OT Security";
vrItemsGr.update();
}
var thirdPartyVrGr = new GlideRecord("sn_vul_third_party_entry");
thirdPartyVrGr.addQuery("source", "Tenable.ot");
thirdPartyVrGr.query();
while(thirdPartyVrGr.next()) {
thirdPartyVrGr.source = "Tenable OT Security";
thirdPartyVrGr.update();

Note: This script is to clean the cmdb_ci, vulnerable item and vulnerability entry table records
specific to Tenable.
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* Run the folllowing script in x_tsirm_tio_itsm scope.

var itsmVulTvmGr = new GlideRecord("x_tsirm_tio_itsm_vulnerability");
itsmVulTvmGr.addQuery("source", "Tenable.io");
itsmVulTvmGr.query();
while(itsmVulTvmGr.next()) {
itsmVulTvmGr.source = "Tenable Vulnerability Management";
itsmVulTvmGr.update();
}
var itsmVulTscGr = new GlideRecord("x_tsirm_tio_itsm_vulnerability");
itsmVulTscGr.addQuery("source", "Tenable.sc");
itsmVulTscGr.query();
while(itsmVulTscGr.next()) {
itsmVulTscGr.source = "Tenable Security Center";
itsmVulTscGr.update();

}

var itsmPluginTvmGr = new GlideRecord("x_tsirm_tio_itsm_plugin");
itsmPluginTvmGr.addQuery("source", "Tenable.io");
itsmPluginTvmGr.query();
while(itsmPluginTvmGr.next()) {
itsmPluginTvmGr.source = "Tenable Vulnerability Management";
itsmPluginTvmGr.update();
}
var itsmPluginTscGr = new GlideRecord("x_tsirm_tio_itsm_plugin");
itsmPluginTscGr.addQuery("source", "Tenable.sc");
itsmPluginTscGr.query();
while(itsmPluginTscGr.next()) {
itsmPluginTscGr.source = "Tenable Security Center";
itsmPluginTscGr.update();

| Note: This script is to clean the Tenable Vulnerability and Tenable Plugin table.

* Run the folllowing script in x_tsirm_tio_vr scope.

var vrAdditionalFindingsGr = new GlideRecord("x_tsirm_tio_vr_ve_info");
vrAdditionalFindingsGr.addQuery("source", "Tenable.ot");
vrAdditionalFindingsGr.query();
while(vrAdditionalFindingsGr.next()) {
vrAdditionalFindingsGr.source = "Tenable OT Security";
vrAdditionalFindingsGr.update();

| Note: This script is to clean the Tenable Plugin Additional Info table.




User Setup

You can assign users with role privileges according to your needs. Roles are specified according to

domain separated instances and non-domain separated instances.

Note: The x_tsirm_tio_now.import_set_admin role is used to access import set tables across all the
tenable apps. Tenable does NOT recommend to give this role to any user.

User Permissions For Non-Domain Separated Instances

User Role

System admin

Administrator

Tenable canvas_user
Application

Admin

cmdb_inst_admin
connection_admin
X_tsirm_tio_
itsm.admin
X_tsirm_tio_
now.admin
X_tsirm_tio_vr.admin

Permission

Installation of the
integration application
plugins

User Creation
Application Log
Create the Connection
Alias

Create the connector
Configuration
Configure Scheduled Job
Resources

Process Monitor
Support

Create the connector
Configuration

Configure Scheduled Job
Resources

Process Monitor

Support

-10 -

Description

This user-role is
the admin of the
ServiceNow
Instance and has
privileges to
perform all the
integration-
specific actions.

This user-role is
the admin of the
application and is
allowed to create
the connector,
update the
configuration, and
configure the
scheduled job.



Tenable
Application User

canvas_user
cmdb_inst_admin
X_tsirm_tio_itsm.user
X_tsirm_tio_now.user
X_tsirm_tio_vr.user

O

Read access of

configuration

Read access to

Connectors, scheduled

job

S

Support

User Permissions For Domain Separated Instances

User

System
Administrator

Tenable
Application
Admin

(6] )

admin
X_tsirm_tio

now.domain_separation_

admin

canvas_user
cmdb_inst_admin
connection_admin
X_tsirm_tio_itsm.admin
X_tsirm_tio_

now.domain_separation_

admin
X_tsirm_tio_vr.admin
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Permission

Installation of the
integration application
plugins

User Creation
Application Log
Create the Connection
Alias

Create the connector
Configuration
Configure Scheduled
Job

Resources

Process Monitor
Support

Create the connector
Configuration
Configure Scheduled
Job

Resources

Process Monitor
Support

This user-role is
limited to read-
only
configurations.
These users are
not able to create
or update any
configurations.

Description

This user-role is
the admin of the
ServiceNow
Instance and has
privileges to
perform all the
integration-
specific actions.

This user-role is
the admin of the
application and is
allowed to create
the connector,
update the
configuration, and
configure the



Tenable
Application User

canvas_user
cmdb_inst_admin
X_tsirm_tio_itsm.user
X_tsirm_tio_now.user
X_tsirm_tio vr.user
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Read access of
configuration
Read access to
Connectors,
scheduled jobs
Support

scheduled job.

This user-role is
limited to read-
only
configurations.
These users are
not able to create
or update any
configurations.



Create a User

You can assign create the various Tenable user roles in the ServiceNow platform.

Required User Role: Administrator

User Permissions For Non-Domain Separated Instances

Username (example) Role

admin canvas_user
cmdb_inst_admin
connection_admin
X_tsirm_tio_itsm.admin
X_tsirm_tio_now.domain_separation_admin
X_tsirm_tio_vr.admin

To create a Tenable user and assign the role to it:
1. Navigate to Organization > Users.
2. Click the Users module.
The Users list appears.
3. Click New.

A New User form appears.

4. Fill in the form.

Note: The values for User ID title, and email address shown in the following table are example J

values.

Field Description

User ID The unique user ID for the role in your ServiceNow Platform instance.
(For example, "tenable_admin")

First Name The first name of this user.

-13-
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11.

12.

13.

14.

15.

O

Last Name The last name of this user.
Title Job title, or role, of this user. (For example, "Tenable admin")
Password The unique password created for this role.
Email The unique email address for this user.
Click Submit.

| Note: Once the New User form is submitted, you can assign the role.

In the Users list in the User ID column, click the name of the new user you created.

The new user record appears and the Set Password user interface is visible in the form view
of the record.

. Click the Set Password user interface action.

A new pop-up appears.

. Click Generate.

| Note: This generates a unique password for the created user that must be changed upon first login.

Copy and safely store the generated password.

Close the pop-up.

In the Users list in the User ID column, click the name of the new user you created.
In the Roles section, and click Edit.

Add the roles in the Collection field of the Edit Member form.

In the Collection column, select roles mentioned in the User Permissions For Domain

Separated Instances table and move them to the Roles List.

Click Save.

-14 -



Create a Connection Alias

You can create a connection alias with a guided setup.
Required User Role: Administrator

To create a connection alias:
1. Log in to your ServiceNow instance.

2. Navigate to Tenable Connector for Assets > Guided Setup.
3. Select the setup type.

Service Graph Connector For Tenable

Service Graph Connector for Tenable imports assets information from tenable to ServiceNow Configuration Management Database (CMDB)

Pick the type of setup you wish to configure Qmpthis e
. . . handy to ease the setup
You can always add configurations later and change your selection
process

In Progress £ 2024-10-21

Quick Start

Just the right configurations r " 2

t:; get :olfprésﬂclt z;ﬁg

4. Click Continue.

5. Inthe Prerequisite page, select the Update the max length of credential field tab and follow

the steps in the user interface.

-15-



< Prerequisite v

Update the max ... Update the max length for credential field Mzndatory

System Administrator role required for this step. Contact to System Administrator to change the length of dictionary field.
« Follow the steps to update the length of user_name in order to store the api key.
1. Open the user_name record
2. Switch to the 'Global’ scope.
3. Update the max length value to 255.

4. Save the record and switch back to the 'Service Graph Connector for Tenable’ scope.

Make sure to complete the task before checking 'Mark as complete' to proceed

= TV & DictionaryEntries View: Advanced |sys_dictionary | Table | name - l Search
Y @ & [ Actions on selected rows... | x vlm?

All > Table starts with discovery_credentials > Column name starts withuser_name

0o« Table « Column name Type Reference Default value Display Textindex
name element internal_type reference default_value display text_
[discoverv credenti l [user name I { Search I [ Search l l Search l { Search I {Search

["] Mark as complete

6. Check the Mark as Complete checkbox.

7. Click Continue.

8. Select the Configure Authentication Information tab and follow the steps in the user interface.

-16 -
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< Configure the Connection and Credentials ~

Configure Authe... Configure Authentication Information Mandatory
&8 Test Connection®

& Configure Tenabl...

Prerequisite: Make the application scope as “Service Graph Connector for Tenable®.

Steps:

1. Click Here [This will navigate the user to the connection page].
2. Select the approriate connection alias record.

3. Click on the Edit button.
4. Fill out all of the required fields.
5. Click on the Edit Connection button.

Make sure to complete the task before checking 'Mark as complete' to proceed

[J Mark as complete

9. Check the Mark as Complete checkbox.

10. Click Continue.

11. Select the Test Connection tab and follow the steps in the user interface.

-17 -

Cancel
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< Configure the Connection and Credentials ~

v Configure Authe... Test Connection Mandatory
Test Connection”
& Configure Tenabl... e Choose tenable connector record for which you want to test the connection. ¥ ’

» Activate the connector and update the record.
e Open the same record and click on the Test Connection button.

Make sure to complete the task before checking 'Mark as complete’ to proceed

= ¥ B TenableConnectors |x_tsirm_tic_now_tenable_connector | Name | name ~ | Search ]

@ & [Actionsonselectedrows...lx VI?

All
0 a Name Active Connection Alias Healthy Updated -
name active connection_alias healthy sys_updated_on
Search } [ Search ] [ Search ] { Search ] [ Search }
Tenable Operational ) ) ) 2024-10-21
Technology true x_tsirm_tio_now.Tenable_Operational_Tech... true
04:00:56
Connector
n 210~
Eil:matzlrecsoe:ix)r true x_tsirm_tio_now.Tenable_Security_Center true £25 B_],ﬁ et

T s ™

] Mark as complete

12. To fetch assets from Tenable, select the Configure Tenable Schedule Import tab and follow
the steps in the user interface.

< Configure the Connection and Credentials v

v Configure Authe... Configure Tenable Scheduled Import to fetch assets from Tenable Mandatory

v Test Connection”

Configure Tenabl... s Open exisiting tenable record that you have configured. Make sure connector is in healthy state. «
e Configure scheduled import from related list to fetch assets on a scheduled basis.

Make sure to complete the task before checking 'Mark as complete’ to proceed

V¥ 3 Tenable Connectors | x_tsirm_tic_now_tenable_connector | Name | name ~ | Search ]

& & [ Actions on selected rows... | x V} m?

All
Name « Active Connection Alias Healthy Updated -
O <
name active connection_alias healthy sys_updated_on
Search } I Search I I Search l [ Search l I Search
Tenable Operational
Technology true X_tsirm_tio_now.Tenable_Operational_Tech... true 2024-10-21
c 04:00:56
onnector
Tenable Security - . N 2024-10-21
BT AT true X_tsirm_tio_now.Tenable_Security_Center true 03:58:34
Tenable Vulnerability 2024-10-21

[] Mark as complete

-18-
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13. Check the Mark as Complete checkbox.

14. Click Continue.

Add Multiple Instances (Optional)
1. Navigate to Tenable Connector for Assets > Add Multiple Instances

2. Select the Add Another Connections tab and follow the steps in the user interface.

< Add Multiple Instances v Close
Activities ~
@ nProgress priort
& Add Another Connections. Test New Connections

@ Test New Connections
create new connector record and test the connection.

@& Configure Tenable Scheduled Import ...

PR prowrer— ..,

= ¥ & TenableConnectors Name = | Search
All
O « Name « Active Service Graph Connection Healthy Updated
Search Search Search ‘ ‘ Search Search
Tenable Operational Technology Connectar true ® false 2025-07-2123:08:48
Tenable Security Center Cons ® false true 2025-07-18 04:49-07
Tenable Vulnerability Management Connector true true 2025-07-2123:08:47

o]

£

1to30f3

3. Check the Mark as Complete checkbox.

4. Click Continue.

5. Select the Test New Connections tab and follow the steps in the user interface.
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< Add Multiple Instances

v Add Another Con...
Test New Conne...

& Configure Tenabl...

Test New Connections Mandatory

e create new connector record and test the connection.

Make sure to complete the task before checking 'Mark as complete’ to proceed

All
ame « ctive onnection Alias ealthy at
0 a N Acti C ion Ali Health Updated -
name active connection_alias healthy sys_updated_on
Search ] [ Search [ Search ] [ Search ] {Search ]
Tenable Operational
Technology true %_tsirm_tio_now.Tenable_Operational_Tech... true 2024-10-21
C 04:00:56
onnector
Tenable Security . . . 2024-10-21
Center Connector true x_tsirm_tio_now.Tenable_Security_Center true 03:58:34
Tenable Vulnerability
Management true ¥_tsirm_tio_now.Tenable_Vulnerability_Ma... true ggzqi%g 2

Y & Tenable Connectors | x_tsirm_tic_now_tenable_connector | Name | name

- | Search

l

& & [ Actions on selected rows... | x v] m?

[C] Mark as complete

Check the Mark as Complete checkbox.

Click Continue.

Cancel

To fetch assets from Tenable, select the Configure Tenable Schedule Import tab and follow

the steps in the user interface.

-20-



< Add Multiple Instances ~

v Add Another Con... Configure Tenable Scheduled Import to fetch assets from Tenable Mandatory
v Test New Conne...

. »
Conftgure Tenabl... s Open exisiting tenable record that you have configured. Make sure connector is in healthy state. v
s Configure scheduled import from related list to fetch assets on a scheduled basis.

Make sure to complete the task before checking 'Mark as complete’ to proceed

= ¥ & TenableConnectors|x_tsirm_tio_now_tenable_ccnnector | Name | name - | Search ]

@ & [ Actions on selected rows... | x VIm?

All
0o a Name « Active Connection Alias Healthy Updated -
name active connection_alias healthy sys_updated_on
Search I I Search ] [ Search ] [ Search l ' Search
Tenable Operational
Technology true %_tsirm_tio_now.Tenable_QOperational_Tech.. true xz(;)isgn
Connector :00:
Tenable Security . . . 2024-10-21
o e true %_tsirm_tio_now.Tenable_Security_Center true 03:58:34
Tenable Vulnerability 2004-10-21

[T Mark as complete

9. Check the Mark as Complete checkbox.

10. Click Continue.

Map Custom Aliases to the Connector (Optional)

Caution: When you create a new alias for your API keys, you may miss the step of mapping this alias to the
Connector. This results in the connector defaulting to the wrong alias, causing connection failures and an
"Unhealthy" connector status. The procedure to correct this scenario is in the following subsection.

If you have created a new Connection & Credential Alias (instead of using the default), you must
manually map it to the Connector.

To map your custom alias to the connector:
1. Navigate to Connectors.
2. Select the relevant Tenable connector.

3. Locate the Service Graph Connection field.

s

Click the lookup icon.

a1

. Select your newly created Connection Alias.

-21-



6. Click Update.

The changes are saved.

_22.



SGC Central Guided Setup

You can create a connection alias with a guided setup.

Required User Role: Administrator

To configure default connections

1. Navigate to Workspaces > CMDB Workspace > SGC Central.

Servicen()w Al Favorites History Workspaces ~ Admin CMDB Workspace ;

Home My Work CMDB 360 Insights Management SGC Central

& Overview All connections

I &3 All connections
. Installed ( Drafts
& Explore connector

| IntegrationHub ETL Review the details of installed connections to verify correct configuration.

@ Settin

Installed connections |3
Last refreshed just now

Connection Connector type Connection status Processing status Import Schedule Last run on
‘enable Vulnerability Management Tenable Success Pending Active
enable Security Cente Tenable Success Pending Active
enable Opera al Technolo Tenable Error Pending Active
Showing 1-3 of 3 1

2. Click All Connections.
View the installed connections list here.

3. Update the existing record.

Note: If the existing setup is in-progress, click the Drafts tab, resume your setup of "Tenable," and
follow the same steps for configuring multi-instance as shown in the following multi-instance setup
section.

4. Click any of the connections..

5. Provide the URL, access key, and secret key.

-23-
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Home My Work CMDB 360 Insights Management

SGCCentral > Tenable Vulnerability Management

Tenable Vulnerability Management

Connection Name %

Tenable Vulnerability Management Connection

Connection URL %

https:/cloud.tenable.com

Access Key Xk

Connector type  Lastrunon  Connectionstate  Processing state  Parent import schedule
Tenable - Success Pending Active
Details Data sources Import schedules Errors

Details

SGC Central

access key

Secret Key %

sssssssssssssssssssne

Use MID Server

Update and test connection

6. Click Update and test connection

Once the connection test is completed, a Connection verified success message appears.

7. View the details of data sources by clicking the Data sources tab.

SGC Central > Tenable Vulnerability Management

Tenable Vulnerability Management

C tortype Lastrunon or Processing stal arent impart sched:
Tenable - Success Pending

Data sources [4

Data Source Type Format
SG-Tenable TVM - 3 File JSON
SG-Tenable TVM - 2 File JSON
SG-Tenable TVM - 4 F JSON
SG-Tenable TVM - 1 File JSON

Showing 1-4 of 4

8. To execute the scheduler, click the Import Schedules tab.

Multi-Instance:

1. Navigate to All Connections.

2. Click Create connection.

Updated

2025-07-20 23:25:34
2025-07-20 23:25:34
2025-07-20 23:25:34

2025-07-20 23:25:34

|

_24 -
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10.

11.

12.

Select Tenable.

Click Create connection.

Note: As mentioned in the steps, perform the Prerequisite step of updating the max length of the
credential field.(If already updated then Click on “Mark as Complete”).

Select the connection alias.

Click Continue.

Provide the connection name, URL, and tokens.
Click on the “Create and test connection” button.

A success message appears.

| Note: While creating connection, if you get a "Save credential failed" alert, you can ignore it.

Review the four schedule data imports.

Click Continue.

SGCCentral >  Create Tenable cannection

Create Connection For Te.. VV & ~ © In Progress * Priority

(@) Prereuisies Configure import schedule
Complete

- Update the max length for Set up scheduled jobs to import data at regular intervals. Vierify that all parent import schedules are active before continuing.
credential field

Configure the Connection a... . —
O o4 Import schedules 4 (=]
» ( Select 5G connection alias Lt Feirashed st mow
~ template
- N > Scheduled Data Import Parent & Run Data source Active Updated
® @ Configure and test connection

Parent: (4) Sh ]
= @ Configure import schedule o ) S

® Confirm connection setup 5G-Tenable TOT - 4 (empty) Periodically $G-Tenable TOT - 4 true 2024-08-16 04:48:26
S5G-Tenable TOT - 2 (empty) Periodically SG-Tenable TOT - 2 true 2024-08-16 04:46:39
@ Create and Configure the Te...
Pending SG-Tenable TOT - 1 (empty) Periodically $G-Tenable TOT - 1 true 2024-08-16 04:43:46
SG-Tenable TOT - 3 (empty) Periodically S$G-Tenable TOT - 3 true 2024-08-16 04:47:08
Showing 1-1 of 1 E] 20~ rows per group

Continue

Navigate to the Confirm Connection tab and click View All Connections to see all the added
connections.

To create the Tenable Connector, navigate to the Next module and click New for the
previously created SG Connection Record.
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13. Provide the required configuration details.

SGCCentral > Create Tenable connection

© In Progress ® Priority

Create Connection ForTe.. V' i ~
Create and Configure the Tenable connector

Prerequisites .
Complete + Choose tenabie connector record for which you want to test the connection or Create new connector record
+ Select appropriate tenable SG Connection
@ Uuda(e‘tr:ern:zx length for « Activate the connector and update the record,

credential field + Open the same record and cick on the Test Connection button

Configure the Connection a...

274 .
= ¥V & TenableConnectors Name = | Search @ & Actions on selected rows...
» () Select SG connection alias
" template Al
® (&) Configure and test connection 1 Name « Active Service Graph Connection Healthy Updated
© Configure import schedule Search Search Search I ‘ Search Search
© Confirm connection setup Tenable Operational Technology Connector true Tenable Operational Technology ® fakse 2025-07-2123:08:48
Tenable Security Center Connector ® false Tenable Security Center true 2025-07-18 04:49:07
Create and Configure the Te...
° . ¢ oo A Tenable Vulnerability Management Connector true Tenable Vulnerability Management true 2025-07-2123:08:47
<
Create and Configure the l =
Tenable connector
& Configure Tenable Scheduled
= Import to fetch assets from...
1 to3of3 o

Mark as complete Skip

14. Click Test Connection.

15. Create a Tenable Schedule Import Job by opening the Connector Record.
16. Click New.

17. Provide the required configuration details.

18. Click Execute Now to collect data manually.

19. Click Mark as Complete.
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Create Connection For Te.. 7 ¢

Prerequisites
Complete

Update the max length for
credential field
Canfigure the Connection a...

24

) Select SG connection alias
template

® (©) Configure and test connection
(& Configure import schedule

@ Confirm connection setup

Create and Configure the Te...

. 172

° Create and Configure the

“ Tenable connector

-0 Configure Tenable Scheduled
Import to fetch assets from...

A~

O

@ In Progress

Configure Tenable Scheduled Import to fetch assets from Tenable

+ Open exisiting tenable record that you have configured. Make sure connector is in healthy state.
« Configure scheduled import from related list to fetch assets on a scheduled basis.

. Tenable Connector
"~ Tenable Operational Technology Connector
Active [

Scheduled Job Run As | System Administrator Q

_
Asset Settings | [TSM Settings ‘ VR Settings

8 0 & B 3 O ¢ @ =
Healthy

* Priarity

S ... [

Logging Level | Errors Only (Recommended)

Pull Asset Chunk Size 1500 Push Asset Record Limit 10,000
e o
[SN Utils] Versions (01
—_—
Tenable Scheduled Imports (2) | Tenable Jobs (2)
= V¥V fortext - Is:ar:h @ & — | Actionson selected rows..
Connector = Tenable Operational Technology Connector
. Name Active Tenable Product Tenable Application
Tenable Operational Technology Connector - Pull Plugins true tat r
Tenable O gy Connector - Pull abilitics true tot vr
1 to2of2
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Manage Connections

Required User Role: Administrator

You can create or update existing connections and test the connection. The Connections module
helps you to manage and monitor connections between various system components.

Key fields in this module include:

Name Description

Name The unique identifier for each connection.

Active Indicates whether the connection is currently active or inactive.
Connection An alternative name or identifier used to reference the connection.

Alias

Message Contains relevant information or notifications related to the connection.
Status The current state of the connection, such as success, pending, or failed.
Status Code The response status code returned from the API call for the using the

connection credentials.

Suggestion Recommendations or actions to address any issues.
Application The application scope in which the connection is created.
Updated The date and time when the connection record was last modified.

The Status field indicates the operational state of a connection and can have the following values:

Name Description

Success The connection is operating normally and is successfully transmitting data or
performing its intended functions.

Error There is an issue with the connection, which may be affecting its performance or
preventing it from functioning as expected.

To manage the connector:
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1. Log in to your ServiceNow instance.

2. Navigate to Tenable Connector for Assets > Connectors.
The Tenable Connector appears.

3. Click New or select an existing connection to update.

Service Graph Connections remain in sync with their associated Tenable connectors. When you
click Test Connection, the status is updated there, and all connectors that use this connection as
their Service Graph Connection are marked as healthy or unhealthy based on the outcome of the
test connection. Similarly, if you perform the Test Connection action from a Tenable connector, the
result of that test is also reflected there, and the status is updated accordingly
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Create the Connector

You can create several required and optional connections for Tenable products.

Required User Role: Administrator

Connector Configuration Options Matrix

Tenable Product Module Job Type
Tenable OT Asset Pull Assets
S ity (ICP

ecurity (ICP) VR Pull Plugins

Pull Vulnerabilities

Tenable Security Asset Pull Assets
Center Push Assets
ITSM Pull Vulnerabilities
SGC for Tenable Pull Queries
Tenable Asset Pull Assets
Vulnerability Push Assets
M nt
anageme ITSM Pull Vulnerabilities

To create the connector:
1. Log in to your ServiceNow instance.
2. Navigate to Tenable Connector for Assets > Connectors.
The Tenable Connector appears.
3. Click New.

A New User form appears:
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— Tenable Connector ¢ © = - m
— Newrecord View: TenableStandard™ -

I Choose Connection Alias same as Tenable product.

e | )

= Tenable Product [ -~ None - VI
* Connection Alias ‘ | Q l
Active Healthy
Scheduled Job Run As \ | Q | LoggingLevel | Errors Only (Recommended) VI
Asset Settings | VR Settings | ITSM Settings
Pull Asset Chunk Size { 1500 Push Asset Record 10.000
Limit

4. Inthe Name field, type the name of the connector.

5. From the Tenable Product drop-down box, select Tenable Vulnerability Management,
Tenable Security Center, or Tenable OT Security (ICP).

6. Choose the Service Graph Connection for the selected Tenable Product.

7. Continue to the Optional Connections, or click Submit.

Optional Connections

1. Navigate to Tenable Connector for Assets > Add Multiple Instances.
2. Check the Mark as Complete checkbox.

3. (Optional) In the Scheduled Job Run As box, type the username of the user with which you
want to import data.

4. (Optional) Choose Logging Level from the dropdown box.

| Note:Tenable recommends to use the Errors Only level.

5. (Optional) In the Asset Settings tab:
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Asset Settings | VR Settings | ITSM Settings

Pull Asset Chunk Size 1.500 Push Asset Record [ 10,000
Limit ’

Description
Pull Asset The number of records that are pulled per page. Used for 1500
Chunk Size the Pull Assets job type.
Push Asset The total records that are pushed on the platform atonce. 10000

Record Limit Used for the Push Assets job type.

| Note: The VR Settings and ITSM Settings tabs are visible only if plugins are activated.

6. (Optional) In the VR Settings tab:

Asset Settings | VR Settings | ITSM Settings

TOT Vulnerability | 200 TOT Plugin Chunk 200

Chunk Size - ’ Size

__ Default
Description

Value
TOT The number of Vulnerabilities that are pulled per page. 200 (also
Vulnerability Used for TOT Pull Vulnerabilities job type. max limit)
Chunk Size
Push Asset The total records that are pushed on the platform at 10000
Record Limit once. Used for the Push Assets job type.

7. (Optional) In the ITSM Settings tab:

Asset Settings | VR Settings | 1TSM Settings

TSC Vulnerabiliy | 1500 TVM Vudnerability 50
Chunk Size Asset Chunk Size
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Name Description Default Value
TSC The number of 1500
Vulnerability vulnerabilities that will be
Chunk Size: pulled per page. Used for
TSC Pull Vulnerabilities
job type.
TVM The number of assets for 50
Vulnerability which all of their
Asset Chunk vulnerabilities will be e e rTOt _to
change the default value of this field.
Size pulled. Used for TVM Pull

Increasing the value also increases the
Vulnerabilities job type. amount of data pulled at once. This may
create an issue while reading that data.

8. Click Submit.
Next steps:

e Configure Tenable Vulnerability Management.

e Configure Tenable Security Center.

e Configure Tenable OT Security.
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Configure Tenable Vulnerability Management

Required User Role: Administrator

To configure Tenable Vulnerability Management in ServiceNow:
1. Log in to your ServiceNow instance.
2. Navigate to Tenable Connector for Assets > Connectors.
The Tenable Connector appears.

3. Navigate to your already existing connector whose Tenable product is Tenable Vulnerability
Management.

4. From the Module drop-down box, you can select Asset or ITSM.

I Note: By default, the connector’'s name is populated.

Note: For the Asset Module, you can select the Pull Assets or Push Assets Tenable Job Type. For
the ITSM Module, you can select Pull Vulnerabilities as the Tenable Job Type.

Asset Module, Tenable Job Type > Pull Assets

The Pull Assets Schedule Job fetches the assets from Tenable Vulnerability Management to
ServiceNow and stores the asset details in the CMDB Tables (Incomplete IP Identified Device,
Unclassed Hardware, Computer, Network Adaptor, IP Address) and the Custom table
(Tenable Asset Attributes).

_ Default
Description
Value

Active If selected, the scheduled job runs on the configured Disabled

schedule.
Initial Run - The amount of time (in days) of how far back you wantto ~ Within the
Historical pull data. last 365
Data days
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Last Run The date and time that the import was last run. N/A
Edit Run Select this box if you want to configure the scheduled job  If selected,
Schedule run configuration. The following options must be Daily is the
configured: default
value.

Note:Make sure not to set the run frequency too high, as
this can result in congested jobs and create performance
issues.

* Run: The frequency that you want the import to
run. Possible values are: Daily, Weekly, Monthly,
Periodically, Once, On Demand, Business
Calendar: Entry Start, or Business Calendar: Entry
End.

* Repeat Interval/Time: Set the time (hh/mm/ss) to
run the import. This differs based on the Run
selection.

Asset Module, Tenable Job Type > Push Assets

The Push Assets Scheduled Job pushes the assets from ServiceNow to Tenable

Vulnerability Management.

_ Default
Description
Value

Active If selected, the scheduled job runs on the configured Disabled

schedule.
Initial Run - The amount of time (in days) of how far back you want to Within the
Historical pull data. last 365
Data days
Last Run The date and time that the import was last run. N/A
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5.

Edit Run Select this box if you want to configure the scheduled job
Schedule run configuration. The following options must be
configured:

Note: Make sure not to set the run frequency too high, as
this can result in congested jobs and create performance
issues.

* Run: The frequency that you want the import to
run. Possible values are: Daily, Weekly, Monthly,
Periodically, Once, On Demand, Business
Calendar: Entry Start, or Business Calendar: Entry
End.

* Repeat Interval/Time: Set the time (hh/mm/ss) to
run the import. This differs based on the Run
selection.

If enabled,
Daily is the
default
value.

In the Conditions > Configuration Item Source Table dropdown, select the table on which you
want the query to run in order to export the assets to Tenable Vulnerability Management.

In the Conditions > Conditions dropdown, apply the filter conditions on the Configuration

Item Source Table that you have selected.

If you selected the ITSM Module, configure the following parameters:

ITSM Module, Tenable Job Type > Pull Vulnerabilities

The Pull Vulnerabilities Schedule Job fetches the vulnerabilities from Tenable Vulnerability
Management to ServiceNow and stores the vulnerabilities in the Custom table (Tenable

Vulnerability).

Name Description Default Value

Active If selected, the scheduled job runs on the Disabled

configured schedule.

Initial Run - The amount of time (in days) of how far back Within the last 365

-36 -



O

Historical
Data

Last Run

Last Run -
Fixed

Run Fixed
Query on
Initial Run

Included
Severities

Edit Run
Schedule

you want to pull data.

The date and time that the import was last run.

The date and time that the fixed import was last
run. The integration fetches the vulnerabilities
from this data and time.

Pulls fixed vulnerabilities on the first import.

Specify the severities for the vulnerabilities
being imported.

Select this box if you want to configure the
scheduled job run configuration. The following
options must be configured:

Note: Make sure not to set the run frequency too
high, as this can result in congested jobs and
create performance issues.

* Run: The frequency that you want the
import to run. Possible values are: Daily,
Weekly, Monthly, Periodically, Once, On
Demand, Business Calendar: Entry Start,
or Business Calendar: Entry End.

* Repeat Interval/Time: Set the time
(hh/mm/ss) to run the import. This differs
based on the Run selection.
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N/A

N/A

Disabled

By default, the value
is empty and only
vulnerabilities with
high and critical
severities are
fetched.

If selected, Daily is
the default value.
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Note: The Name text box is automatically populated based on the name of the connector and Job
Type.

8. Click Submit.
Next steps:

* Go to Test Configuration.

ServiceNow ITSM Pro Incident Rule Fields

The ServiceNOW integration with Tenable Vulnerability Management produces incident rule fields
and pushes the following asset attributes to ServiceNow ITSM Pro.

Incident Rule Fields and Asset Attributes

Label Name

cvssV4Supplemental u_cvssv4supplemental
seolDate u_seoldate

epssScore u_epssscore
recastRiskRuleComment u_recastriskrulecomment
acceptRiskRuleComment u_acceptriskrulecomment
hostUUID u_hostuuid

acrScore u_acrscore

Agent UUID u_agent_uuid

First Found u_first_found

IPs u_ips

Operating System u_operating_system
Plugin Modification Date u_plugin_modification_date
Priority u_priority
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Label Name
Scan u_scan

severity_maodification_type u_severity _modification_type

XREF

Description
indexed

Netbios Name
Plugin Family Type
Port Port
risk_accepted
severity_default_id
VPR Context
Configuration Item
Hostname

Last Found Date
Plugin Description
Plugin Synopsis
Repository ID

SC Unique
Tenable Plugin ID
FQDN

last_fixed

pluginName
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u_xref

u_description
u_indexed
u_netbios_name
u_plugin_family_type
u_port_port
u_risk_accepted
u_severity_default_id
u_vprcontext

u_ci

u_hostname
u_last_found_date
u_plugin_description
u_plugin_synopsis
u_repository_id
u_scunique
u_tenable_plugin
u_fqdn

u_last_fixed

u_pluginname



O
Label Name

Plugin Publication Date u_plugin_publication_date
Reopened u_reopened

Scan Started At u_scan_started_at

State u_state

vulnUniqueness u_vulnuniqueness
vulnUUID u_vulnuuid

Incident Rule Fields and Asset Attributes (cont'd)

Label Name

cvssV4BaseScore u_cvssv4dbasescore
cgiScanEnabled u_cgiscanenabled
keyDrivers u_keydrivers
assetExposureScore u_assetexposurescore
thoroughScanEnabled u_thoroughscanenabled
paranoidScanEnabled u_paranoidscanenabled
finding_id u_finding_id

BIOS UUID u_bios_uuid
hasBeenMitigated u_hasbeenmitigated
Last Found u_last_found

Plugin CVE u_plugin_cve

Plugin Solution u_plugin_solution
Repository Data Format u_repository_data_format
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Label Name

Scan UUID
Substate

Asset Hostname
First Found Date
Job Type

Output

Plugin Name
Product Type
Scan Completed At
Source Name
Device Type

IP
operatingSystem
Plugin ID

Port Protocol
Risk Recasted
Severity ID

VPR Score
source
Connector
hostUniqueness

MAC Address

O
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u_scan_uuid
u_substate
u_asset_hostname
u_first_found date
u_job_type
u_output
u_plugin_name

u_product_type

u_scan_completed_at

u_source_name
u_device_type
u_ip
u_operatingsystem
u_plugin_id
u_port_protocol
u_risk_recasted
u_severity_id
u_vpr_score
u_source
u_connector
u_hostuniqueness

u_mac_address



Label Name

Plugin Family

Port

Repository Name
Severity
uniqueness
attachment
cvssV4Vector
cvssV4ThreatScore

cvssV4ThreatVector

O
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Configure Tenable Security Center

Required User Role: Administrator

To configure Tenable Security Center in ServiceNow:
1. Log in to your ServiceNow instance.
2. Navigate to Tenable Connector for Assets > Connectors.
The Tenable Connector appears.

3. Navigate to your already existing connector whose Tenable product is Tenable Security
Center.

4. From the Module drop-down box, you can select Asset, ITSM, or SGC for Tenable.

I Note: By default, the connector’'s name is populated.

Note: For the Asset Module, you can select the Pull Assets or Push Assets Tenable Job Type. For
the ITSM Module, you can select Pull Vulnerabilities as the Tenable Job Type.

Asset Module, Tenable Job Type > Pull Assets

The Pull Assets Schedule Job fetches the assets from Tenable Security Center to
ServiceNow and stores the asset details in the CMDB Tables (Incomplete IP Identified Device,
Unclassed Hardware, Computer, Network Adaptor, IP Address) and the Custom table
(Tenable Asset Attributes).

Default
Value

Description

TSC Query The selected filter is used to pull vulnerabilities or assets Disabled
from Tenable Security Center.

Active If selected, the scheduled job runs on the configured Disabled
schedule.
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Initial Run - The amount of time (in days) of how far back you wantto ~ Within the

Historical pull data. last 365

Data days

Last Run The date and time that the import was last run. N/A

Edit Run Select this box if you want to configure the scheduled job  If selected,

Schedule run configuration. The following options must be Daily is the
configured: default

value.

Note: Make sure not to set the run frequency too high, as
this can result in congested jobs and create performance
issues.

* Run: The frequency that you want the import to
run. Possible values are: Daily, Weekly, Monthly,
Periodically, Once, On Demand, Business
Calendar: Entry Start, or Business Calendar: Entry
End.

* Repeat Interval/Time: Set the time (hh/mm/ss) to
run the import. This differs based on the Run
selection.

Asset Module, Tenable Job Type > Push Assets

The Push Assets Scheduled Job pushes the assets from ServiceNow to Tenable Security
Center. In Tenable Security Center, the data is pushed in the group that you specify when

creating the schedule job. A new group is created on the platform, if the specified one is not
already present.

_ Default
Description
Value
Active If selected, the scheduled job runs on the configured Disabled
schedule.
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Historical
Data

Last Run

Edit Run
Schedule

O

The amount of time (in days) of how far back you want to
pull data.

The date and time that the import was last run.

Select this box if you want to configure the scheduled job
run configuration. The following options must be
configured:

Note: Make sure not to set the run frequency too high, as
this can result in congested jobs and create performance
issues.

* Run: The frequency that you want the import to
run. Possible values are: Daily, Weekly, Monthly,
Periodically, Once, On Demand, Business
Calendar: Entry Start, or Business Calendar: Entry
End.

* Repeat Interval/Time: Set the time (hh/mm/ss) to
run the import. This differs based on the Run
selection.

Within the
last 365
days

N/A

If enabled,
Daily is the
default
value.

. In the Conditions > Configuration Item Source Table dropdown, select the table on which you

want the query to run in order to export the assets to Tenable Security Center.

Note: By default, this value is set to cmdb_ci. For the group type Static IP Address, the
Configuration Item Source Table should be the parent table of "CMDB CI IP Address."

. In the Conditions > Group Name text box, enter the name of the group.

Note: This named group is created in Tenable Security Center while pushing the assets records. You
can identify these records based on the group name on the platform.

. In Conditions > Group Type dropdown, select DNS or Static IP Address, based on which

type of data you would like to push.
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Note: For Static IP Address, you need to set the IP Version and IP’s To Send options. Only unique
IP addresses are stored on the Tenable Security Center. However, in the Tenable job’s Total Record
field, you may see more records than the number actually stored on the platform. This discrepancy
occurs because the job does not check for uniqueness, whereas the platform does. The scheduled
job first retrieves the record from the selected table, then checks the parent-child relationship in the
cmdb_rel_ci table. If the relationship is not satisfied, the IP is not pushed to the platform. If the
relationship is satisfied, the child IP is pushed to the platform.

8. Inthe Conditions > Conditions dropdown, apply the filter conditions on the Configuration ltem
Source Table that you have selected.

9. If you selected the ITSM Module, configure the following parameters:
ITSM Module, Tenable Job Type > Pull Vulnerabilities

The Pull Vulnerabilities Schedule Job fetches the vulnerabilities from Tenable Security
Center to ServiceNow and stores the vulnerabilities in the Custom table (Tenable
Vulnerability).

Default
Value

Description

TSC Query The selected filter is used to pull vulnerabilities or assets Disabled
from Tenable Security Center.

Active If selected, the scheduled job runs on the configured Disabled
schedule.
Initial Run - The amount of time (in days) of how far back you wantto ~ Within the
Historical pull data. last 365
Data days
Last Run The date and time that the import was last run. N/A
Last Run - The date and time that the fixed import was last run. The N/A
Fixed integration fetches the vulnerabilities from this data and
time.
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Query on
Initial Run

Edit Run
Schedule
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| Note: This field is for the Fixed job mode.

Pulls fixed vulnerabilities on the first import.

Select this box if you want to configure the scheduled job
run configuration. The following options must be
configured:

Note: Make sure not to set the run frequency too high, as
this can result in congested jobs and create performance
issues.

* Run: The frequency that you want the import to
run. Possible values are: Daily, Weekly, Monthly,
Periodically, Once, On Demand, Business
Calendar: Entry Start, or Business Calendar: Entry
End.

* Repeat Interval/Time: Set the time (hh/mm/ss) to
run the import. This differs based on the Run
selection.

Disabled

If selected,
Daily is the
default
value.

Note: The Name text box is automatically populated based on the name of the connector and Job

Type.

10. Click Submit.

Next steps:

* Go to Test Configuration.
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Configure Tenable OT Security

Required User Role: Administrator

To configure Tenable OT Security in ServiceNow:
1. Log in to your ServiceNow instance.
2. Navigate to Tenable Connector for Assets > Connectors.
The Tenable Connector appears.
3. Navigate to your already existing connector whose Tenable product is Tenable OT Security.

4. From the Module drop-down box, you can select Asset or VR.

| Note: By default, the connector’'s name is populated.

Note: For the Asset Module, you can select the Pull Assets Tenable Job Type. For the VR Module,
you can select the Pull Vulnerabilities as the Tenable Job Type. The Pull Plugins Tenable Job
Type is automatically created by the Pull Vulnerabilities job.

Asset Module, Tenable Job Type > Pull Assets

The Pull Assets Schedule Job fetches the assets from Tenable OT Security to ServiceNow
and stores the asset details in the CMDB Tables (IP Address, Network Adapter, OT Control
Systems, Incomplete IP Identified Device, Operational Technology (OT), Network Gear,
Industrial Sensors) and the Custom table (Tenable Asset Attributes).

_ Default
Description
Value

Active If selected, the scheduled job runs on the configured Disabled

schedule.
Initial Run - The amount of time (in days) of how far back you wantto ~ Within the
Historical pull data. last 365
Data days
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Last Run The date and time that the import was last run. N/A
Edit Run Select this box if you want to configure the scheduled job  If selected,
Schedule run configuration. The following options must be Daily is the
configured: default
value.

Note:Make sure not to set the run frequency too high, as
this can result in congested jobs and create performance
issues.

* Run: The frequency that you want the import to
run. Possible values are: Daily, Weekly, Monthly,
Periodically, Once, On Demand, Business
Calendar: Entry Start, or Business Calendar: Entry
End.

* Repeat Interval/Time: Set the time (hh/mm/ss) to
run the import. This differs based on the Run
selection.

If you selected the VR Module, configure the following parameters:

| Note: This module is only be visible if the "Tenable.ot for VR" integration is installed.

VR Module, Tenable Job Type > Pull Plugins

The Pull Plugins Schedule Job fetches the assets from Tenable OT Security to ServiceNow
and stores the plugin details in the Custom table (Plugin Import and Tenable Plugin Additional
Info).

I Note: This Scheduled job is automatically created when the Pull Vulnerabilities job is created.

Default
Value

Description

Active If selected, the scheduled job runs on the configured Disabled
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Initial Run -
Historical
Data

Last Run

Last Run -
Fixed

Run Fixed
Query on
Initial Run

Edit Run
Schedule

schedule.

The amount of time (in days) of how far back you want to
pull data.

The date and time that the import was last run.

The date and time that the fixed import was last run. The
integration fetches the vulnerabilities from this data and
time.

l Note: This field is for the Fixed job mode.

Pulls fixed vulnerabilities on the first import.

Select this box if you want to configure the scheduled job
run configuration. The following options must be
configured:

Note: Make sure not to set the run frequency too high, as
this can result in congested jobs and create performance
issues.

* Run: The frequency that you want the import to
run. Possible values are: Daily, Weekly, Monthly,
Periodically, Once, On Demand, Business
Calendar: Entry Start, or Business Calendar: Entry
End.

* Repeat Interval/Time: Set the time (hh/mm/ss) to
run the import. This differs based on the Run
selection.

VR Module, Tenable Job Type > Pull Vulnerabilities
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The Pull Vulnerabilities Schedule Job fetches the vulnerabilities from Tenable OT Security to

ServiceNow and stores the vulnerabilities in the ServiceNow able Vulnerable Item.

Active

Initial Run -
Historical
Data

Last Run

Last Run -
Fixed

Run Fixed
Query on
Initial Run

Edit Run
Schedule

_ Default
Description
Value
If selected, the scheduled job runs on the configured Disabled
schedule.

The amount of time (in days) of how far back you wantto ~ Within the

pull data. last 365
days
The date and time that the import was last run. N/A

The date and time that the fixed import was last run. The N/A
integration fetches the vulnerabilities from this data and
time.

I Note: This field is for the Fixed job mode.

Pulls fixed vulnerabilities on the first import. Disabled

Select this box if you want to configure the scheduled job  If selected,

run configuration. The following options must be Daily is the
configured: default
value.

Note: Make sure not to set the run frequency too high, as
this can result in congested jobs and create performance
issues.

* Run: The frequency that you want the import to
run. Possible values are: Daily, Weekly, Monthly,
Periodically, Once, On Demand, Business
Calendar: Entry Start, or Business Calendar: Entry
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* Repeat Interval/Time: Set the time (hh/mm/ss) to
run the import. This differs based on the Run
selection.

Note: The Name text box is automatically populated based on the name of the connector and Job
Type.

6. Click Submit.
Next steps:

* Go to Test Configuration.
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Test the Configuration

The ServiceNow MID Server application facilitates communication and movement of data between
the platform and external applications, data sources, and services. There can be several MID
servers in an environment with some dedicated for development and testing, and others dedicated
to production.

Configuration checks:

* If your Tenable Security Center resides behind a firewall on your internal network, you must
use the MID server to access its data.

* For Tenable Operational Technology MID Server is mandatory.
* Review the MID server section in the ServiceNow documentation.

* Ensure your system meets the MID server system requirements, as described in the MID
Server System requirements in the ServiceNow documentation.
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FAQ

Why am | unable to install an application from the ServiceNow
Store?

1. Verify you have the system administrator (admin) role.
2. Navigate to System Applications > All Available Applications > All.

3. Verify the application appears under the Installed tab.

How can | create a new user?

* Perform the steps the steps in User Administration.

Why am | getting an error related to ECC Queue timeout?

1. Navigate to sys_properties.LIST.
2. Update the following system properties with given values:
a. glide.http.outbound.max_timeout.enabled = false
b. glide.http.outbound.max_timeout.enabled = false
c. glide.http.outbound.max_timeout = 60 (or increase the time as per requirement)

3. Run the scheduled script again.

Why am | unable to Create the Connection Alias?

* Verify you have the system administrator (admin) role.

Why am | Unable to Create the Connector?

1. Verify you have the system administrator (admin) role or Application Admin role.

Why is the Connector unhealthy?
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1. Check the credentials and the endpoint of the Connection Alias. Make sure nottoadd a ‘/’
after the endpoint.

2. (For TSC and TOT) Verify that the MID is running. (Mandatory for TOT)

Why am | unable to see options in the Tenable Scheduled Import
Form view?

1. Clear cache from your browser or create the Scheduled Import Job from Incognito.
2. Clear cache from your ServiceNow instance:
a. Login to your ServiceNow instance.

b. Type “cache.do” in the filters tab.

servicenow

Y cache.do|

FAVORITES

No Results

ALL RESULTS

No Results

c. Click Enter
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d. On the following page click Clear Cache.

Servlet Memory
Max memory: 1980.0
Allocated: 1980.0

In use: 1695.0

Free percentage: 14.0

After Cache Flush

Servlet Memory
Max memory: 1980.0
Allocated: 1980.0

In use: 1264.0

Free percentage: 36.0

Clear Cache

Why are Jobs not created after executing the scheduled job?

1. Create missing cross scope privilege records manually:

a. Set Application scope to Service Graph Connector for Tenable from here:

Application scope: ServiceGraph Connector for Tenable A
Update set: Default [ServiceGraph Connector for Tenable]

(&

< Application scope: ServiceGr...

Y Filter

RECENT SELECTIONS

ServiceGraph Connector forTe... ./

Tenable for ITSM

b. Click Filter and type "sys_scope_privilege.list".
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servicenow

Y Filter

c. Click Enter

d. Click the New button in the top-right corner.
@& & Actions onselectedrows..|x v | m

The form below appears:

= (Crossscope privik ~ N
Y R— ‘o--E3
Source Scope| source_scope  ServiceGraph Connector for Tenable Application| sys_scope  ServiceGraph Connector for Tenable Cl
+ Target Scope | t | Q ‘ % Operation tion | Read|resd v

Status | status | Requested | requested

+ TargetName

4 TargetType | target_type | Table  sys_db object v

e. Create six records with following values.

Target Operatio

Target Name Status

Type n

1 Tenable X_tsirm_tio_itsm_ Table Read Allowed
for ITSM vulnerability
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2 Tenable TenablelTSMHelper Script Execute Allowed
for ITSM Include  API

3 Tenable TenablelITSM Script Execute Allowed
for ITSM Include API

4 Tenable TenablelI TSMScheduleH  Script Execute Allowed
for ITSM elper Include  API

5 Tenable. TenableVRScheduleHel Script Execute Allowed
ot for VR per Include  API

6 Tenable. TenableVRHelper Script Execute Allowed
ot for VR Include  API

f. Go to Schedule Import record and click Execute.
2. Check if all the threads are occupied.
a. Navigate to the User Administration > All Active transaction.
b. Confirm that all threads are occupied. If yes, then remove the unused threads.

c. Reload the Scheduled Data import form.

Why is the integration failing and/or data not being ingested into the
table?
1. Check the connector’s configuration and make sure it is healthy.

2. Make sure the user has proper roles. Refer to this page to see what role users should have on
Tenable platforms.

3. Check the Application Logs.
4. Ifthe error is related to API calls made, follow these steps:

a. Enable the following three system properties from the sys_properties table (you can
type “sys_properties.LIST” in the Filters section) and then run the integration again:
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* glide.outbound_http_log.override -> Set value to “true”,
e glide.outbound_http_log.override.level -> Set value to “all”
* glide.outbound_http.content.max_limit -> Set value to “1000”

b. Check the HTTP requests in the Outbound HTTP Requests module under System
Logs which contains details of request and response of API calls.

Y Outbound HTTP Reque &

FAVORITES

No Results

ALL RESULTS

v System Logs

Outbound HTTP Requests

Why am | getting a "Request method or request URL not found from
undefined” error?

1. Navigate to the Flow Designer > Actions.

2. Open the Rest step and check the execution. It might be an error from the API.

3. Run scheduled job again.
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| got an "Exception: SyntaxError: Empty JSON string” while pulling
data using an import job and then increasing the file size. What do |
do?

1. Confirm that you have the system administrator (admin) role.

2. Navigate to sys_properties.

3. Increase the value of the com.glide.attachment.max_get_size and
com.glide.attachment.max_size. Enter the value in bytes.

Note:if the property does not exist then create a new one in Global Scope. (For example, values can
be: com.glide.attachment.max_get size = 31457280 and com.glide.attachment.max_size
= 4096)

Why am | unable to validate the MID server?

1. Navigate to MID Server > MID Security Policy.

2. Open Intranet and Internet Records and uncheck Certificate Chain Check , Hostname
Check and Revocation Check checkboxes.

How can | activate/deactivate data sources for ITSM or VR?

1. Setthe Application scope to ServiceGraph Connector for Tenable from here:

Application scope: ServiceGraph Connector for Tenable A
Update set: Default [ServiceGraph Connector for Tenable]

24

'

< Application scope: ServiceGr...

Y Filter
RECENT SELECTIONS

ServiceGraph Connector forTe... .~
Tenable for ITSM
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2. Click Filter.

servicenow Al

Y Filter

3. Type "x_tsirm_tio_now_data_source_registry.list".
4. Click Enter.

5. After applying the appropriate filters, in the Active column set the value of that record.

How can | see Tenable Asset Attributes in the related list of Asset
records?

1. Click the Additional Actions button in the top-left corner of the Asset record.

2. Goto Configure > Related Lists.
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=

O

ip_address [scratchpad][table fields][toggle label]

‘ Update

Related
Subscrib

DNSN

= Y

IP 2ddress =9.9.9.9

Save
Insert
tess | 9.9.9.9
Insert and Stay
Configure b Form Design V]
Export Form Layout
View » Related Lists
Create Favorite All
Copy URL Table
Copy sys_id Security Rules
Show XML Business Rules
History > Client Scripts
Reload form Ul Policies
Data Policies
DNSName | cndp_3| ' Actions bns name | dns_nam ~ | Search
Notifications
Dictionary

Q Dns name

dns_name

3. Select the Tenable Asset Attributes option and push it to the Selected list.
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Avzilable Selected

Filter choices... | DNS Name | cmdb_ip_address_dns_name.ip_addr ~
TETS RO ZECY Sy S IS OO IOU TS SUUEE FU LS CMDEB 360 Data | REL:49f2ce4e73001010a642¢
Task->Configurationitem | task.cmdb_ci O Hardware->Configuration Item | alm_hardware.c

TCP Endpoint->Duplicate Of | emdb_ci_endpoint_tc IP Address->Owned By Configuration Item | cmd
Teams | cmdb._rel_team.ci Tenable Asset Attributes->Related Cl
Technical Service->Duplicate Of | cmdb_ci_service_

Telco equipment holder [DEPRECATED]-»Duplicat:
Telco equipment->Duplicate Of | cmdb_ci_ni_telco_

Tenable Vulnerability->Configuration item | x_tsirm > »
Therzpeutic Device-»Duplicate Of | emdb_ci_med_t
<]

Tibco Adapter->Duplicate Of | cmdb_ci_appl_tibco_
Tibco BW Endpoint->Duplicate Of | emdb_ci_endpc
Tibco BW process->Duplicate Of | cmdb_ci_endpoit
Tibco Conf File Endpoint-»Duplicate Of | emdb_ci_e
Tibco Enterprise Message Service->Duplicate Of | ¢
Tibco File Listener Endpoint->Duplicate Of | cmd b_.
Tibco Hawk Endpoint->Duplicate Of | emdb_ci_end
Tibco Hawk->Duplicate Of | cmdb_ci_appl_tibco_ha _
Ticket->Canf o ik i

View name: .
Defaultview W

4. Click Save.

5. Now you can see the Tenable Asset Attributes related list in the asset.

In Xanadu, why does the integration redirect to a step of another
section when clicking "Mark as Complete” in the guided setup?

* This is currently a known issue in Xanadu. For more details on this issue check the
ServiceNow community page.

If the existing connection records do not display on SG Connection
Module Table view, after upgrading the application:
1. Navigate to All > Fix Scripts.

2. Open the fix script record titled Tenable - Create SG Connections.

3. Click Run Fix Script.
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4. After execution, review the records in the SGC Connection table.

5. Existing records are now displayed over the SG Connection Module.

The Firmware Installation table is displaying duplicate entries for the
same Configuration Item (ClI):

* This duplication occurred because ServiceNow generates two different Source Native Keys for
the same Cl record, resulting in the creation of multiple entries.

While configuring a Connection record from the SGC Central
module, if the process gets stuck or the page becomes
unresponsive:

* Refresh the page and restart the configuration steps from the beginning.

In the Zurich release, once a user completes a Guided Setup, the
configuration steps cannot be modified or restarted:

* To address this limitation, ServiceNow introduced SGC Central (post-Zurich) as a replacement
for the Guided Setup. With SGC Central Workspace, users can now create and configure new
connections more flexibly.

* For detailed instructions on using SGC Central, refer to SGC Central Guided Setup.
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